Jump to content
TheF3nt0n

Adding a new emergency vehicle is possible now.

Recommended Posts

Is it possible to just add police lights and siren to any vehicle? Without adding a new vehicle?

Wait my friend Wait, the plugin of zmodeler is coming...

Share this post


Link to post
Share on other sites

Anyone know what siren setting used for the tow trucks and Boxville? 10 (Lifeguard Granger) works, but makes vehicles give-way and adds tail light flashers. What is the correct one to use?

Share this post


Link to post
Share on other sites

I am pretty sure It's tow truck siren lights setting located at:

<sirenSettings value="9"

I am going to update the tutorial, If I got a time.

Edited by TheF3nt0n

Share this post


Link to post
Share on other sites

Alright. Thanks. Gonna test it now.

 

Edit: 9 works. It's the correct setting for the Boxville, and most likely the tow trucks as well.

Edited by Småen

Share this post


Link to post
Share on other sites

And if i want to change only the siren sound, for example:

I Want just the police3 with policeb siren sound? Is that possible?

Can't change just the siren, it's all sounds at once.

Share this post


Link to post
Share on other sites

I am pretty sure It's tow truck siren lights setting located at:

<sirenSettings value="9"

I am going to update the tutorial, If I got a time.

PLEAS UPDATE THE TUTORIAL, and doe a better steps. 

EXAM:

1.- For add new vehicle first: Enter in the file *******

2.- ADD THE Models and textures

3.- COPY THE FILES OF THE DLC ****** AND ADD IN ****

 

I Very new in the modding, and i dont now what files and location 

Share this post


Link to post
Share on other sites

I will do it, Please wait.

 

EDIT: Edited, Check the first page.

I am having difficulty having my vehicles have interior textures despite adding the lines to vehicles.meta. What would be the cause of this? Is there a particular order I need to do these things?

Share this post


Link to post
Share on other sites

1,) You cannot add the new added vehicles on specified section of dispatch.meta

 

Alright this is most annoying thing on adding new emergency vehicles as If you add a Police SUV and put the name on SWAT_SUV section, It will spawns empty, No cops drive it, It just wandering around like a normal car, I don't know if this is hardcored or it still can be edited on a file or native script.

 

This also does not work on new added Ambulance or Fire truck too, They're still spawns with driver and passengers but it does not reports to fire or dead bodies, I don't know why but I'd recommend not to add the new vehicles to those sections of dispatch.meta

Not true. I have added multiple custom vehicles to dispatch.meta. Police cars and a fire department Granger. All of them work just fine without problems.    

SAHP Buffalo spawning as Sheriff car (SAHP1)

  • Spawns and act like normal police car

LSSD Buffalo spawning as Sheriff car (sheriffbuf)

  • Spawns and act like normal police car

LSPD Granger spawning as police cruiser and SWAT(lspdsuv)

  • Spawns and act like normal police car and spawns and act like normal SWAT SUV when supposed to.

LSFD Granger Spawning as Fire Truck (lsfdgranger)

  • Spawns with fire men hanging from the sides. Works like normal fire truck.

 

I have one SUV (noosesuv) that fails to spawn people inside. But I think I may and done some other mistake with this particular vehicles, as the textures are weird as well for this vehicle. 

Edited by Småen

Share this post


Link to post
Share on other sites

Thank you for this post. It has helped me a lot. I am adding the LSPD Granger into the game and I have it it working. It spawns, it has sound, interior, light &  sirens. The only issue I am having is that every time the vehicle hits an object in game, my game crashes. Any ideas on what that could be?

Thanks,

 

 


R. Sereda

Winnipeg, Manitoba, Canada

Share this post


Link to post
Share on other sites

@Smaen, Could you test your LSPD granger on SWAT_SUV section of dispatch.meta?

		<Vehicle>
			<Name>SWAT_SUV</Name>
			<ConditionalVehicleSets>
				<Item>
					<ZoneType>VEHICLE_RESPONSE_ARMY_BASE</ZoneType>
					<VehicleModels>
						<Vehicle>crusader</Vehicle>
					</VehicleModels>
					<PedModels>
						<Ped>S_M_Y_Marine_03</Ped> 
					</PedModels>
				</Item>
				<Item>
					<ZoneType>VEHICLE_RESPONSE_COUNTRYSIDE</ZoneType>
					<VehicleModels>
						<Vehicle>sheriff2</Vehicle>
					</VehicleModels>
					<PedModels>
						<Ped>S_M_Y_Swat_01</Ped> 
					</PedModels>
				</Item>
				<Item>
					<VehicleModels>
						<Vehicle>lspdsuv</Vehicle>
					</VehicleModels>
					<PedModels>
						<Ped>S_M_Y_Swat_01</Ped>
					</PedModels>
				</Item>
			</ConditionalVehicleSets>
		</Vehicle>

Let me know if you got it working or not, If you got it working, I will delete that note for sure.

Share this post


Link to post
Share on other sites

@Smaen, Could you test your LSPD granger on SWAT_SUV section of dispatch.meta?

Let me know if you got it working or not, If you got it working, I will delete that note for sure.

I'm on my phone right now, so I can't say for sure, but I think that is what I set it to. 

 

Share this post


Link to post
Share on other sites

Looks strange to me, For me it just spawns empty without any driver and passengers or sometimes does not spawns at all.

I will check later when I get home from work. I don't know why it doesn't work for you.  I have both police cars and a fire emergency vehicle spawning with people and giving chase/putting out fire.

I didn't do anything specialto mak it work either.

Share this post


Link to post
Share on other sites

Wait a second, I am talking about specified section of dispatch.meta, SWAT_SUV section is extremely bugged if you put one of any added car on it's section, No SWAT members drive it and it behaves like a ghost car, Then, I decided not to put them on "SWATAutomobile", Another section of dispatch.meta is working fine, No other problems aside from SWATAutomobile.

Share this post


Link to post
Share on other sites

Wait a second, I am talking about specified section of dispatch.meta, SWAT_SUV section is extremely bugged if you put one of any added car on it's section, No SWAT members drive it and it behaves like a ghost car, Then, I decided not to put them on "SWATAutomobile", Another section of dispatch.meta is working fine, No other problems aside from SWATAutomobile.

Pretty sure I have a LSPD Granger responding as SWAT I'm going to check when I get home.

I have a LSFD Granger working as fire engine. So that I can say for sure is working.

Share this post


Link to post
Share on other sites

Wait a second, I am talking about specified section of dispatch.meta, SWAT_SUV section is extremely bugged if you put one of any added car on it's section, No SWAT members drive it and it behaves like a ghost car, Then, I decided not to put them on "SWATAutomobile", Another section of dispatch.meta is working fine, No other problems aside from SWATAutomobile.

It's not the vehicle set that's causing the issue. it's the dispatch type. These have to be controlled in some other file we can't yet access, and SWATAutomobile must have specific models defined elsewhere, crusader, fbi2 and sheriff2, and those are the only ones that will work. But setting them as a PoliceAutomobile type works fine (though the Grangers only hold two doing it that way).

Share this post


Link to post
Share on other sites

Alright, just checked my game and I was wrong. I had set my LSPD Grangers to spawn as police cars as well as SWAT, so I never noticed they were not working as intended. My LSFD Granger responds just fine with firemen hanging of the sides, but they will in normal circumstances not exit and do their job. I never really payed any attentions to what they did.

So I admit, I was wrong.   

Share this post


Link to post
Share on other sites

Is there any way to specify a secondary color for vehicles in carcols? Because alaik you can only configure the primary color.

I'd assume one of the four values would control that, just not sure which is which.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...