Jump to content
TheHC09

I have found the ELS siren strings! 100% WORKING!

Recommended Posts

Moderator notice: Your title has been edited.  Please do not make thread titles all caps.

 

http://i.imgur.com/I0B5P1Y.png

This topic has been moved to the appropriate forum. Please post in the correct location in the future.

Share this post


Link to post
Share on other sites

Hmm...sooo i kinda get it?lol...So my main siren for police4 does not work only the secondary; how do I go about this sir?

Share this post


Link to post
Share on other sites

@TheHC09 Holy shit you're a savior, I've been wanting to know these hashes in a long time! THANKS!

Edited by YoshePlays

Share this post


Link to post
Share on other sites

Think there's any possibility of creating a sirens.awc and having just siren tones in it (probably more than are allotted for vanilla sirens) rather than putting them in the vehicles.awc? Doing so might also get around the change in pitch that you get with the FIB siren

Edited by willrs

Share this post


Link to post
Share on other sites
6 minutes ago, officer 21 said:

SO HOW DO YOU MAKE THIS WORK AS THEY DONT WORK WHEN ADDED TO ELS

 

CHEERS

 

2 minutes ago, TheSandwichStealer said:

I don't know if this means anything, but you can try asking someone on the RDE discord for help. They know about ELS.

 

For example, this is for my ems related vehicles:

83nV1G3.png

and for my fire related vehicles:

066b57V.png

 

Edited by YoshePlays

Share this post


Link to post
Share on other sites
5 minutes ago, YoshePlays said:

HI

 

is this added straight in the xml file for the els cars??
 

 as the vehicle rfp don't have EXample Wail 01 as a file name

Share this post


Link to post
Share on other sites
2 minutes ago, officer 21 said:

 

is this added straight in the xml file for the els cars??
 

 as the vehicle rfp don't have EXample Wail 01 as a file name

 

yes.

Share this post


Link to post
Share on other sites
2 hours ago, YoshePlays said:

 

 

For example, this is for my ems related vehicles:

83nV1G3.png

and for my fire related vehicles:

066b57V.png

 

 

What did you name the sound files to in order to work?  I renamed the audio files I wanted for firetruck to the same thing you have in the VCF, but it still uses my default tones for police.

 

Does it actually work for you?  Having fire sirens for firetruck and police sirens for police?

Share this post


Link to post
Share on other sites
5 hours ago, willrs said:

Think there's any possibility of creating a sirens.awc and having just siren tones in it (probably more than are allotted for vanilla sirens) rather than putting them in the vehicles.awc? Doing so might also get around the change in pitch that you get with the FIB siren

I believe the strings are set within the game engine and so that wouldn’t be possible. I did think this at first too but was proved wrong by putting in the updated OpenIV main LSPD siren strings and them not working.

1 hour ago, Giordano said:

 

What did you name the sound files to in order to work?  I renamed the audio files I wanted for firetruck to the same thing you have in the VCF, but it still uses my default tones for police.

 

Does it actually work for you?  Having fire sirens for firetruck and police sirens for police?

I would ensure you have got a brand new copy of the vehicles.oac with the updated string names and then input the ones I have listed into the VCF. You can mix and match tones, there are pretty much no limits.

6 hours ago, flackolc said:

Hmm...sooo i kinda get it?lol...So my main siren for police4 does not work only the secondary; how do I go about this sir?

Are they working properly now?

3 hours ago, officer 21 said:

thank you for the hand

much appreciated

Working for you now?

Share this post


Link to post
Share on other sites
2 hours ago, Giordano said:

 

What did you name the sound files to in order to work?  I renamed the audio files I wanted for firetruck to the same thing you have in the VCF, but it still uses my default tones for police.

 

Does it actually work for you?  Having fire sirens for firetruck and police sirens for police?

 

mhm

FIRE:

 

EMS:

 

PD/HP:

 
Edited by YoshePlays

Share this post


Link to post
Share on other sites

Does anybody have the Hash codes to replace these with modded sirens? Have been attempting for weeks to get the PA2000SM Rumbler from Modern Siren Pack to work, but it either reverts back to the base game siren or the modded siren i had previously.

Share this post


Link to post
Share on other sites
1 minute ago, WHSD said:

Does anybody have the Hash codes to replace these with modded sirens? Have been attempting for weeks to get the PA2000SM Rumbler from Modern Siren Pack to work, but it either reverts back to the base game siren or the modded siren i had previously.

 

0x0EA58C7C - Generic Bullhorn   

 

0x013F5FE7 - PoliceB Main    
0x17DDFB5C - PoliceB Secondary

 

0x0A8960B6 - FIB Primary   
0x0A49B203 - FIB Secondary 

 

0x0D329446 - Police Primary  
SIREN_2 - Police Secondary   
POLICE_WARNING 

AMBULANCE_WARNING  

 

0x0E0DA7BC - Granger Primary  
0x16E74B3E - Granger Secondary  

 

0x1C98C4D5 - Ambulance Primary 
0x144C8602 - Ambulance Secondary 


0x14BFBCE3- Fire Horn 
0x159C9182 - Fire Primary 
0x161768E7 - Fire Secondary 

Edited by YoshePlays

Share this post


Link to post
Share on other sites

If this is from Lundy's post from 2015, those hashes don't seem to work (for me at least) for some reason. Have replaced both FIB sirens with the Rumbler i want, and still get in game sirens.

Is there some sort of limit set for the audio files to play?

Share this post


Link to post
Share on other sites
Just now, WHSD said:

If this is from Lundy's post from 2015, those hashes don't seem to work (for me at least) for some reason. Have replaced both FIB sirens with the Rumbler i want, and still get in game sirens.

Is there some sort of limit set for the audio files to play?

 

Are you sure you've replaced them in the mods folder? Did you edit the .xml files for the FIB hashes? They do work, you have it installed wrongly.

Share this post


Link to post
Share on other sites

I have installed and re-re-installed in the mods folder. However, i will double and triple check.

I should because i did a full re-install of everything in my game and 'favorite' marked the locations in OpenIV.

Share this post


Link to post
Share on other sites
1 minute ago, WHSD said:

I have installed and re-re-installed in the mods folder. However, i will double and triple check.

I should because i did a full re-install of everything in my game and 'favorite' marked the locations in OpenIV.

 

Make sure the you put RESIDENT_VEHICLES_SIREN_WAIL_02 and RESIDENT_VEHICLES_SIREN_QUICK_02 in the xml file.

Share this post


Link to post
Share on other sites

I have done this, but i have also found where i may have gone wrong. I have Albo1125's Modding DLC and found a 'hidden' audio file cache. It may have to go in there, but i do not know.

However, i have the x64 location with the Resident placed in my mods folder and other tones from the siren group (Police Warning, Siren 2, Airhorn) are working and were not in the Modding DLC area, it's just the Primary Siren that does not seem to match up to any of the hashes (have the audio file installed in three different slots, those being Police Primary and the two FIB) and reverts back to a Whelen Rumbler i had placed when i re-did my mods folder from a clean re-install, or the base-game sirens.

Edited by WHSD

Share this post


Link to post
Share on other sites
6 minutes ago, WHSD said:

I have done this, but i have also found where i may have gone wrong. I have Albo1125's Modding DLC and found a 'hidden' audio file cache. It may have to go in there, but i do not know.

However, i have the x64 location with the Resident placed in my mods folder and other tones from the siren group (Police Warning, Siren 2, Airhorn) are working and were not in the Modding DLC area, it's just the Primary Siren that does not seem to match up to any of the hashes (have the audio file installed in three different slots, those being Police Primary and the two FIB) and reverts back to a Whelen Rumbler i had placed when i re-did my mods folder from a clean re-install.

 

Sounds like your own problem then, a reinstall of everything should resolve it.

Share this post


Link to post
Share on other sites

Yeah.... That's what I've come to the conclusion of as well....

Thanks for the help Yoshe!

Share this post


Link to post
Share on other sites

Just a reminder for anyone using this, the PoliceB sirens are swapped with each other for some reason. 

0x013F5FE7(PoliceB Primary)=RESIDENT_VEHICLES_SIREN_QUICK_03

0x17DDFB5C(PoliceB Secondary)=RESIDENT_VEHICLES_SIREN_WAIL_03

 

@TheHC09 You should update this in your post as well.

Edited by YoshePlays

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×