Jump to content
ScottRance

Ragehook plugin wont load

Recommended Posts

I'm having problems with my lspdfr. I cant get it to work.

I have a fresh gta copy from the latest update (the festive update). I installed LSPDFR 0.2b, then the latest ragehook plugin (0.29). However. nothing loads when I get in game...?

edit:

I noticed that gta opened up twice. First time it crashed with no error, just closed quickly. Then a second gta loaded with nothing loaded to it. So maybe the game is crashing on startup but with no error popup?

 

Edited by ScottRance

Share this post


Link to post
Share on other sites
1 hour ago, ScottRance said:

Where can I find my logs?

you should find the ragepluginhook.log and other logs in your root gtav folder.

Share this post


Link to post
Share on other sites
22 minutes ago, timnboys said:

you should find the ragepluginhook.log and other logs in your root gtav folder.

I dont have a log for some reason. Its not a crash. The scripts or nothing just dont load when I get in game.

Edited by ScottRance

Share this post


Link to post
Share on other sites
18 minutes ago, ScottRance said:

I dont have a log for some reason. Its not a crash. The scripts or nothing just dont load when I get in game.

okay could I ask then what do you have currently installed on your machine dependencies wise as my guess is if it doesn't create the log files the scripthooks aren't even working.

could you grab me a screenshot of your root gtav directory as I want to see if all the files are there just to be on the safe side to verify that you aren't missing a critical file for something. 

I am on a different computer that isn't my gaming pc otherwise I would have given you a screenshot of my root gtav directory and let you compare it to yours.

Also what game version do you have?

as I know the latest game version is v573

so check to make sure your game is up to date at least with that game version please as I do know ragepluginhook removed all support for all previous versions of the game in the latest release.

to be honest you really was supposed to put lspdfr after you install the latest ragehook as the latest lspdfr download includes a old ragehook like .20 that won't work on latest games. so to make sure you get it installed right first copy the latest ragehook .29 and then only copy the plugins and other requirements from the lspdfr download but do not copy anything related to the ragehook out of the lspdfr download as it won't work as explained above.

you should only copy the following files for lspdfr to work in its latest download with the latest ragehook(.29)

  • LSPDFR Readme.pdf
  • Plugins folder
  • LSPDFR folder

and that is it don't copy anything else out of the lspdfr download as it will have to do with the old ragehook which won't work as explained above.

Edited by timnboys

Share this post


Link to post
Share on other sites
23 minutes ago, timnboys said:

okay could I ask then what do you have currently installed on your machine dependencies wise as my guess is if it doesn't create the log files the scripthooks aren't even working.

could you grab me a screenshot of your root gtav directory as I want to see if all the files are there just to be on the safe side to verify that you aren't missing a critical file for something. 

I am on a different computer that isn't my gaming pc otherwise I would have given you a screenshot of my root gtav directory and let you compare it to yours.

Also what game version do you have?

as I know the latest game version is v573

so check to make sure your game is up to date at least with that game version please as I do know ragepluginhook removed all support for all previous versions of the game in the latest release.

Here is a screenshot of my GTA V directory. 

http://prntscr.com/9iqlav

 

My GTA V is up to date v573. Note that I have 2 GTA directorys. One for multiplayer which is vanilla and one with mods in it (LSPDFR)

Edited by ScottRance

Share this post


Link to post
Share on other sites
1 minute ago, ScottRance said:

Here is a screenshot of my GTA V directory. 

http://prntscr.com/9iqlav

 

My GTA V is up to date v573

you wasn't actually supposed to copy all the files for scripthookvdotnet only the .asi file itself

also do you have the requirements for scripthookvdotnet installed?

Install both the Microsoft .NET Framework 4.5.2 (or higher, so skip this on Windows 10)and the Microsoft Visual C++ Redistributable Package for Visual Studio 2013 (x64). Do that again even if you think you already have them.

Download and install the latest Script Hook V(including the ASI loader). If mods break due to a game update, don't forget to update this one!

Download Script Hook V .NET and copy the ASI file into your game directory (The DLL is for developers).

Put .NET scripts inside a "scripts" sub-folder in your game directory!

Share this post


Link to post
Share on other sites

I had the same problem awhile back and found that I had to install both versions of Microsoft visual c++ .. I'm running windows 10 and still reinstalled everything and it fixed my problem

Share this post


Link to post
Share on other sites
1 minute ago, gamer516 said:

I had the same problem awhile back and found that I had to install both versions of Microsoft visual c++ .. I'm running windows 10 and still reinstalled everything and it fixed my problem

yes that is because scripthookvdotnet and ragehook uses two different versions of visual c++.

Share this post


Link to post
Share on other sites
6 minutes ago, timnboys said:

you wasn't actually supposed to copy all the files for scripthookvdotnet only the .asi file itself

also do you have the requirements for scripthookvdotnet installed?

Install both the Microsoft .NET Framework 4.5.2 (or higher, so skip this on Windows 10)and the Microsoft Visual C++ Redistributable Package for Visual Studio 2013 (x64). Do that again even if you think you already have them.

Download and install the latest Script Hook V(including the ASI loader). If mods break due to a game update, don't forget to update this one!

Download Script Hook V .NET and copy the ASI file into your game directory (The DLL is for developers).

Put .NET scripts inside a "scripts" sub-folder in your game directory!

Will do that.

3 minutes ago, gamer516 said:

I had the same problem awhile back and found that I had to install both versions of Microsoft visual c++ .. I'm running windows 10 and still reinstalled everything and it fixed my problem

Could u link me the 'other version of MVC++'?

Edited by ScottRance

Share this post


Link to post
Share on other sites
2 minutes ago, ScottRance said:

Will do that.

Could u link me the 'other version of MVC++'?

yes I can.https://www.microsoft.com/en-us/download/confirmation.aspx?id=40784&6B49FDFB-8E5B-4B07-BC31-15695C5A2143=1

or here: https://www.microsoft.com/en-us/download/details.aspx?id=40784

make sure you download the x64 bit version for either one though.

Edited by timnboys

Share this post


Link to post
Share on other sites
1 minute ago, ScottRance said:

When I open the 'vcredist_arm.exe' it wont open. When I run it as admin is says, 'This app can't run on your PC'.   I have windows 10.

All I want is this mod to work :(

you don't download arm that is a processor for phones please download the one that says vcredist_x64.exe please

 

Share this post


Link to post
Share on other sites

I did install lspdfr first, then the latest ragehook.

3 minutes ago, timnboys said:

you don't download arm that is a processor for phones please download the one that says vcredist_x64.exe please

 

Its already downloaded onto my PC(64-bit). It just says if you want to repair it, which I have done.

Edited by ScottRance

Share this post


Link to post
Share on other sites
1 minute ago, ScottRance said:

I did install lspdfr first, then the latest ragehook.

Its already downloaded onto my PC. It just says if you want to repair it, which I have done.

okay but is that the 2013 version or the 2015 version as both versions must be installed together.

Share this post


Link to post
Share on other sites
4 minutes ago, timnboys said:

okay but is that the 2013 version or the 2015 version as both versions must be installed together.

Both of them are installed.

What could be the problem? I could try a whole new fresh install. And could I have simple steps on what to do in order?

 

I want to play :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×