Jump to content
LtFlash

Small programming questions - API

Recommended Posts

Added SetPursuitTactics and SetPursuitHelicopterTactics to the API :)

Will be available soon.

Thank you for taking the time to make the API, and for adding those!


logov1_zpsd8d8fbe3.jpeg

Help my channel grow and I can explain to my wife why this addiction to coding is a good thing!

Share this post


Link to post
Share on other sites
1 minute ago, LtFlash said:

@LMS The new VS versions does not work with LCPD:FR library - shows no classes in dll. Is there any way to by-pass this or I got to download VS 2012?

Could you elaborate on that, i.e. show an error log? Or doesn't it show any functions at all?


Please do not PM me unless really necessary (knowing you helps). If you think you need my attention in a topic, tag me.

Share this post


Link to post
Share on other sites

@LMS

I opened the previously working *.sln file in VS 2015, it does not recognize any identifier nor namespace (reference not found) from LCPD First Response.dll file (I re-downloaded the latest version ofc and included it into the project). When I open Object Browser I can browse all namespaces and content of ScriptHook.NET, SlimDX but LCPDFR seems empty, when trying to expand only the arrow changes from closed (>) to opened (_|) and nothing shows up. The file itself seems OK - I opened it in ILSpy and it shows the content properly. Solution platform is set to x86 and .NET to 4.5.

I can download VS12 but that's 12 gigs of an installation folder just for 1 project.

Edited by LtFlash

Share this post


Link to post
Share on other sites
20 hours ago, LtFlash said:

@LMS

I opened the previously working *.sln file in VS 2015, it does not recognize any identifier nor namespace (reference not found) from LCPD First Response.dll file (I re-downloaded the latest version ofc and included it into the project). When I open Object Browser I can browse all namespaces and content of ScriptHook.NET, SlimDX but LCPDFR seems empty, when trying to expand only the arrow changes from closed (>) to opened (_|) and nothing shows up. The file itself seems OK - I opened it in ILSpy and it shows the content properly. Solution platform is set to x86 and .NET to 4.5.

I can download VS12 but that's 12 gigs of an installation folder just for 1 project.

Okay I see, I will try it myself this weekend and report back. In case I forget, don't hesitate to tag me again in a few days.


Please do not PM me unless really necessary (knowing you helps). If you think you need my attention in a topic, tag me.

Share this post


Link to post
Share on other sites

how does one create callouts?

I know it might be big but you guys might be able to help!


 

Nvidia GTX 1070FE, MSI Z170A SLI PLUS, I7 6700K

Chandler, Az

Steam: The_Lone_Wolf293                               GTA5-Mods.com: TheLoneWolf293

Share this post


Link to post
Share on other sites
On 5/17/2016 at 2:18 PM, LtFlash said:

@LMS How's it goin'? Have you checked the issue we were talking about?

Yes, and it does work fine for me on VS 2015. I created a new project, referenced the DLL and called a function to make sure it works. Does VS give any log output?


Please do not PM me unless really necessary (knowing you helps). If you think you need my attention in a topic, tag me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...