Jump to content
jordangelowitz1

Need Help with ELS!!!!

Recommended Posts

Hey all

 

I recently bought GTAIV for PC just to play LCPDFR. I have done quite a bit of research on how to get it all running properly and such and I came across this video so I simply did everything according to this video. 

Share this post


Link to post
Share on other sites

Got Some Questions for you.

1. Where do you have ELS put at?

 

2. Are you running as a admin?

 

3. Computer Specs?

 

(reason for Comp Specs, is because i tried that, and my specs were bad, and I fixed it by using a program, I found.)

 

Share this post


Link to post
Share on other sites

1. I have ELS installed in my common folder, exactly where it should be according to the extensive ammount of research I've done.

 

2. I don't think I'm running as admin, because I don't know how to do that, do you mean just right click the game and select "run as administrator"?

 

3. As far as my computer specs go, I have an Asus G74sx which is apparently a top of the line gaming laptop so there shouldn't be a problem there, but here are the specs anyway:

OS Name Microsoft Windows 7 Home Premium
Version 6.1.7601 Service Pack 1 Build 7601
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name OWNER-PC
System Manufacturer ASUSTeK Computer Inc.
System Model G74Sx
System Type x64-based PC
Processor Intel® Core i7-2630QM CPU @ 2.00GHz, 2001 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. G74Sx.201, 27/04/2011
SMBIOS Version 2.6
Windows Directory C:Windows
System Directory C:Windowssystem32
Boot Device DeviceHarddiskVolume1
Locale Canada
Hardware Abstraction Layer Version = "6.1.7601.17514"
User Name Owner-PCOwner
Time Zone Mountain Daylight Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.98 GB
Available Physical Memory 5.92 GB
Total Virtual Memory 16.0 GB
Available Virtual Memory 13.0 GB
Page File Space 7.98 GB
Page File C:pagefile.sys
 

Share this post


Link to post
Share on other sites

You have ELS installed in your common folder?  It should be in your games root directory, not the common folder.  

 

Remove the files from your common folder and place them in your root folder (ie: mine is eflc so the path is :C:Program Files (x86)SteamSteamAppscommonGrand Theft Auto IV Episodes from Liberty CityEFLC).

 

Good luck

 

DrDetroit

Share this post


Link to post
Share on other sites

Wait, do you have lag? If not, did you know you need to press J 3 times before getting to primary lights? (Otherwise RAlt+J).

Share this post


Link to post
Share on other sites

I do have simple trainer installed, but ive been trying to uninstall it and can't seem to figure out how to do that lol. and yes my ELS is in my common folder as well as my root directory, should it only be in one? and no i do not have any lag so far.

 

P.S

thanks for the replies!

Share this post


Link to post
Share on other sites

Okay thanks, and no my trainer keys are not disabled as my computer does not have a num lock so i cannot control the trainer when it comes up using 8,2,6 and 4

 

Alright, that's why the lights aren't working. To disable the keys from outside of the game do this:

 

1. Open trainer.ini in your GTA directory (C:Program Files (x86)Rockstar GamesGrand Theft Auto IV)

2. Search the document (CTRL+F) for KeyBindingsDisabled

3. Change the value after KeyBindingsDisabled from 0 to 1

4. Save and exit

 

Or if you wanted to you can just get rid of trainer completely by deleting trainer.ini and trainer.asi

Edited by James3000117

Share this post


Link to post
Share on other sites

Thanks very much for your help! I'm in the process of reinstalling everything so ill re download everything accordingly and try that

Alright. Try to see if ELS works before installing the trainer, just so you can prove that it's what's causing the problem.

 

Share this post


Link to post
Share on other sites

Thanks very much for your help! I'm in the process of reinstalling everything so ill re download everything accordingly and try that

 You need to ensure you make a back up of all your files. That way if you run into a problem you can simply use your back up to fix some issues. it saves alot of time

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×