Jump to content
cheekygamer

Need help with LSPDFR 0.3

Recommended Posts

So I downloaded LSPDFR 0.3 along with the latest Ragehookplugin 36 and followed all the videos and guides but whenever I click on Ragehook.exe to start nothing happens. I tried opening it from within the game but the same result. I have the most up-to-date asi loader and all neccessary requirments to run it it I can't even in administrator mode. I also noticed in the guide vids that you will get Ragehook licensce when installing LSPDFR but I didn't, the box just ticked itself when I clicked show liscence. I'm terrible at modding and apologise in advance for my stupidity but I really need help with this because I want to play LSPDFR. Thanks in advance.

Share this post


Link to post
Share on other sites

Hello there - Welcome, and thanks for trying out LSPDFR. We require all members to read the provided ReadMe and User Documentation before getting support. Please keep in mind that this is a beta version of LSPDFR - we cannot guarantee that all issues have been resolved. 

You can find the user manual in your LSPDFR Download folder. If you still have questions after reading the User Documentation, review the LSPDFR FAQ; http://www.lcpdfr.com/forums/topic/51162-lspdfr-frequently-asked-questions/. 

Ensure you have a folder titled "LSPDFR" and "plugins" in your root directory. 

  • The plugins folder should contain the following; 
    • LSPD First Response.dll
    • A folder titled "LSPDFR"

Ensure that you are running a supported version of LSPDFR. As of 2016-01-16 ONLY LSPDFR 0.3 is supported - No LSPDFR 0.2 plugins are supported for LSPDFR 0.3 unless otherwise stated

Make sure you have the latest RagePluginHook (version 0.34 is shipped with LSPDFR 0.3): http://ragepluginhook.net/ 

Please do so now and return to this topic when this is done and do the following;

  • Give a clear, detailed description of the problem.
  • Explain any circumstances surrounding the problem.
  • State what solutions you have tried.
  • State which version of the game you're using (Steam or Retail)
  • Post the RagePluginHook.log in a spoiler tag (Please be courteous and only include the relevant information).
  • Include as much information as possible.
  • Post your system specifications. You need to meet the required system specifications for the mod to work properly. 
  • Post what other mods you are using. 
  • Post a screenshot of your GTA V Game directory. 

 Failure to follow these instructions may result in topic closure. 

Share this post


Link to post
Share on other sites

Whenever I want to start the game and double click Ragehook.exe nothing happens. I tried again and again but it does nothing. 

I noticed that I don't have a folder titled LSPDFR in my plugins but I do have one above plugins.

I tried to re-install the mod but with the same results. The only Ragehook plugin available to downloade is 36. The others no longer have working download links.

I use the Steam version of the game.

I have Windows 7 Servive pack 1 with Intell Core i7 and DirectX 11, basically everything listed in the system requirements.

The only other mods I use are the Simple Trainer and Map editor but these I installed after LSPDFR.

screenshot 2.png

Share this post


Link to post
Share on other sites
2 hours ago, cheekygamer said:

I am not too sure but I'm pretty sure that I don't.

It's the requirement for running ragehook. Install it, I had the same issue.

Share this post


Link to post
Share on other sites
9 minutes ago, cheekygamer said:

Ok well I'll do that but do you happen to know which version I need for the latest update to Ragehook? Thanks for the help.

 

Requirements

Requirements for regular users

 

 

Share this post


Link to post
Share on other sites

Well I did all that and Ragehook loaded up perfectly but then in game I couldn't see any changes and LSPDFR was unavailable even though I had selected it to be run. I tried opening the console in game but the button didn't bring up anything. What could the problem be?

Share this post


Link to post
Share on other sites

Have not been able to play since 0.2 before this new version came out... now RAGE plugins won't load at all, before that, I had to set directx checked on RAGE settings or game would crash (LSPD First Response) and could only do traffic stops, and run names, couldnt accept callouts, bring up radio, etc. been waiting for a new update on LSPD 0.3 but maybe I just cant play it anymore.. I find it funny how the showoff youtubers have no issues whatsoever it seems, I always do. Weird. Seems it only works for them.

Share this post


Link to post
Share on other sites

Game starts but LSPDFR does not work... did everything in the faq and people on Ragehook forum has the same problems.

Funny thing is, people say LSPDFR is so great and yet, the game wont run from get go and dont forget no support. Because people are not allowed. The other police mod out there runs from get go without any problems lol

I know what i will use from now on.

Share this post


Link to post
Share on other sites
1 hour ago, Qanpicho said:
1 hour ago, Qanpicho said:

Game starts but LSPDFR does not work... did everything in the faq and people on Ragehook forum has the same problems.

Funny thing is, people say LSPDFR is so great and yet, the game wont run from get go and dont forget no support. Because people are not allowed. The other police mod out there runs from get go without any problems lol

I know what i will use from now on.

Game starts but LSPDFR does not work... did everything in the faq and people on Ragehook forum has the same problems.

Funny thing is, people say LSPDFR is so great and yet, the game wont run from get go and dont forget no support. Because people are not allowed. The other police mod out there runs from get go without any problems lol

I know what i will use from now on.

First of all Forget What People say, learn by your own experience.

Secondly this forum is generally for people seeking support - trouble is how can anyone support you?

If, maybe, you can give more information ie, a shot of your directories, what you have installed, what versions are installed etc, people may be able to assist so you can then, like me, enjoy the mod to its full potential and clearly see for yourself how police mod2 doesn't even touch the surface. In no way am I dissing Police Mod2, its a great mod. However LSPDFR with all the supporting plugins and alike, against PoliceMod2? Seriously? Are you sure?

Share this post


Link to post
Share on other sites
On ‎19‎/‎02‎/‎2016 at 11:40 PM, cheekygamer said:

Well I did all that and Ragehook loaded up perfectly but then in game I couldn't see any changes and LSPDFR was unavailable even though I had selected it to be run. I tried opening the console in game but the button didn't bring up anything. What could the problem be?

When the game is loading up, do you see the RAGE logo appear with a settings icon placed just to the left? If so, hold down Shift or click the icon(when the RAGE logo appears, when loading game) to enter the RAGE menu. Then make sure that the plugins you want to use have all been highlighted for launch. I tick the Load All Plugins option, then click Save and Launch.

Try that - Also Is your Rage.exe set to Run as Administrator?

6 hours ago, Unknown Soldier said:

Have not been able to play since 0.2 before this new version came out... now RAGE plugins won't load at all, before that, I had to set directx checked on RAGE settings or game would crash (LSPD First Response) and could only do traffic stops, and run names, couldnt accept callouts, bring up radio, etc. been waiting for a new update on LSPD 0.3 but maybe I just cant play it anymore.. I find it funny how the showoff youtubers have no issues whatsoever it seems, I always do. Weird. Seems it only works for them.

Many, many people are using this mod, so therefore there should be no reason why it shouldn't work for you. Why not try a new fresh download and see if anyone's about to offer you advise as you re-attempt to install? You got this far?

Trust me be patient, take one step at a time - go slowly and I guarantee that you too will have a new you tube channel out in weeks, spinning them patrols like no tomorrow.

Share this post


Link to post
Share on other sites

Except it seems that for many people, the latest update released by Rockstar (at least through Steam for me) and Rage plugin .36 crashes as soon as the LSPDFR dll is loaded.  Waiting on a fix...

Share this post


Link to post
Share on other sites

That isn't exactly LSPDFRs fault now is it?

Like Babylon said, if you provided the required information that we require you to post, we can quite gladly help you. Unfortunately, saying that it doesn't work doesn't give us any actual information to help you fix it.

On 21 February 2016 at 11:25 AM, Qanpicho said:

Because people are not allowed.

Where did this come from? If your talking about the notice, that's to keep the forum tidy from people who don't read instructions.

Share this post


Link to post
Share on other sites

RPH works with the newest version of GTA V.

Try installing LSPDFR again (0.3.1) and with the newest RPH. See if it works now. Make sure you meet all the requirements of RPH and LSPDFR. These can be found on their sites. Good Luck!

Share this post


Link to post
Share on other sites
5 hours ago, Reyesinc said:

RPH works with the newest version of GTA V.

Try installing LSPDFR again (0.3.1) and with the newest RPH. See if it works now. Make sure you meet all the requirements of RPH and LSPDFR. These can be found on their sites. Good Luck!

I actually uninstalled RPH and LSPDFR and repaired my game, played the game just fine running around after leaving Franklins house. After 15 minutes of killing cops I quit the game and did the steps again and rage hook crashed even without LSPDFR plugin in so I don't know anymore, still waiting lol.

Share this post


Link to post
Share on other sites
4 minutes ago, CODEHX said:

I actually uninstalled RPH and LSPDFR and repaired my game, played the game just fine running around after leaving Franklins house. After 15 minutes of killing cops I quit the game and did the steps again and rage hook crashed even without LSPDFR plugin in so I don't know anymore, still waiting lol.

Do you meat all the requirerments for RPH?

Share this post


Link to post
Share on other sites
6 minutes ago, Reyesinc said:

Do you meat all the requirerments for RPH?

I downloaded all of them and/or repaired them due to already having them.

Share this post


Link to post
Share on other sites

The problem is RPH .36 and the newest patch from Rockstar for the retail version. If any of you have the retail version (CD, not downloaded off Steam), that is probably why your games are crashing. I am in the same boat. Nothing can really be done until RPH .37 is released, which I thought would have been out already since they discovered the issue long ago, but those forums seem to be a ghost town.

The game's not playable for CD users until .37 is released.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×