Jump to content
sgtdonuts

At the end of my nerves, does ELS even work on 64 bits??

Recommended Posts

Ran it flawlessly on XP.

 

Short story I am now on 7 64 bit. Everything works perfect, and i mean every single mod script hook you name it; works.

 

Except ELS. The menu will not show and none of the ALT commands do anything. Holding J/K for random periods will activate primary and secondary lights but that's about it. Sometimes it takes a few seconds for that to happen.

 

i have tried every possible solution i have ever read of or thought of, everything with no result. My only available option is to dual boot XP and run GTA on that.

 

Anybody else gotten ELS 5/6/6.1 to work on windows 7 64bit?

 

 

Share this post


Link to post
Share on other sites

I am running GTA on windows 7 home premium 64 bit and have never had any problems with ELS.

Except the fact ELS-H dont work...

Share this post


Link to post
Share on other sites

You have to put all the files in your main directory, not your scripts folder.

 

I made that mistake once... :S

Edited by Michael V.

Share this post


Link to post
Share on other sites

there is one other thing that you can try.... if you are running a trainer disable you keys in the trainer.... i had the same problem for the longest time till i realized that i had key biding from the trainer and els... hope it helps

Share this post


Link to post
Share on other sites

tried all that. no change. even installed gta on another drive in case it was some program files protection thing from windows. nada.

 

dsound or xlive. no effect on ELS. tried both, different versions. same result.

 

 



i know the .asi works because other asi mods load and function. except this bloody thing.

 

the console log always says using els: false as well. if that is an indication of anything.

 

version 6 and 6.1 are exactly the same. you get them from the gtapolicemods site, under luxart. somebody asked



yet it says its loaded.

 

 

Loading ASI d:gta4Grand Theft Auto IVELS.asi
ASI loaded : d:gta4Grand Theft Auto IVELS.asi, Address 0x00000000

Share this post


Link to post
Share on other sites

What a pain. Had to install XP. Guess what... IT WORKS.

 

Just doesn't work on 7 ultimate 64 bit. It is the OS or the ELS or something in the way it is coded.

 

 

Not sure how but even used my old gta installation (old as in 1 hour old) that i put under 7... setup did something and didn't change anything to the install. heh, except that im now missing the savegames folder. So i might have to wipe it yet again

 

Anyway, els  drama "solved"

Share this post


Link to post
Share on other sites

tried all that. no change. even installed gta on another drive in case it was some program files protection thing from windows. nada.

 

dsound or xlive. no effect on ELS. tried both, different versions. same result.

 

 

i know the .asi works because other asi mods load and function. except this bloody thing.

 

the console log always says using els: false as well. if that is an indication of anything.

 

version 6 and 6.1 are exactly the same. you get them from the gtapolicemods site, under luxart. somebody asked

yet it says its loaded.

 

 

Loading ASI d:gta4Grand Theft Auto IVELS.asi

ASI loaded : d:gta4Grand Theft Auto IVELS.asi, Address 0x00000000

 

1.) Are you using ELS enabled cars?

 

2.) Are you running GTA 4 as admin (if not run it as admin)

 

3.) Is your computer good enough to handle ELS

 

4.) Like the other person said turn your Trainer keys off. You said if you are holding down J/K over time it will turn the lights on. That means some other script (more then likely the trainer) is interfering with it. When people say turn off your trainer keys, you need to go into your trainer under the 1st menu on the right said and DISABLE THE KEYS

 

5.) Its not a problem with ELS its a problem with you/ your game....

 

 

Also it works fine on my windows 7 64 bit

Edited by Darkangel

Share this post


Link to post
Share on other sites
1.) Are you using ELS enabled cars?

 

2.) Are you running GTA 4 as admin (if not run it as admin)

 

3.) Is your computer good enough to handle ELS

 

4.) Like the other person said turn your Trainer keys off. You said if you are holding down J/K over time it will turn the lights on. That means some other script (more then likely the trainer) is interfering with it. When people say turn off your trainer keys, you need to go into your trainer under the 1st menu on the right said and DISABLE THE KEYS

 

5.) Its not a problem with ELS its a problem with you/ your game....

 

 

Also it works fine on my windows 7 64 bit

 

 Then explain why it works on XP but not on 7? both are fresh installations. It is the only mod that does not work under 7 from what i've noticed.

 

In my original post i stated i've exhausted all conventional issues. Why are 30 people repeating them one by one as if i somehow didn't try that? Eh?

Share this post


Link to post
Share on other sites
 Then explain why it works on XP but not on 7? both are fresh installations. It is the only mod that does not work under 7 from what i've noticed.

 

In my original post i stated i've exhausted all conventional issues. Why are 30 people repeating them one by one as if i somehow didn't try that? Eh?

 

 

Jeez were just trying to help

 

It must be user error then because it works for everyone else on windows 7 64 BIT....

 

 

Either that or your windows got messed up and just needs to be fixed, but I highly doubt it, just download "advanced system care" and run it and repair the errors....

Share this post


Link to post
Share on other sites

I am having this same issue as well, Can press J K L for light activation but ALT+M and ALT+T do not work whatsoever.

 

Running a fully up to date Win7 Ultimate AMD64. 

 

GTA is 1.0.7.0 with everything working BUT that ELS. Everything else works perfectly (LCPDFR, FuelMod, Trainer, etc)

Share this post


Link to post
Share on other sites
Do you think any other mods would be clashing with the ELS hotkeys?

 

 

I personally disabled all addons except for ELS as well, and the problem persisted, so I would imagine it wasn't a keybinding issue.

Share this post


Link to post
Share on other sites
Damn, sounds really weird. :I

 

I think it may be related to a Win7 update, because I loaded it up on a Vista and XP machine and it worked beautifully... confirming it with a couple buddies on Win8 too.I also noticed that it stopped working after I ran Windows Update. I just don't know which one messed with it.

Share this post


Link to post
Share on other sites

Here we go, something that finally makes sense. Could be an update indeed. Since i update any install before i put anything else on it. I should try with a base early win 7 release and see if that works. then if it does work, update that and see if it still works.

 

it could be as odd as the dotnets. they are different for 7 and xp and up to  a different update versions as well.

 

 

 

Alright back to happy gtaing for me under xp till and if this is figured out.

Edited by sgtdonuts

Share this post


Link to post
Share on other sites
Here we go, something that finally makes sense. Could be an update indeed. Since i update any install before i put anything else on it. I should try with a base early win 7 release and see if that works. then if it does work, update that and see if it still works.

 

it could be as odd as the dotnets. they are different for 7 and xp and up to  a different update versions as well.

 

 

 

Alright back to happy gtaing for me under xp till and if this is figured out.

 

 

I think it's gonna be a hell of a effort,  but I might try to figure out which update did it. But it makes perfect sense to be a update. Since XP, Vista, 7 and 8 have different update trees, May be similar updates, but still difference in the update code... 

 

On the other hand, I may just wait until it's fixed.

Share this post


Link to post
Share on other sites

After a long fight with it, I went into the Steam directory and re installed the dependencies (Not sure if my fix had a effect on it.) but I found out that if I hold my ALT M button or ALT T button for about 15-30 seconds, they actually work. 

 

I just didn't except to have to hold it that long.

Share this post


Link to post
Share on other sites
I think it may be related to a Win7 update, because I loaded it up on a Vista and XP machine and it worked beautifully... confirming it with a couple buddies on Win8 too.I also noticed that it stopped working after I ran Windows Update. I just don't know which one messed with it.

 

Your not looking at the big picture, more then likely your windows got all !@#$ fuck when you install it either, trying to do a advanced install, maybe computer turned off or something. Its not just windows 7, windows 7 works and runs fine. I have windows 7 64 bit and it runs 100% perfect. 

 

I am almost 99% sure your windows got messed up when it was installing.

 

Like I said you will how to either...

 

A: Download and install and run Advanced system care will fix those problems and also a lot of other problems on your computer.

 

B: Re install windows all together to get that fresh windows smell back....

 

C: Use the FIX windows option on the recovery/ installing disk and try to fix windows that way. (I don't recommend this because it might only fix a few problems then give up lol...)

 

 

---------------------------------------------------....

 

Didn't see your other post there about the 15-30 seconds.

 

This sounds like it could be a keyboard related problem and I just have the idea why it works on 1 windows and not the other.

 

It could be the drivers for your keyboard got messed up when installing for any reason and never got the chance to fix them. This can cause keys to "Jam up" and not work on programs. Like with my new keyboard almost had a heart attack when the macro keys didn't work at 1st. But it as because the drivers got screwed up just reinstall them and now I have no more key jams.... 

Edited by Darkangel

Share this post


Link to post
Share on other sites
Just doesn't work on 7 ultimate 64 bit. It is the OS or the ELS or something in the way it is coded.

 

I am here to attest to the fact that ELS does work on Windows 7/64 as that's what I run and I have NO issues. There has to be something in your configuration that is causing the issue.

Share this post


Link to post
Share on other sites
Didn't see your other post there about the 15-30 seconds.

 

This sounds like it could be a keyboard related problem and I just have the idea why it works on 1 windows and not the other.

 

It could be the drivers for your keyboard got messed up when installing for any reason and never got the chance to fix them. This can cause keys to "Jam up" and not work on programs. Like with my new keyboard almost had a heart attack when the macro keys didn't work at 1st. But it as because the drivers got screwed up just reinstall them and now I have no more key jams.... 

 

I don't have keyboard drivers installed for my keyboard. It's a Das Ultimate mechanical PS/2 keyboard. No drivers needed. 

Share this post


Link to post
Share on other sites
I don't have keyboard drivers installed for my keyboard. It's a Das Ultimate mechanical PS/2 keyboard. No drivers needed. 

 

Everything has drivers.... Speakers have drivers, Mice have drivers, joy sticks have drivers, if they made a necklace for a computer it would have drivers....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×