Jump to content
leonard795

Installation failed.

Recommended Posts

Installation component 'LCPDFRModels' error'd!

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite)

at System.IO.File.Copy(String sourceFileName, String destFileName)

at G17MediaSetupEngine.Installation_Components.tazershit.beginComponent()

at G17MediaSetupEngine.UI.Interface.wizardControl1_SelectedPageChanged(Object sender, EventArgs e)

at G17MediaSetupEngine.UI.Interface.wizardControl1_SelectedPageChanged(Object sender, EventArgs e)

I was told to post this for support. How do I fix this?

Share this post


Link to post
Share on other sites

Did you run the installer as Administrator?, does the destination exist? eg: it's in the default location of C:program files (x86)rockstar gamesgta iv

Share this post


Link to post
Share on other sites

I have gta through steam, and i was told just to do it through the general gta4 folder. And idk how to run as administrator. as soon as the download is finished the installer opens on its own and doesn't give me the option to run as an administrator.

Share this post


Link to post
Share on other sites

DING!!! thats why! it does not see your GTA folder where the store bought game is! ok, here's what you do, right click the installer, hit run as administrator, when it comes to the to part where it's asking where it needs to go, hit browse, follow folders in this order program files (x86)*-> steam-> steamapps-> common select GTAIV

* If you do not have Program Files (x86) it should be in Program Files

Share this post


Link to post
Share on other sites

Thats what i have been doing...the only thing i cant do is run as an administrator. It doesnt give me the option, it just starts right after the download is done. There is no file and it doesnt save.

Share this post


Link to post
Share on other sites

This is a really common problem;

Run the installer as admin by right clicking and clicking 'run as administrator'

Further, go to the folder where your game is installed (for steam it should be steam/steamapps/common/grand theft auto iv/gta iv/) and make sure those files and folders are not ready only (highlight ALL of them, right click, properties, untick read only)

You download the installer form this website. It is a file called 095RC2R2.exe. Place it somewhere (like your desktop)

Edited by Ekalb

Share this post


Link to post
Share on other sites

This is interesting, this is the same thing that happened to my friend, his folders were unlocked, and he ran it as a administrator...and it STILL failed, this might have to be looked into by the devs

Share this post


Link to post
Share on other sites

ummm if its opening right after download.....try selecting SAVE and not OPEN then find it in your downloads folder then run as admin

Share this post


Link to post
Share on other sites

I also having exactly the same issue, i did all these steps and it didn't work yet. Only thing that i didn't have done yet is installing patch 1.0.7.0. I will let you guys know if this worked.

----------------------EDIT------------------------

Solution found! If you have 1.0.4.0 u must upgrade it to 1.0.7.0.

Download Link: http://games.softpedia.com/dyn-postdownload.php?p=30489&t=0&i=1

1. Download the setup

2. Launch UpdateTitle.exe

3. Install the files.

4. For windows 7 and Vista users run the LCPDFR setup as a administrator.

5. Follow the instructions for the install

6. Go ingame and test if it works with ALT+P

Edited by Max911

Share this post


Link to post
Share on other sites

I also having exactly the same issue, i did all these steps and it didn't work yet. Only thing that i didn't have done yet is installing patch 1.0.7.0. I will let you guys know if this worked.

----------------------EDIT------------------------

Solution found! If you have 1.0.4.0 u must upgrade it to 1.0.7.0.

Download Link: http://games.softped...p=30489&t=0&i=1

1. Download the setup

2. Launch UpdateTitle.exe

3. Install the files.

4. For windows 7 and Vista users run the LCPDFR setup as a administrator.

5. Follow the instructions for the install

6. Go ingame and test if it works with ALT+P

  1. Please don't thread hijack, in future, if you are having problems create a topic in the support section.
  2. It is necessary to upgrade to 1.0.7.0 as stated in the stickies. If you had created a topic, you also would have been told this during the troubleshooter.
Edited by Tom H

Share this post


Link to post
Share on other sites

Installation component 'LCPDFRModels' error'd!

at RageLib.FileSystem.IMGFileSystem.Open(String filename)

at G17MediaSetupEngine.Installation_Components.tazershit.beginComponent()

at G17MediaSetupEngine.UI.Interface.wizardControl1_SelectedPageChanged(Object sender, EventArgs e)

at G17MediaSetupEngine.UI.Interface.wizardControl1_SelectedPageChanged(Object sender, EventArgs e)

i had it working but then my gta messed up i uninstalled it all now reinstalling it i get this message :(

Share this post


Link to post
Share on other sites

Installation component 'LCPDFRModels' error'd!

at RageLib.FileSystem.IMGFileSystem.Open(String filename)

at G17MediaSetupEngine.Installation_Components.tazershit.beginComponent()

at G17MediaSetupEngine.UI.Interface.wizardControl1_SelectedPageChanged(Object sender, EventArgs e)

at G17MediaSetupEngine.UI.Interface.wizardControl1_SelectedPageChanged(Object sender, EventArgs e)

i had it working but then my gta messed up i uninstalled it all now reinstalling it i get this message :(

Dont thread-hijack.

Create your own support thread

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×