Jump to content
NLM

ELS v8 on windows XP

Recommended Posts

NLM    2

Anyone tried this on windows XP yet?

I don't see any guides to make this work on windows xp. I tried to run it but don't think the script is loading successfully.

Also I get an error, GetTickcount64 not found in kernel32.dll when launching the game. Game start after displaying that error though.

Anyone know a way to make this work on XP?

 

 

What's New?
What's New in Version V8.0 (R01) (See full changelog)
  • WARNING: ELS V7 VCF (VEHICLE CONFIG. FILES) ARE NO LONGER COMPATIBLE WITH ELS V8--ENSURE TO MAKE NECESSARY UPDATES.
  • SEVERAL MINOR TO MAJOR BUG FIXES AND OPTIMIZATIONS.
  • FLASH DELAY LIMIT INCREASED FROM 3 TO 5.
  • ADDED NEW LSTG ACTIVATION METHODS: DEFAULT, INVERTED, JUMP, AND EURO.
  • ADDED ABILITY TO CHOOSE LSTG ACTIVATION METHOD PER VEHICLE.
  • ADDED WINDOWS XP COMPATIBILITY (NOT FULLY TESTED).
  • REPLACED ALL SOUNDS (LSTG ACTIVATION, FEATURE TOGGLE, PATTERN BROWSING).

 

Share this post


Link to post
Share on other sites

Are you using Windows XP? If yes, switch to Windows 7. It's a 13 year old operating system, it is a wonder they bothered to add support for it. 

Share this post


Link to post
Share on other sites

Windows XP is a really old and outdated system, most programs and games today aren't supported nor work on Windows XP.

 

ELS V8 and LCPD:FR 1.0 uses coding programs/software that isn't compatible with nor supported on Windows XP, i thinks it's about time to think about upgrading to either Windows 7 or Windows 8 since most programs run perfectly on them.

Share this post


Link to post
Share on other sites
NLM    2

yes I'm aware that it's an old os. But my system memory or performance is not enough to run the game on windows 7 without lags. In windows XP it runs perfectly with full graphics on. So I keep windows XP just to play this game and would like to know a solution to run this on XP.

Share this post


Link to post
Share on other sites

There is one: Upgrade to a OS from this century. Windows 7, Windows 8 or 8.1 will do. Windows XP is no longer supported by Microsoft, and hardly isn't supported by us anymore. 

Share this post


Link to post
Share on other sites
NLM    2

There is one: Upgrade to a OS from this century. Windows 7, Windows 8 or 8.1 will do. Windows XP is no longer supported by Microsoft, and hardly isn't supported by us anymore. 

 

I'm asking support for ELS, not LCPDFR. I understand LCPDFR doesn't support windows xp. But new ELS v8 does support windows xp according to the change log.

So I'm simply asking how can I make this run on XP?

 

Can you guys please be more supportive instead of lecturing me how much older windows xp is?

 

FYI; I already have windows 7 in my pc but the game is not stable when ruuning it from 7 as I mentioned above. That's why I keep windows xp to play it.

Share this post


Link to post
Share on other sites
NLM    2

ELS v8 is currently incompatible with Windows XP, by the error message it's showing.

 

To my knowledge if developers compile the script using windows XP this GetTickcount error can be easily overcome making this mod XP friendly.

Share this post


Link to post
Share on other sites

The developers do not have time to develop for an outdated operating system. 

To answer your question: You cannot run this on Windows XP. 

Edited by ineseri

Share this post


Link to post
Share on other sites

The function it's attempting to call was added in Vista. ELS is trying to make a system call which simply doesn't exist in XP. If it required compiling the mod on XP to fix, you'd be *completely* out of luck; it's objectively unreasonable to expect Caine to get Windows XP just to compile his mod to support it. But it's slightly different: The API function ELS uses isn't there. There's a dependency to a function in the Windows API DLL that isn't in the DLL. The only fix would be to replace the function; this might be possible, but Caine may have chosen GetTickCount64 for a good reason.

Now, this call could potentially be replaced if ELS detects it's running on XP. Caine might be willing to do that. Alternatively, if this is being used to handle light flash ticks, it's possible that GetSystemTimeAsFileTime might work as well (http://msdn.microsoft.com/en-us/library/windows/desktop/ms724397(v=vs.85).aspx ). However, if this doesn't work, then it's likely that the mod wasn't actually tested much on XP, so there may be other bugs. Advice: Drop XP now. It's past end-of-life, with no more security patches, no bugfixes, nothing. It should be presumed to be insecure. It was first released 13 years ago. Running it on your computer is a serious security risk; if you're willing to put up with a serious security risk to play GTA with full graphics, then get a newer computer that can do so with an operating system that still gets patched. But you should not be using XP. Period.

Share this post


Link to post
Share on other sites

If he wants to? If Caine feels like making it compatible, he will. There's some indication that he at least cares a little bit about this.

Share this post


Link to post
Share on other sites
NLM    2

If he wants to? If Caine feels like making it compatible, he will. There's some indication that he at least cares a little bit about this.

 

Yes, "added windows XP compatiblity" line in the changelog is a good sign that he wants make it available for XP users. :smile:

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×