Jump to content
TheChef

Change default police?

Recommended Posts

Difficult to make the title more clear, but i got a quick question. Somewhere along the line of my modding-spree i seem to have changed something that changed all my 'street cops' from regular cops to the State Troopers. What can i change to change the street cops back to regular cops instead of troopers? Tried to Google but don't think i used the right search words. Any help would be appreciated!

Share this post


Link to post
Share on other sites

Do to I thing pedgrps. (.some kind of file extension) they will be a line where you can set which cops spawn (search cop) then put m_y_cop as the first two

Share this post


Link to post
Share on other sites

Backups are a must when modding a game. If you don't backup, you should not mod.

 

@OP: Did you change any of your Police peds?

If so, either change them back to default,

          or

Go to GTA:IV folder > common > data > open pedgrp.dat > scroll down to "# POPCYCLE_GROUP_COPS" then:-

Make sure "M_Y_STROOPER" is in the line after "M_Y_Cop, M_M_Fatcop_01",  if it is not, do the correction.

If it is in the correct place, then remove "M_Y_STROOPER". That should stop the State Troopers from spawning on foot & hopefully start spawning the normal cops again. However, note that this will completely stop them spawning on foot, meaning even in Alderney you will have normal cops instead of the State Troopers, not good for realism imo.

Share this post


Link to post
Share on other sites

@Rocking_Star Thanks a bunch bud, indeed what i needed.
@The rest; I have backups of everything, but if you don't know what you did wrong, then it's not the best thing to throw all the backups back in the original place. Would create alot more problems then solving them. I did modify my peds, however i cannot remember ever touching the pedgrp.dat file.

 

So will try this fix when i get home, thanks alot everybody!

Share this post


Link to post
Share on other sites

@then it's not the best thing to throw all the backups back in the original place. Would create alot more problems then solving them.

 

That's why you investigate and look for what you changed. If you modded the ped models themselves, figuring the correct back up files to replace the current files with should be fairly easy. Default cop should be m_y_cop in the componentpeds.img for an example.

 

If it was the pedgrp file thing, yeah, do what Rocking suggested.

 

Share this post


Link to post
Share on other sites

I did modify my peds, however i cannot remember ever touching the pedgrp.dat file.

 

So will try this fix when i get home, thanks alot everybody!

 

Oh, that reminds me.

Forgot to mention that there is a bug that happens sometimes if your police ped model is too HQ & the game won't spawn it ingame as a AI on-foot cop, it'll divert to the other non-modded, default cop model, even if it's inappropriate for the location (for eg. State Trooper spawning in Algonquin, etc.).

Usually putting the non-modded cop model in the next line after the modded model in pedsgrp.dat fixes it, sometimes it does not.

Share this post


Link to post
Share on other sites

Oh, that reminds me.

Forgot to mention that there is a bug that happens sometimes if your police ped model is too HQ & the game won't spawn it ingame as a AI on-foot cop, it'll divert to the other non-modded, default cop model, even if it's inappropriate for the location (for eg. State Trooper spawning in Algonquin, etc.).

Usually putting the non-modded cop model in the next line after the modded model in pedsgrp.dat fixes it, sometimes it does not.

 

 

Thanks again. This is how it looks:

 

 

# POPCYCLE_GROUP_COPS (M_Y_Cop_Traffic removed. Was the one in NJ)

M_Y_Cop, M_M_Fatcop_01
M_Y_STROOPER

 

MY_COP & STROOPER are modded, fatcops are default. If i remove the STROOPER line, my game loads and crashes after 1 second. ^^ So that doesn't seem to be the fix. I noticed the line about the Trafficcops, those i modified aswell. So i'm starting to think it was related to that mod. Will try to put the defauls regular copskin back and see if they spawn then, although i never had this problem before using all these peds the last couple of months.

Share this post


Link to post
Share on other sites

Thanks again. This is how it looks:

 

 

MY_COP & STROOPER are modded, fatcops are default. If i remove the STROOPER line, my game loads and crashes after 1 second. ^^ So that doesn't seem to be the fix. I noticed the line about the Trafficcops, those i modified aswell. So i'm starting to think it was related to that mod. Will try to put the defauls regular copskin back and see if they spawn then, although i never had this problem before using all these peds the last couple of months.

 

The string about traffic cops was just left behind by developers. In the beta, the cops in Alderney used to be the traffic cops. Shouldn't have anything to do with your issue. If you'd allow me to, I could try and teamview you and detect the issue. Done it a few times now.

 

Edited by Olanov

Share this post


Link to post
Share on other sites

The string about traffic cops was just left behind by developers. In the beta, the cops in Alderney used to be the traffic cops. Shouldn't have anything to do with your issue. If you'd allow me to, I could try and teamview you and detect the issue. Done it a few times now.

 

 

That would be much appreciated, do have TV installed but no knowledge of the software itself. Send me a message with the details needed!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×