Jump to content
Cleatus

G7 Media IV Diagnostics has 'Stopped Working'

Recommended Posts

Hey,

When I run the program G7 Media IV Diagnostics, cycles through all the components until it gets to 'GTAIV Detected' and then stops working, GTAIV Detected does 'tick' but the program stops there. At the tops of the window when this happens it says ;".NET Framework 4.0 Status: Checking..."

I am having a very common problem, with pressing Alt+P and the screen going blurry, I know about the configuration shortcut etc, but without my diagnostics report I fear you guys can not help me.

Thank you for your time,
Cleatus. 

Share this post


Link to post
Share on other sites

Hi, ensure you have the following installed (click the text below to be take to download links)

.NET Framework 3.5

.NET Framework 4.0

Visual C++ 2010 Redistributable 32-bit or 64-bit (this depends on the type of operating system your PC runs. To find out go to Start>Right click Computer>Left click properties and you should see some thing that looks similar to this:

 

8ae0e315f181d78beb29a1a45d0e8a25.png

if it says "64-bit Operating System, download 64-bit and vice versa for 32-bit.) Once you've done that restart the diagnostics tool and you should be good to go.

Share this post


Link to post
Share on other sites

Hello, 

Thank you, this helped me a lot and i now have my diagnostics report. 

BEGIN *SIGNED* LCPD First Response Issue Report

Diagnostics Tool Version: 0.4.3
Operating system: Windows7 HomePremium (6.1.1.0 Build: 7601) Service Pack:Service Pack 1
System RAM (GB): 7.96
CPU cores: 4
NET Framework 4.0 installed: True
Visual C++ 2010 Redistributable installed: True
GTA IV - Installed: True
GTA IV - Install folder: C:Program Files (x86)SteamsteamappscommonGrand Theft Auto IVGTAIV
GTA IV - Version: 1, 0, 7, 0
GTA IV - Asi loader installed: True
GTA IV - Asi loader: DSOUND
GTA IV - Asi loader valid: True
GTA IV - C++ ScriptHook installed: True
GTA IV - C++ ScriptHook valid: True
GTA IV - C++ ScriptHook version: 0, 5, 1, 0
GTA IV - ScriptHookDotNet installed: True
GTA IV - ScriptHookDotNet valid: True
End of *SIGNED* LCPD First Response Issue Report
Digital signature: NroA/pb9I9IFW695EMjXgw==



Should I make another topic, or are you able to help me further? Now that I have done the diagnostics report, I cannot launch the GTAIV .exe file. I am trying to find out if this is because of the mod, or something else I have downloaded. When I click 'Play' through Steam, the Socialclub launcher appears and I type in my login etc, I click play through that and the window closes. My yellow outline around the my Steam icon, changes to blue after around 3-4 seconds. Hopefully my diagnostics report can help my problem? This problem with the GTAIV.exe has only appeared now, after doing the Diagnostics Report and download the stuff you told me too. Hopefully I don't have to mess around with my files, I could delete something I'm not meant too.

Thanks once again,
Cleatus. 

Share this post


Link to post
Share on other sites

 

Hello, 

Thank you, this helped me a lot and i now have my diagnostics report. 

BEGIN *SIGNED* LCPD First Response Issue Report

Diagnostics Tool Version: 0.4.3
Operating system: Windows7 HomePremium (6.1.1.0 Build: 7601) Service Pack:Service Pack 1
System RAM (GB): 7.96
CPU cores: 4
NET Framework 4.0 installed: True
Visual C++ 2010 Redistributable installed: True
GTA IV - Installed: True
GTA IV - Install folder: C:Program Files (x86)SteamsteamappscommonGrand Theft Auto IVGTAIV
GTA IV - Version: 1, 0, 7, 0
GTA IV - Asi loader installed: True
GTA IV - Asi loader: DSOUND
GTA IV - Asi loader valid: True
GTA IV - C++ ScriptHook installed: True
GTA IV - C++ ScriptHook valid: True
GTA IV - C++ ScriptHook version: 0, 5, 1, 0
GTA IV - ScriptHookDotNet installed: True
GTA IV - ScriptHookDotNet valid: True
End of *SIGNED* LCPD First Response Issue Report
Digital signature: NroA/pb9I9IFW695EMjXgw==

Should I make another topic, or are you able to help me further? Now that I have done the diagnostics report, I cannot launch the GTAIV .exe file. I am trying to find out if this is because of the mod, or something else I have downloaded. When I click 'Play' through Steam, the Socialclub launcher appears and I type in my login etc, I click play through that and the window closes. My yellow outline around the my Steam icon, changes to blue after around 3-4 seconds. Hopefully my diagnostics report can help my problem? This problem with the GTAIV.exe has only appeared now, after doing the Diagnostics Report and download the stuff you told me too. Hopefully I don't have to mess around with my files, I could delete something I'm not meant too.

Thanks once again,

Cleatus. 

 

Hmm as far as I can see there's nothing wrong with any mods. Try reinstalling the game, also before installing any mods make sure the game can run. Then install all of your previous mods one by one (install one run the game to see if it works then install another, just keep repeating that step for all of your mods). That way you'll be able to tell what mod is causing you game to crash.

Share this post


Link to post
Share on other sites

Hmm as far as I can see there's nothing wrong with any mods. Try reinstalling the game, also before installing any mods make sure the game can run. Then install all of your previous mods one by one (install one run the game to see if it works then install another, just keep repeating that step for all of your mods). That way you'll be able to tell what mod is causing you game to crash.

Ok, I will reinstall GTA IV. LCPDFR is the only mod I have installed. Thank you for your help!

Share this post


Link to post
Share on other sites

Ok, I will reinstall GTA IV. LCPDFR is the only mod I have installed. Thank you for your help!

No probs

Share this post


Link to post
Share on other sites

No probs

Hello again,

The problem has stopped with launching the game but the alt+P still does not work, the screen goes blurry of course, but no stars show up on the map indicating police stations etc. Are there any circumstances that could cause this? Do i have to complete the game first or something like that?

Sorry for bothering you again,

Cleatus

Share this post


Link to post
Share on other sites

Hello again,

The problem has stopped with launching the game but the alt+P still does not work, the screen goes blurry of course, but no stars show up on the map indicating police stations etc. Are there any circumstances that could cause this? Do i have to complete the game first or something like that?

Sorry for bothering you again,

Cleatus

Hmm, do you have any mods that could conflict with key bindings? (such as Simple Native Trainer). Also, no you don't have to complete the game first.

Share this post


Link to post
Share on other sites

Hmm, do you have any mods that could conflict with key bindings? (such as Simple Native Trainer). Also, no you don't have to complete the game first.

No I don't have any other mods, and I have no clue what Simple Native Trainer is. Ok, that's good then. 

Share this post


Link to post
Share on other sites

No I don't have any other mods, and I have no clue what Simple Native Trainer is. Ok, that's good then. 

 

Could you please check whether the file ScriptHookDotNet.log is created in your game root folder when lauching the game? If so, please paste its content here.

Share this post


Link to post
Share on other sites

I have ScriptHookDotNet.asi and AdvancedHook.dll and that's it. 

 

If no ScriptHookDotNet.log is created you are most likely missing the dependencies for it. Either reinstall all dependencies or use dependecy walker (http://www.dependencywalker.com/) on ScriptHookDotNet.asi and ScriptHook.dll to check whether you are missing any files (those are marked in the tool then).

 

ScriptHookDotNet.asi needs the following:

 

KERNEL32.DLL

SCRIPTHOOK.DLL

MSVCR100.DLL (might be the missing one)

USER32.DLL

D3DX9_43.DLL (might also be missing)

MSCOREE.DLL

 

Note: Error about IESHIMS.DLL missing can be ignored.

Share this post


Link to post
Share on other sites

I have KERNEL32.DLL

          SCRIPTHOOK.DLL
          MSVCR100.DLL
          USER32.DLL
          MSCOREE.DLL

                                          D3DX9_37.DLL, that's got a red circle with a black '!' in it,

D3DX9_43.DLL < I can't find this one 

What does the Yellow circle and black '?' mean?

 

Edited by Cleatus

Share this post


Link to post
Share on other sites

Try this one please: http://www.microsoft.com/downloads/details.aspx?FamilyID=a7b7a05e-6de6-4d3a-a423-37bf0912db84

 

And this: http://www.microsoft.com/en-us/download/details.aspx?id=35

 

If it still doesn't work, please download xliveless from http://www.gtaforums.com/?showtopic=388658. Remove dsound.dll from your game folder and copy xlive_d.dll inside. Then rename it to xlive.dll. Launch the game as usual, if the screen still only goes blurry, please paste the content of the xlive.log here.

Share this post


Link to post
Share on other sites

Try this one please: http://www.microsoft.com/downloads/details.aspx?FamilyID=a7b7a05e-6de6-4d3a-a423-37bf0912db84

 

And this: http://www.microsoft.com/en-us/download/details.aspx?id=35

 

If it still doesn't work, please download xliveless from http://www.gtaforums.com/?showtopic=388658. Remove dsound.dll from your game folder and copy xlive_d.dll inside. Then rename it to xlive.dll. Launch the game as usual, if the screen still only goes blurry, please paste the content of the xlive.log here.

I have downloaded the things you have told me to, some of them i already had, and i have copied the xlive_d.dll and renamed it to xlive.dll and yet the screen still goes blurry, Also, all of my save-games have disappeared but it's not a big problem i was only around 40% into the game. I can not find an 'xlive.log'.

Share this post


Link to post
Share on other sites

I have downloaded the things you have told me to, some of them i already had, and i have copied the xlive_d.dll and renamed it to xlive.dll and yet the screen still goes blurry, Also, all of my save-games have disappeared but it's not a big problem i was only around 40% into the game. I can not find an 'xlive.log'.

 

Screen of your game folder please.

Share this post


Link to post
Share on other sites

Screen of your game folder please.

Here it is, hopefully all the files are shown in this layout. I'm unsure what the size will be, if you have to download it too see it larger then I hope it's not a problem. 

Share this post


Link to post
Share on other sites

Alright, post xlive_trace content please.

26/07/2013 20:36:55.623 Log started (xliveless 0.999b7)

26/07/2013 20:36:55.624 GetModuleHandle returns 00f80000
26/07/2013 20:36:55.624 [EXE] unprotecting section '.text': addr = 0x00001000, size = 0x0094c000
26/07/2013 20:36:55.624 [EXE] unprotecting section '.rdata': addr = 0x0094d000, size = 0x001bf000
26/07/2013 20:36:55.624 Patching OK (1.0.7.0 - update 7)
26/07/2013 20:36:55.624 Error loading library 32
26/07/2013 20:36:55.624 plugin loader: loaded 'ScriptHookDotNet.asi'
26/07/2013 20:36:55.920 XLiveInitializeEx
26/07/2013 20:36:55.920 XNetStartup
26/07/2013 20:36:55.920 XWSAStartup 
26/07/2013 20:36:59.313 XLiveOnCreateDevice
26/07/2013 20:36:59.313 XOnlineStartup
26/07/2013 20:36:59.313 xlive_5270: XNotifyCreateListener (0x0000000000000001)
26/07/2013 20:36:59.313 xlive_5270: XNotifyCreateListener (0x0000000000000007)
26/07/2013 20:36:59.313 xlive_5263: XUserGetName (0, .. , 16)
26/07/2013 20:36:59.313 xlive_5263: XUserGetName (0, .. , 16)
26/07/2013 20:36:59.313 xlive_5270: XNotifyCreateListener (0x0000000000000001)
26/07/2013 20:36:59.313 xlive_5270: XNotifyCreateListener (0x0000000000000002)
26/07/2013 20:36:59.520 XNotifyPositionUI (1)
26/07/2013 20:37:09.488 xlive_5270: XNotifyCreateListener (0x0000000000000001)
26/07/2013 20:37:21.788 xlive_5263: XUserGetName (0, .. , 16)
26/07/2013 20:37:21.788 xlive_5263: XUserGetName (0, .. , 16)
26/07/2013 20:37:21.790 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegames'
26/07/2013 20:37:21.799 XLiveContentCreateEnumerator
26/07/2013 20:37:21.811 XEnumerate (buffer=> 02249B70[0])
26/07/2013 20:37:21.839 XUserSetContextEx
26/07/2013 20:37:21.839 XGetOverlappedExtendedError
26/07/2013 20:37:21.896 XUserReadProfileSettings (0, 0, 8, ..., 0, ...)
26/07/2013 20:37:21.896 XUserReadProfileSettings (0, 0, 8, ..., 1036, ...)
26/07/2013 20:37:21.897 XUserCreateAchievementEnumerator (dwStartingIndex=>0, cItem=>80 
26/07/2013 20:37:21.899 XGetOverlappedResult
26/07/2013 20:37:21.899 XCreateSocket (2, 2, 254)
26/07/2013 20:37:22.976 XUserSetContextEx
26/07/2013 20:37:22.976 XGetOverlappedExtendedError
26/07/2013 20:37:23.973 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegames'
26/07/2013 20:37:23.983 XUserWriteProfileSettings
26/07/2013 20:37:23.984 XGetOverlappedResult
26/07/2013 20:37:23.984 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegames'
26/07/2013 20:37:23.984 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesControlMap.dat'
26/07/2013 20:37:23.985 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA400'
26/07/2013 20:37:24.029 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA412'
26/07/2013 20:37:24.086 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA400'
26/07/2013 20:37:24.086 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA400'
26/07/2013 20:37:24.090 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA412'
26/07/2013 20:37:24.090 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA412'
26/07/2013 20:37:24.097 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegames'
26/07/2013 20:37:24.097 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesControlMap.dat'
26/07/2013 20:37:24.098 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA400'
26/07/2013 20:37:24.099 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA412'
26/07/2013 20:37:24.100 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA412'
26/07/2013 20:37:24.106 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA412'
26/07/2013 20:37:24.122 XLiveCreateProtectedDataContext
26/07/2013 20:37:24.122 XLiveQueryProtectedDataInformation
26/07/2013 20:37:24.122 XLiveUnprotectData (..., 12, ..., 0, 1)
26/07/2013 20:37:24.123 XLiveUnprotectData (..., 12, ..., 12, 1)
26/07/2013 20:37:24.124 XLiveCloseProtectedDataContext
26/07/2013 20:37:36.743 XTitleServerCreateEnumerator (cItem=> 8)
26/07/2013 20:37:42.915 XUserSetContext
26/07/2013 20:37:42.915 XUserSetContext
26/07/2013 20:37:42.915 XUserSetContextEx
26/07/2013 20:37:42.915 XGetOverlappedExtendedError
26/07/2013 20:37:49.460 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegames'
26/07/2013 20:37:49.460 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesControlMap.dat'
26/07/2013 20:37:49.461 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA400'
26/07/2013 20:37:49.462 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA412'
26/07/2013 20:37:49.474 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA400'
26/07/2013 20:37:49.474 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA400'
26/07/2013 20:37:49.488 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA412'
26/07/2013 20:37:49.488 [getSavefilePath]: 'C:UsersWindowsDocumentsRockstar GamesGTA IVsavegamesSGTA412'

I hope this is what you need, but whilst we were doing this I thought i would delete all my LCPDFR files from my PC, and reinstall them along with my GTAIV, it was a spur of the moment thing, but it didn't help. I have reinstalled all the required things, but with my diagnostics report this happens instead

BEGIN *SIGNED* LCPD First Response Issue Report

Diagnostics Tool Version: 0.4.3
Operating system: Windows7 HomePremium (6.1.1.0 Build: 7601) Service Pack:Service Pack 1
System RAM (GB): 7.96
CPU cores: 4
NET Framework 4.0 installed: True
Visual C++ 2010 Redistributable installed: True
GTA IV - Installed: True
GTA IV - Install folder: C:Program Files (x86)SteamsteamappscommonGrand Theft Auto IVGTAIV
GTA IV - Version: 1, 0, 7, 0
GTA IV - Asi loader installed: False
GTA IV - Asi loader: 
GTA IV - Asi loader valid: False
GTA IV - C++ ScriptHook installed: True
GTA IV - C++ ScriptHook valid: True
GTA IV - C++ ScriptHook version: 0, 5, 1, 0
GTA IV - ScriptHookDotNet installed: True
GTA IV - ScriptHookDotNet valid: True
End of *SIGNED* LCPD First Response Issue Report
Digital signature: 9Q5Lxts5vaDHcqjbuLfrfQ==

Share this post


Link to post
Share on other sites

The error for loading the librabry is ERROR_SHARING_VIOLATION. Now I don't really know why this happens. Is this log before or after you decided to reinstall everything? Please make sure you only either have dsound.dll or xlive.dll in your folder, not both.

Share this post


Link to post
Share on other sites

After I decided to reinstall everything. Even when i only have xlive.dll it the screen still turns blurry.

Edited by Cleatus

Share this post


Link to post
Share on other sites

After I decided to reinstall everything. Even when i only have xlive.dll it the screen still turns blurry.

That's bad because we can't find the first issue then. Delete dsound.dll and put the debug xlive_d.dll inside (and rename again) and post the xlive_trace.log again.

Share this post


Link to post
Share on other sites

This may be a superfluous point, but make sure you are not running the Steam exe, use the LaunchGTAIV.exe (or LaunchEFLC.exe, whatever the case).  That is located in your root game folder, and I can tell you first hand it run better, smoother and without the crashing (as often anyhow).  

 

I have noticed big issues with the Steam exe, that I don;t have with the LaunchGTAIV.exe (LaunchEFLC.exe in my case).

 

Good luck,

 

DrDetroit

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×