Jump to content
Sign in to follow this  
cp702

Texture which doesn't suit setting

Recommended Posts

When I try to export from Zmodeler, I get a ton of errors along the lines of "using texture foo which doesn't suit the setting for shader bar". Anyone know what causes them and how to fix them?

Share this post


Link to post
Share on other sites

That means your materials aren't setup the right way. They need to be in this order:

Your basic texture (UV#1 Mod)

Your dirt texture (UV#2 M/A)

Your nrm texture (UV#1 DontProduct3)

Your spec texture (UV#1 Spec M/A)

Uncheck the nrm afterwards. All of the materials must be setup like that.

Share this post


Link to post
Share on other sites

Uncheck the nrm afterwards. All of the materials must be setup like that.

Not completely true. That's the setup for mesh materials and is also possible or at least similar for vehglass or lightsemissive.

Different material shaders need different setup, compare with default vehicles for correct setttings.

Share this post


Link to post
Share on other sites

Also, if there are a lot of materials with the same name, is that a problem?

Share this post


Link to post
Share on other sites

Not completely true. That's the setup for mesh materials and is also possible or at least similar for vehglass or lightsemissive.

Different material shaders need different setup, compare with default vehicles for correct setttings.

Agreed.

Also, if there are a lot of materials with the same name, is that a problem?

Yes. Certainly.

Share this post


Link to post
Share on other sites

Yes. Certainly.

Actually not, as you maybe even require different settings (dirtmap, specmap etc.). Although, you could try to get the vehicle use only one of them, as unused materials won't be exported.

Share this post


Link to post
Share on other sites

Actually not, as you maybe even require different settings (dirtmap, specmap etc.). Although, you could try to get the vehicle use only one of them, as unused materials won't be exported.

I believe he asked about materials not textures?

Share this post


Link to post
Share on other sites

I believe he asked about materials not textures?

Yes, he did. But a material contains different textures. The material name is the name of the first texture and the shader. If you have for example two generic materials with different specmaps, the first texture will stay the same and only the last would change. But they have the same name.

Share this post


Link to post
Share on other sites

Yes, he did. But a material contains different textures. The material name is the name of the first texture and the shader. If you have for example two generic materials with different specmaps, the first texture will stay the same and only the last would change. But they have the same name.

I'm catching your drift. However, I don't think zmod will allow exporting it that way.I might be wrong tho.

Share this post


Link to post
Share on other sites

I'm catching your drift. However, I don't think zmod will allow exporting it that way.I might be wrong tho.

It does. It is even possible to export with wrong material setups, but this will give warnings.

Share this post


Link to post
Share on other sites

It does. It is even possible to export with wrong material setups, but this will give warnings.

Just like the ones in OPs post.

Share this post


Link to post
Share on other sites

Just like the ones in OPs post.

Exactly. In the most cases, the model works without visible problems anyway. Although it's recomment to try fixing them.

Edited by Cj24

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×