Jump to content
jarjarbinx123

Game crashes shortly after clicking 'Start'.

Recommended Posts

Like the title says, my game crashes about one-two load screens after I click start. Once, I got as far as "The Cousins Bellic" load screen after the graphic artscreens.

Windows error report states:

Files that help describe the problem: C:UsersdcjwleeAppDataLocalTempWER1D57.tmp.hdmp

Diagnostics show no problems. I followed all instructions when trying both dsound and xlive .dll's, making sure to delete the former before re-installing.

I checked my computer>rockstar>grand theft auto 4 and all subfolders to read only OFF.

I checked that my computter>rockster>grand theft auto 4>scripts contained an LCDFR folder and two other obscure items I can't remember right now.

I run the game as an administrator using the LAUNCHGTAIV app from the GTA4 folder in 'my computer'.

Here are my diagnostic reports.

All help is appreciated. I have the 360 version and I bought the PC version solely to try LCPDFR and PP. New to PC gaming so please go easy on me.

____________________________________________________________________________

With dsound

BEGIN *SIGNED* LCPD First Response Issue Report

Diagnostics Tool Version: 0.4.3

Operating system: Windows7 HomePremium (6.1.1.0 Build: 7601) Service Pack:Service Pack 1

System RAM (GB): 8

CPU cores: 6

NET Framework 4.0 installed: True

Visual C++ 2010 Redistributable installed: True

GTA IV - Installed: True

GTA IV - Install folder: C:Program Files (x86)Rockstar GamesGrand Theft Auto IV

GTA IV - Version: 1, 0, 7, 0

GTA IV - Asi loader installed: True

GTA IV - Asi loader: DSOUND

GTA IV - Asi loader valid: True

GTA IV - C++ ScriptHook installed: True

GTA IV - C++ ScriptHook valid: True

GTA IV - C++ ScriptHook version: 0, 5, 1, 0

GTA IV - ScriptHookDotNet installed: True

GTA IV - ScriptHookDotNet valid: True

===============BEGIN .NET SCRIPTHOOK LOG===============

2012-05-05 23:36:32 - Initializing ScriptHookDotNet v1.7.1.4 BETA (GTA IV version 1.0.7.0)

2012-05-05 23:37:56 - Direct3D device created!

2012-05-05 23:37:56 - SEARCHING FOR SCRIPTS...

2012-05-05 23:37:56 - Loading scripts in Assembly 'scriptsFirstResponse.net.dll' ...

2012-05-05 23:37:56 - ...found script '0.LCPDFR-Obfuscated-13'!

2012-05-05 23:37:56 - ...found script '0.LCPDFR-Obfuscated-5'!

2012-05-05 23:37:56 - ...found script '0.LCPDFR-Obfuscated-16'!

2012-05-05 23:37:56 - ...found script '0.LCPDFR-Obfuscated-1'!

2012-05-05 23:37:56 - ...found script '0.3.LCPDFR-Obfuscated-0'!

2012-05-05 23:37:56 - ...found script '0.3.LCPDFR-Obfuscated-1'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-8'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-14'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-9'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-11'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-10'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-13'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-2'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-4'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-15'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-3'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-12'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-6'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-5'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-0'!

2012-05-05 23:37:56 - ...found script '0.1.LCPDFR-Obfuscated-7'!

2012-05-05 23:37:56 - ...found script '1.0.LCPDFR-Obfuscated-0'!

2012-05-05 23:37:56 - ...found script '0.2.LCPDFR-Obfuscated-1'!

2012-05-05 23:37:56 - ...found script '0.2.LCPDFR-Obfuscated-0'!

2012-05-05 23:37:56 - DONE! 24 valid scripts found!

2012-05-05 23:37:56 - STARTING SCRIPTS...

2012-05-05 23:37:56 - Error during GetPhoneNumber (Phone checks will be disabled):

System.Exception: Accessing Globals failed! Invalid Memory Address!

at unmanaged.MemoryAccess.GetGlobalAddress(Int32 index)

at unmanaged.MemoryAccess.GetPhoneNumber()

at GTA.NetHook.CheckPhone()

2012-05-05 23:37:56 - ...successfully started script '0.2.LCPDFR-Obfuscated-0'!

2012-05-05 23:37:56 - ...successfully started script '0.2.LCPDFR-Obfuscated-1'!

2012-05-05 23:37:56 - Unhandled Exception: System.IO.FileNotFoundException: Could not load file or assembly 'System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

File name: 'System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'

at 0.LCPDFR-Obfuscated-6.1()

at 0.LCPDFR-Obfuscated-6.0(Object A_0)

at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)

at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)

at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()

at System.Threading.ThreadPoolWorkQueue.Dispatch()

at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

WRN: Assembly binding logging is turned OFF.

To enable assembly bind failure logging, set the registry value [HKLMSoftwareMicrosoftFusion!EnableLog] (DWORD) to 1.

Note: There is some performance penalty associated with assembly bind failure logging.

To turn this feature off, remove the registry value [HKLMSoftwareMicrosoftFusion!EnableLog].

2012-05-05 23:37:56 - CRASH!

2012-05-05 23:37:56 - Unhandled Exception: System.IO.FileNotFoundException: Could not load file or assembly 'System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

File name: 'System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'

at 0.LCPDFR-Obfuscated-6.1()

at 0.LCPDFR-Obfuscated-6.0(Object A_0)

at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)

at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)

at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()

at System.Threading.ThreadPoolWorkQueue.Dispatch()

at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

WRN: Assembly binding logging is turned OFF.

To enable assembly bind failure logging, set the registry value [HKLMSoftwareMicrosoftFusion!EnableLog] (DWORD) to 1.

Note: There is some performance penalty associated with assembly bind failure logging.

To turn this feature off, remove the registry value [HKLMSoftwareMicrosoftFusion!EnableLog].

2012-05-05 23:37:56 - CRASH!

===============END .NET SCRIPTHOOK LOG===============

===============BEGIN LCPD FIRST RESPONSE LOG===============

[5/5/2012 11:15:30 PM] [sTATISTICS] System.Net.WebException: The remote server returned an error: (404) Not Found.

at System.Net.HttpWebRequest.GetResponse()

at 0.1.LCPDFR-Obfuscated-12.0.4(Object A_0)

[5/5/2012 11:37:56 PM] [sTATISTICS] System.Net.WebException: The remote server returned an error: (404) Not Found.

at System.Net.HttpWebRequest.GetResponse()

at 0.1.LCPDFR-Obfuscated-12.0.4(Object A_0)

===============END LCPD FIRST RESPONSE LOG===============

End of *SIGNED* LCPD First Response Issue Report

Digital signature: PE1EzYqlEtHt+geOhLeaVA==

Edited by dcjwlee

Share this post


Link to post
Share on other sites

I just got as far as to see Niko popping a squat in front of the door in his cousin's apartment. Then the game froze and crashed.

Uninstalled LCPDFR and the game works fine. Would still like to figure this out though.

Edited by dcjwlee

Share this post


Link to post
Share on other sites

Yes, as I mentioned, I am running as admin using the LAUNCHGTAIV app in the rockstar folder.

I have now gotten as far as one step out of my hideout before the game crashes.

I have also turned off UAC

Update: I have noticed that I cannot keep the GTA 4 folder as read only OFF. Re-installing GTAIV running as admin to see if this fixes the issue. Tried taking it out of the program files folder to see if that was the cause, but that created other problems. Again, UAC is OFF. I am running nearly everything as admin.

MODERATOR NOTICE

Don't double post, instead of creating a new post, edit your previous one instead, posts merged. -JAM

Edited by JAM-Justin35

Share this post


Link to post
Share on other sites

I Need Help First thing when my game starts up it crashed not even to do any thing need help

and how to uninstall lcpdfr

Share this post


Link to post
Share on other sites

I Need Help First thing when my game starts up it crashed not even to do any thing need help

and how to uninstall lcpdfr

Do not attempt to hijack this topic. Instead, if you do have problems with the mod, make your own topic. Please read the stickies/pinned posts provided and make sure there isn't another topic that already solves your issue. This makes the forum moderators' jobs easier and doesn't enrage the rest of the community.

Edited by wmai20

Share this post


Link to post
Share on other sites

Looking at your log, you have one or more dependencies missing.

Install both of these, even if you think you already have them try anyway as people often have the wrong version:

http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=a7b7a05e-6de6-4d3a-a423-37bf0912db84&displaylang=en

Share this post


Link to post
Share on other sites

Tom H,

Thanks for your reply. Interestingly enough, later in the night after I fiddled around with trying to get the file to read only and moving it around, the diagnostics tool showed a few x's instead of checks. I ended up installing the same .NET framework update that you linked and getting it to work. I guess I should have double checked but I DID check my update history to see that C++ and .NET had been updated recently and ran the diagnostics which showed I had the correct version.

Anyways, not sure what happened, but I'm glad to be on.

...smh APX. NIce first post.

HERE IS HOW TO UNINSTALL LCPDFR

CLICK ANY LINK: http://lmgtfy.com/?q=uninstall+lcpdfr

Go to the folder with GTA IV installed on it and delete the "scripts" folder, dsounds.dll OR xlive.dll (depending on which you installed), and advancedhook.dll

I'm sure you could get it to work with a little bit of patience though.

Mods? I think this case can be closed?

Share this post


Link to post
Share on other sites

Tom H,

Thanks for your reply. Interestingly enough, later in the night after I fiddled around with trying to get the file to read only and moving it around, the diagnostics tool showed a few x's instead of checks. I ended up installing the same .NET framework update that you linked and getting it to work. I guess I should have double checked but I DID check my update history to see that C++ and .NET had been updated recently and ran the diagnostics which showed I had the correct version.

Anyways, not sure what happened, but I'm glad to be on.

...smh APX. NIce first post.

HERE IS HOW TO UNINSTALL LCPDFR

CLICK ANY LINK: http://lmgtfy.com/?q=uninstall+lcpdfr

Go to the folder with GTA IV installed on it and delete the "scripts" folder, dsounds.dll OR xlive.dll (depending on which you installed), and advancedhook.dll

I'm sure you could get it to work with a little bit of patience though.

Mods? I think this case can be closed?

I'm glad you got it working. Enjoy.

P.S - The mods usually will close the thread when they come across it or someone starts thread hijacking.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×