Jump to content

Recommended Posts

I downloaded GTA 4 off of Steam. I downloaded LCPDFR .95 RC2 and installed all of the nescessary files.(.net 4, visual c++2010 etc) The automatic downloader downloads the files (for LCPDFR) and places them in the folders in Program files(x86)/steam/steamapps/Grand Theft Auto IV/GTAIV. I tried the mod first with only dsound and then with only xliveless and when I perss alt+p, nothing happens. What am I doing wrong? Please help. i am using 1.0.7.0.

Share this post


Link to post
Share on other sites
Guest Andrew.   
Guest Andrew.

run the diagnostics tool and post the results here

Share this post


Link to post
Share on other sites

BEGIN *SIGNED* LCPD First Response Issue Report

Diagnostics Tool Version: 0.4.3

Operating system: Windows7 HomePremium (6.1.1.0 Build: 7601) Service Pack:Service Pack 1

System RAM (GB): 3.98

CPU cores: 4

NET Framework 4.0 installed: True

Visual C++ 2010 Redistributable installed: False

GTA IV - Installed: True

GTA IV - Install folder: C:Program Files (x86)SteamsteamappscommonGrand Theft Auto IVGTAIV

GTA IV - Version: 1, 0, 7, 0

GTA IV - Asi loader installed: True

GTA IV - Asi loader: DSOUND

GTA IV - Asi loader valid: True

GTA IV - C++ ScriptHook installed: True

GTA IV - C++ ScriptHook valid: True

GTA IV - C++ ScriptHook version: 0, 5, 1, 0

GTA IV - ScriptHookDotNet installed: True

GTA IV - ScriptHookDotNet valid: True

End of *SIGNED* LCPD First Response Issue Report

Digital signature: TXsCWOKwzPrJhdfysgXq+g==

Share this post


Link to post
Share on other sites
Guest Andrew.   
Guest Andrew.

Visual C++ 2010 Redistributable installed: False

You should have that installed also....Do you have any 3rd party mods?

Share this post


Link to post
Share on other sites

Visual C++ 2010 Redistributable installed: False

Please refer to

also to go on duty you need to press the left Alt key then P

Edited by Asuna

Share this post


Link to post
Share on other sites

The mod doesnt work. The game crashes after a while and says "GTA IV FATAL ERROR: ZLIB20: Invalid resource detected- Please reinstall the game. -5. IDK what to do. I am using dsound instead of xliveless and i am always signed into windows live. Should I be using Xliveless instead? I have installed visuall c++ 2010 redistributable.

Share this post


Link to post
Share on other sites

you have a corrupted file in your game, you need to reinstall your game. did you install C++2010 (x86)? as your diagnostic doesn't register c++2010, you need to use the x86 version, not the x64

Share this post


Link to post
Share on other sites

I am in the proccess of re-downloading the game now. I had the 86 version but it was not detected. Does it have to be in a special folder? I will start over from the very beginning. Does the fact that I am only at mission #2 make a difference?

Share this post


Link to post
Share on other sites

Does the fact that I am only at mission #2 make a difference?

No it doesn't make any difference.

Share this post


Link to post
Share on other sites

ok. would this be easier with the disk version instead of steam version? why would the diagnostic tool not be able to locate the visual c++ 2010 redistributeable? does it need to be in the GTAIV folder?

Share this post


Link to post
Share on other sites

ok. would this be easier with the disk version instead of steam version? why would the diagnostic tool not be able to locate the visual c++ 2010 redistributeable? does it need to be in the GTAIV folder?

No, it needs to be installed separate to GTA and not just placed in the folder. Download this, and once it has finished just double click it and follow the on-screen instructions.

Share this post


Link to post
Share on other sites

Ok. When the download for GTA4 is finished, I will complete the first mission and then i will save. I will then list a step by step in a post in this topic of what I think I should do in order to fully install and use lcpdfr. This will come within 2 hours. Then, once one of you very helpful people approve my method, i will go ahead and start. I will post my results when I am finished. Thank God you guys know a lot more than I do. I appreciate all of you taking time out of your lives to help me to be able to enjoy this mod. Thank you!

Share this post


Link to post
Share on other sites

Ok. I have created a save file between missions 1 and 2. I will now list the procedure. I will not act until told to by one of you guys who will approve my plan.

1. I will first download visual c++2010 redistributeable package(x86). I will run the setup and follow the instructions in the installation wizard.

2. I will then install LCPDFR .95 RC2. I will follow the setup wizard for that. I have the rest of the files necessary(.net version 4, legitamate copy, games for windows.)(I will use dsound and NOT xliveless.)

3. I will launch my game and press alt+p to go on duty.

My questions:

1. Does the visual c++2010 package need to be in any particular folder or can it be where the installation wizard puts it?

Notes:

1. All programs will be run by clicking "Run as administrator"

Please respond as to whether this should work.

Share this post


Link to post
Share on other sites

OK. The game works fine but I still cannot go on patrol. Now, the diagnostics tool wont even detect my gta4 game. It still says that c++ 2010 is not installed! IDK what to do now! please Help!!!!!

Edited by a B1G newb xxx

Share this post


Link to post
Share on other sites

Yes. The files for the mod are there. In the scripts folder there is a folder titled LCPDFR and two other documents. in the main folder there is dsound, advanced hook.dll, amb_nailgun.wdr and .wtd, asilog, liblua.51, lua4net script hook.dll, and scripthookdotnet.asi. please compare this with your configuration.

Share this post


Link to post
Share on other sites

GTAIV, btw...if you place the diagnostic in the folder with the gta files...it should find it and are you using Left Alt+p?

Edited by Asuna

Share this post


Link to post
Share on other sites

GTAIV, btw...if you place the diagnostic in the folder with the gta files...it should find it and are you using Left Alt+p?

Sorry but that isn't true. It doesn't matter where the diagnostics tool is placed.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×