Jump to content
Sign in to follow this  
MooHamOinkBeef21

Strange LSPDFR Crash

Recommended Posts

I've been getting some pretty frequent crashes after .3 and usually I'm pretty good about looking at the logs and finding the problem plugin but. 

 

Spoiler

[1/19/2016 11:43:52 AM.286] LSPD First Response: 
[1/19/2016 11:43:52 AM.286] LSPD First Response: ==============================
[1/19/2016 11:43:52 AM.286] LSPD First Response: UNHANDLED EXCEPTION DURING GAME THREAD TICK
[1/19/2016 11:43:52 AM.287] LSPD First Response: ------------------------------
[1/19/2016 11:43:52 AM.287] LSPD First Response: Origin: Game fiber "<UNNAMED THREAD>".
[1/19/2016 11:43:52 AM.287] LSPD First Response: ------------------------------
[1/19/2016 11:43:52 AM.288] LSPD First Response: Exception type: Rage.Exceptions.InvalidHandleableException
[1/19/2016 11:43:52 AM.288] LSPD First Response: Exception message: Operation is not valid because the specified  Rage.Ped is invalid.
[1/19/2016 11:43:52 AM.288] LSPD First Response: ------------------------------
[1/19/2016 11:43:52 AM.288] LSPD First Response: Inner exceptions:
[1/19/2016 11:43:52 AM.288] LSPD First Response: ------------------------------
[1/19/2016 11:43:52 AM.288] LSPD First Response: Stack trace:
[1/19/2016 11:43:52 AM.289] LSPD First Response: at Rage.Entity.get_Model()
[1/19/2016 11:43:52 AM.289] at ?????????????????????????????????????????.?????????????????????????????????????????(Ped ) in E:\GTA V\LSPD First Response\LSPD First Response\Engine\Scripting\Functions.cs:line 1241
[1/19/2016 11:43:52 AM.289] at LSPD_First_Response.Engine.Scripting.Entities.Persona.?????????????????????????????????????????() in E:\GTA V\LSPD First Response\LSPD First Response\Engine\Scripting\Entities\Persona.cs:line 193
[1/19/2016 11:43:52 AM.289] at LSPD_First_Response.Engine.Scripting.Entities.Persona..ctor(Ped ped) in E:\GTA V\LSPD First Response\LSPD First Response\Engine\Scripting\Entities\Persona.cs:line 70
[1/19/2016 11:43:52 AM.289] at ?????????????????????????????????????????..ctor(Ped ped) in E:\GTA V\LSPD First Response\LSPD First Response\Engine\Scripting\Entities\CPed.cs:line 90
[1/19/2016 11:43:52 AM.289] at NK7>L$j\&2e\&6)>yunUnF\&_I{'.?????????????????????????????????????????(Ped ) in E:\GTA V\LSPD First Response\LSPD First Response\Engine\Scripting\Entities\CPedCache.cs:line 31
[1/19/2016 11:43:52 AM.289] at ?????????????????????????????????????????.?????????????????????????????????????????(????????????????????????????????????????? ) in E:\GTA V\LSPD First Response\LSPD First Response\Mod\SuspectTransportManager.cs:line 195
[1/19/2016 11:43:52 AM.289] at ?????????????????????????????????????????.?????????????????????????????????????????() in E:\GTA V\LSPD First Response\LSPD First Response\Mod\SuspectTransportManager.cs:line 89
[1/19/2016 11:43:52 AM.289] at Rage.GameFiber.Main()
[1/19/2016 11:43:52 AM.290] LSPD First Response: ==============================
[1/19/2016 11:43:52 AM.290] LSPD First Response: 
 

It seems looking at this that the crash might be from the prisoner transport called after an NPC cop arrest, I'm not sure and would greatly appreciate some help in this matter.

Share this post


Link to post
Share on other sites

I have spoken to a few people about this crash including albo and they seem to think its associated with 0.3 itself. might just have to wait for a hotfix.  its not prisoner transport crashing it - it just happens to be running at the time of the crash.

albos comment in spoiler.


1a60908ab9.png

 

Edited by TheDude

Share this post


Link to post
Share on other sites
22 minutes ago, TheDude said:

I have spoken to a few people about this crash including albo and they seem to think its associated with 0.3 itself. might just have to wait for a hotfix.  its not prisoner transport crashing it - it just happens to be running at the time of the crash.

Hmmm interesting, thanks for the info.

Share this post


Link to post
Share on other sites
42 minutes ago, TheDude said:

I have spoken to a few people about this crash including albo and they seem to think its associated with 0.3 itself. might just have to wait for a hotfix.  its not prisoner transport crashing it - it just happens to be running at the time of the crash.

It appears to be some sort of bug in LSPDFR 0.3's transport manager. I'm not saying their code is bad, but in all these errors being reported, there is no reference to any third party plugins in the stack trace.

@LMS or @Sam may be able to check into it for us, but I'm not sure how difficult it is to reproduce. In the (albeit, limited) time I have played 0.3, I have not had this error happen.

Share this post


Link to post
Share on other sites
9 minutes ago, Stealth22 said:

It appears to be some sort of bug in LSPDFR 0.3's transport manager. I'm not saying their code is bad, but in all these errors being reported, there is no reference to any third party plugins in the stack trace.

@LMS or @Sam may be able to check into it for us, but I'm not sure how difficult it is to reproduce. In the (albeit, limited) time I have played 0.3, I have not had this error happen.

Yeah that's what I was thinking it did happen right after an NPC cop arrest at the end of a pursuit so I'm thinking it's something do with the NPCs calling prisoner transports.

Share this post


Link to post
Share on other sites

yeah for me it seems to always happen when they transports a suspect, generally as soon as the car is out of LOD range the game will crash. perhaps its has to do with vehicle.meta edits?

Share this post


Link to post
Share on other sites
2 hours ago, TheDude said:

yeah for me it seems to always happen when they transports a suspect, generally as soon as the car is out of LOD range the game will crash. perhaps its has to do with vehicle.meta edits?

If you look at the crash log, it refers to a Ped being invalid. Which means that, if this is caused by LSPDFR 0.3, the car goes out of range and gets despawned, along with all the peds inside. Script tries to access one of said Peds (without checking if it exists), and boom, crash.

Share this post


Link to post
Share on other sites
12 minutes ago, Stealth22 said:

If you look at the crash log, it refers to a Ped being invalid. Which means that, if this is caused by LSPDFR 0.3, the car goes out of range and gets despawned, along with all the peds inside. Script tries to access one of said Peds (without checking if it exists), and boom, crash.

yah i just thought that maybe because some of my custom cars have different lods then default that perhaps the script might be trying to access something that when developed/tested worked fine but under edited circumstances doesnt. perhaps the core game is cleaning them up before lspd gets a chance to?

Edited by TheDude

Share this post


Link to post
Share on other sites

This also happened to me when i leave the suspect dead at the location and driving away without cleaning up the scene by calling the coroner. I changed my playing habits a bit and I managed to play for an hour without the game crashing by making the arrests myself and clearing the scene using the Police Radio Checker to call the coroners for the bodies and towing away unoccupied cars that are blocking the roads. It's what a normal police officer would have to do before ending their call to be available for a new call anyways. It's just not as fun when it's not action packed. The only time it crashed was when I spam the X button to look for new calls i wanted to take. Otherwise it seems fine using this method. Hope my method works for you too. 

Share this post


Link to post
Share on other sites

Mine did the "????????" When crashing as well, yesterday, while performing a traffic stop, after the driver's check came back. It's probably just a situation where a hot fix is needed; doubt that your mods are the cause of it. I would just go to your console and type "force duty" and continue your patrols for now. 

Share this post


Link to post
Share on other sites

I'm not sure but....

 [1/19/2016 11:43:52 AM.289] at ?????????????????????????????????????????.?????????????????????????????????????????(Ped ) in E:\GTA V\LSPD First Response\LSPD First Response\Engine\Scripting\Functions.cs:line 1241 


 

What that's E:\GTA V\LSPD First Response\LSPD First Response\Engine\Scripting\Functions.cs? I don't even have a E: drive. Is taht correct?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×