Jump to content
Sign in to follow this  
hlsavior

Can't attach in Zmodeler

Recommended Posts

For some reason i can't simply drag my lightbar model into the chassis. If that didn't make sense here are some pics.
 
This is the lightbar name (renamed to extra_9 for the chassis):
7fd5f7520e290c1a3f8388ffd96920a5.png?136
this is the chassis that i cant attach the lightbar too. (I'm dragging extra_9 into chassis, it flickers for about a milisecond, then nothing happens and nothing changes)
b890e79e8de010544eb25abc4c7c441b.png?136
heres a video:

http://www.youtube.com/watch?v=UsJXbZCnG0I

Share this post


Link to post
Share on other sites

you can rename the lightbar to extra_9... it conflicts with the extras in it change it to Misc_z or something

Share this post


Link to post
Share on other sites

you can rename the lightbar to extra_9... it conflicts with the extras in it change it to Misc_z or something

 

Changing the name didn't help the fact that i cant drag what object into the chassis hierarchy.

Share this post


Link to post
Share on other sites

you need to import textures before working on a model, always

also your dummies are messed up, they should be blue boxes not purple thingys

as for attaching stuff you cant attach it because the mesh isn't under the correct parent

for you to be able to attach what ever to chassis you would need to put it under chassis dummy and not extra 9 as extra 9 dummy would be it's parent dummy and not chassis dummy, also i would recommend attaching your lightbar to the chassis as it will extremely difficult to edit the model once you've attached it.

Share this post


Link to post
Share on other sites

you need to import textures before working on a model, always

also your dummies are messed up, they should be blue boxes not purple thingys

as for attaching stuff you cant attach it because the mesh isn't under the correct parent

for you to be able to attach what ever to chassis you would need to put it under chassis dummy and not extra 9 as extra 9 dummy would be it's parent dummy and not chassis dummy, also i would recommend attaching your lightbar to the chassis as it will extremely difficult to edit the model once you've attached it.

 

My textures are all imported

Share this post


Link to post
Share on other sites

it doesnt look like so

your car was completely white and everything you were working with as well

your car would be invisible if you tried to spawn it ingame

 

All the vshare files are imported, all the files in the .wtd for the car and lightbar are imported. The interior of the car is textured fyi

 

EDIT:

I'm a complete noob at this and am attempting this from putting together a few minor tutorials. I honestly have no idea whats dummies are but I am currently looking them up. If you guys know of any tutorials or shit like that please inform me.  <3 xox

Edited by hlsavior

Share this post


Link to post
Share on other sites

from the looks of the picture you've provided i've come to an conculsion

when you imported the model you didnt have sliced model check, that's curcial to the model showing up properly

also when importing make sure all your textures are in the same format, dds or png or tga

as for attaching stuff drag the mesh, whatever it's called and put it under chassis, the dummy right after the wft dummy

once you've done that your good to be able to attach whatever your wishing to attach to the chassis_L0

 

Share this post


Link to post
Share on other sites

from the looks of the picture you've provided i've come to an conculsion

when you imported the model you didnt have sliced model check, that's curcial to the model showing up properly

also when importing make sure all your textures are in the same format, dds or png or tga

as for attaching stuff drag the mesh, whatever it's called and put it under chassis, the dummy right after the wft dummy

once you've done that your good to be able to attach whatever your wishing to attach to the chassis_L0

 

I didnt really understand what you just said. Like what do you mean by "the dummy right after the wft dummy"

Edited by hlsavior

Share this post


Link to post
Share on other sites

Okay currently everything is working except when i turn the lights on they dont flash, the light appears, but i know thats just els, the lightbars dont flash.

Share this post


Link to post
Share on other sites

Okay currently everything is working except when i turn the lights on they dont flash, the light appears, but i know thats just els, the lightbars dont flash.

NickieB's tutorial sums up modeling for a new person quite well.

 

If you follow that perfectly you shouldnt have any issues. 

Modeling is a lot easier when you get a little bit of help and do it on your own and then troubleshoot on your own.

When help is only given and you dont try on your own, it makes it harder to learn(I didnt learn much until I actually tried fixing my problems).

 

Good luck

Share this post


Link to post
Share on other sites

NickieB's tutorial sums up modeling for a new person quite well.

 

If you follow that perfectly you shouldnt have any issues. 

Modeling is a lot easier when you get a little bit of help and do it on your own and then troubleshoot on your own.

When help is only given and you dont try on your own, it makes it harder to learn(I didnt learn much until I actually tried fixing my problems).

 

Good luck

 

I know you said use trial and error but that tutorial didnt help me in the slightest, I don't have any of the names he [Nickie] said.

This is whats in mine:

28ca75367e817945bb2adeccfba7b19d.png?136

Share this post


Link to post
Share on other sites

Okay im starting to really get pissed at Zmodeler. Now whenever i import anything ay all, lightbar, car, any model at all i get purple dummies. Every single texture is in. Why the fyling F**k is this happening.

Share this post


Link to post
Share on other sites

i've specifically told multiple times already

WHEN YOU IMPORT A MODEL MAKE SURE YOU HAVE SLICED MODEL CHECKED OR ELSE YOU WILL HAVE PURPLE DUMMIES.

you shouldnt have any other wft dummy other then the car model dummy, meaning rename the lightbar dummy to something else

also you need to rename the meshes under that lightbar dummy to something else or else they'll mess up ingame

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×