Jump to content

Attaching extras in Zmodeler


Illusionyary

This tutorial only applies to vehicles with multiple extras.

Once we have the vehicle setup to our liking, we'll want to attach the extras together so ELS will actually work in-game.

First things first, check to see if the lighting equipment has any "helper" (or similar) folders within the main folder itself. As you can see, there are two helper folders here.

yapc0SN.png

Drag these helper folders out of the main equipment folder (in this case WhelenEdge and Whelen_Talon) above the vehicle model (police.wft).

2VK1iep.png

Once the helper folders are no longer inside the main equipment folder(s), proceed to delete the equipment folder(s) (this is not a requirement, but it keeps things tidy) by right clicking on the folder and selecting edit/delete.

33425J4.png

Open up the helper folders, as you can see there are multiple extra 1 and extra 4 folders. These are what we will be attaching (only attach the extras if there is more than one set). At this point, decide which light bar will be the "main" one you will attach everything to. For this tutorial, I have selected the Whelen Edge (the second helper folder) as the main light bar.

KthVqsD.png

Open the extra folders, inside you should see a extra_L0 file. Drag the extra_L0 files out of this folder and into the main light bar (WhelenEdge) extras folder.

I2THZIi.png

You should now see duplicate extra_L0 files.

Flcs7lJ.png

Right click on the main light bar folder (WhelenEdge) and select "Show isolated", this will hide all other layers/folders but the one selected.

9ilfQVB.png

The hierarchy and view panels should know look like this... and oh no! The car is gone! Don't worry, this is perfectly fine.

k3G7l5c.png

Now hide the main light bar base (the actual bar itself, not the extras - these should be named differently). You should end up with a view like this.

E12oMO0.png

Under the tools tab on the left hand side of your screen, click on modify and then click attach.

Hadyua7.png

Making sure Selective Mode is off (keyboard shortcut - space-bar), attach the extras to each other (extra_1_L0 to extra_1_L0 and extra_4_L0 to extra_4_L0, ect) by clicking on the secondary (talon) extras and selecting the primary (edge) extras.

S8dKwxQ.png

The duplicate extra_L0 files should now disappear from your hierarchy. This means you have successfully attached the extras together.

34TCGOi.png

Right click on the main light bar and click "show the rest". This should reveal all hidden layers/folders.

eqDqklE.png

The extras folders (where you took the extra_L0 files from) can now be deleted (once again, this isn't required, but it keeps things neat and tidy).

O2S3dhC.png

If the vehicle has any sub folders inside the lighting equipment folders (as shown, there is a misc_g folder inside the talon helper folder), drag them out and delete the original folder. At this point, rename any folders that are named the same (in this case I've changed "helper" to edge).

PI1vGfA.png

Place the lighting equipment folders (edge and misc_g) inside the vehicle model hierarchy folder.

ERNlJcb.png

Because the lights are mounted on the roof and dash of this vehicle, they're fine to sit under the chassis_L2 file, however this is dependent on the lighting position (ex: if you have lights in the grill, they should go inside the "bonnet" folder. NOTE: Always make sure the extra_L0 files are above the lighting equipment model, such as the base/stand, itself!).

fEi0Jy3.png

Hopefully this tutorial helped you. If you have any questions, please leave them below and I will try my best to answer them. :)



User Feedback

Recommended Comments

my lights flash white not red and blue

 

Import your light textures using openIV/SparkIV. Once that is done, go into your game then activate your lights. Your lights should be flashing multiple colours.

Share this comment


Link to comment
Share on other sites

Import your light textures using openIV/SparkIV. Once that is done, go into your game then activate your lights. Your lights should be flashing multiple colours 

 

it would overwrite my els for my main though

Share this comment


Link to comment
Share on other sites

im trying to add a watch guard camera for the unlocked harris county tx impala. i cant seem to move the camera into positon using zmodeler2.

Share this comment


Link to comment
Share on other sites

when i did everything and worked and no issues then when i go in game the lightbar worked but not the little beacon that i put behind it

Share this comment


Link to comment
Share on other sites

Thanks for this! Extremely good and very detailed tutorial. Thank you so much! Will probably upload a picture with my first car that i just made where i used your tutorial.

Share this comment


Link to comment
Share on other sites

my grill lights are white why

​You either mapped them incorrectly or didn't assign textures to them.

Edited by Illusionary

Share this comment


Link to comment
Share on other sites
On 6/12/2015 at 8:52 AM, krazzy said:

at the end of ur tutorial i have extras 1 9 left should i delete them 

U makin an impala?

Edited by Insanatix

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×