Jump to content
espfutbol98

Light texture problem from released cars

Recommended Posts

Hello, I'm having a problem that it seems some others were having as well. Basically it looks like the textures for lights aren't aligned for some reason and this is been happening with cars from multiple authors. Some cars work perfectly but others have problems. I've replaced and installed new cars hundreds of times, I know the drill. I follow the instructions to the letter and properly update the carvariations as well as the yft and ytd files but I still have the problem. Here are some pictures of what I'm talking about:
 

Spoiler

 

2.jpg.f091d3d539c29fabde4dc355eca838e4.j

3.jpg.fd2783c7bb656c2402d4358e52bc7c2c.j4.jpg.18d71493ff5a679aa934b2c43e86aabb.j1.jpg.97268be65e933a2a95318c594c219867.j

 

 

Share this post


Link to post
Share on other sites

Hmm. Have you started fresh from a new mod folder lately? It might help considering you said you have installed hundreds of cars, just rename your old mod folder to something else in case you want to go back to it easily. Its most likely a problem with a carvarations or a vehicle.meta file that was altered along the way during one of your other skin installs. I had a problem similar to this back in GTA IV and ultimately I had to restore back to default and re add everything one at a time until I figured out where I had made the mistake. Perhaps someone smarter then myself will actually know how to fix your problem though. *fingers crossed*

Also If you run the game vanilla are all the light textures ok or are they all offset as well?

Share this post


Link to post
Share on other sites

It looks to me like a problem with your carvariations.meta file. You must've installed the cars on-top of other ones without adding the carvariations.meta for that specific car. A friend of mine was having this problem beforehand, and restoring carvariations and adding the appropriate entries for each car seemed to do the trick. TheDude was on the right track I suppose! If that doesn't solve your problem, do the same with the vehicles.meta file and see if that works out for you.

Edited by Lunasious
No reason.

Share this post


Link to post
Share on other sites

I thought that might be the problem so I searched through every carvariations.meta and either made sure it didn't have a police/police3/[or whichever] section and if it did I updated it. The only problem is I only just now started using the mods folder with the latest OpenIV update so I can't really just rename a folder. I'm thinking it might be a problem with vehicles.meta but like I said, I don't have an original. Would you be able to post the police, police3, and fbi sections of the vehicles.meta?

Share this post


Link to post
Share on other sites

Due to the Plagiarism & Copyright Guidelines, I'm not sure I can post those due to a matter of infringement and/or EULA or something of the sort. It's the GTA files itself, so I'm pretty sure that's against Rockstar's redistribution policies or something of the sort. I'M just being pre-cautious. Though you can try Verifying your Steam Cache to gain the original files back. Keep in mind though, that doing so will remove all the mods in your game.

Edited by Lunasious

Share this post


Link to post
Share on other sites
1 minute ago, espfutbol98 said:

Okay, yeah, that's what I'm trying to avoid. No worries.

a google search might be able to net you those files also ;)

Share this post


Link to post
Share on other sites
1 hour ago, espfutbol98 said:

I managed to find the original vehicles.meta entries and update each vehicles.meta file in the game using the search function but still no luck.

Have you tried the same with the carvariations.meta file? That's most likely your problem.

Share this post


Link to post
Share on other sites

This is a problem with your carvariations.meta file. Make sure you add the correct carvariations file and rename it to whatever slot you are using. For example:

If it says "<modelName>police</modelName>" and you are using the car in the sheriff2 slot, rename police to sheriff2

 

Share this post


Link to post
Share on other sites

If the carvariations.meta file is set up correctly, then you shouldn't be having a problem with your game. All of the problems in your screenshots suggest something is wrong with your carvariations.meta file.

Share this post


Link to post
Share on other sites

I just searched through all 18 of the carvariations.meta files and only found one reference to police and police3, and none to fbi. Can anyone confirm that the standard install (including patches and updates) doesn't include carvariations for these cars?

Share this post


Link to post
Share on other sites
47 minutes ago, espfutbol98 said:
47 minutes ago, espfutbol98 said:

I just searched through all 18 of the carvariations.meta files and only found one reference to police and police3, and none to fbi. Can anyone confirm that the standard install (including patches and updates) doesn't include carvariations for these cars?

I just searched through all 18 of the carvariations.meta files and only found one reference to police and police3, and none to fbi. Can anyone confirm that the standard install (including patches and updates) doesn't include carvariations for these cars?

I believe they reside with the sheriff cars and some of the other police vehicles in x64a/data. Unfortunately it is a ymt file and cannot be altered to the best of my knowledge.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×