Jump to content
Rodri.zz

Open iv only showing "police" and "police4" (ingame) How do i fix this

Recommended Posts

ok guys so i finally got open iv to somewhat work but now when i go to change the cars in game only  "police" and "police4" show up as the ones i change the others are generic gta police cars. So in the mods folder i put x64, update.rpf and x64e so when i open open iv i click x64e then i got to the cars then i change the files so when i do that only police4 and police show up IN GAME 


Enrique Rodriguez

Director of Regional Roleplay

 

  

Share this post


Link to post
Share on other sites

Are you in the right directory? 

x64e.rpf -----> levels -----> gta5 -----> vehicles.rpf

What I do is copy and paste the unmodified GTA 5 folder from steamapps, to my desktop, just as a backup. Then I would start modifying the files.

Share this post


Link to post
Share on other sites

Are you in the right directory? 

x64e.rpf -----> levels -----> gta5 -----> vehicles.rpf

What I do is copy and paste the unmodified GTA 5 folder from steamapps, to my desktop, just as a backup. Then I would start modifying the files.

i got the retail but ya thats what i do but got this issiue


Enrique Rodriguez

Director of Regional Roleplay

 

  

Share this post


Link to post
Share on other sites

Is your copy with steam, or do you use the rockstar games launcher?

 

mine is retail and i use rageplugin to launch

I don't remember the exact path, but if you click the update folder, patch3ng, it should be pretty self explanatory from there.

thats what i usally do but there NOTHING changes when i change car files


Enrique Rodriguez

Director of Regional Roleplay

 

  

Share this post


Link to post
Share on other sites

I don't know if this will help you or not but when you replace the vehicles, click the "file" next to "edit" at the top. Press rebuild in that menu. Once that is done, it should show a line in the rebuild tool stating the name, location, and type of modified content. Double click that to make sure it is highlighted, then press rebuild. Once that is complete, it will say "open rebuilt archive?", press yes. Then go back to "file" at the top and select close all archives. Then close open iv and make sure it is not opened when you are in-game. This has happened to me before, so I used this method and it started working. Hope this helps.

Edited by patrickgom126

Share this post


Link to post
Share on other sites

For police2, sheriff, sheriff2  -> update\x64\dlcpacks\patchday3ng\dlc.rpf\levels\gta5\vehicles.rpf

For police3 -> update\x64\dlcpacks\patchday4ng\dlc.rpf\levels\gta5\vehicles.rpf

For police, police4 -> x64e.rpf\levels\gta5\vehicles.rpf

You're welcome.

Share this post


Link to post
Share on other sites

For police2, sheriff, sheriff2  -> update\x64\dlcpacks\patchday3ng\dlc.rpf\levels\gta5\vehicles.rpf

For police3 -> update\x64\dlcpacks\patchday4ng\dlc.rpf\levels\gta5\vehicles.rpf

For police, police4 -> x64e.rpf\levels\gta5\vehicles.rpf

You're welcome.

is this from mods folder?

 


Enrique Rodriguez

Director of Regional Roleplay

 

  

Share this post


Link to post
Share on other sites

That's for the .rpf files inside your GTA 5 directory.

When you replace the vehicles, click the "file" next to "edit" at the top. Press rebuild in that menu. Once that is done, it should show a line in the rebuild tool stating the name, location, and type of modified content. Double click that to make sure it is highlighted, then press rebuild. Once that is complete, it will say "open rebuilt archive?", press yes. Then go back to "file" at the top and select close all archives. Then close open iv and make sure it is not opened when you are in-game. This has happened to me before, so I used this method and it started working. Hope this helps.

Share this post


Link to post
Share on other sites

"open existing archive"? sorry man i suck at open iv thingz

That's for the .rpf files inside your GTA 5 directory.

When you replace the vehicles, click the "file" next to "edit" at the top. Press rebuild in that menu. Once that is done, it should show a line in the rebuild tool stating the name, location, and type of modified content. Double click that to make sure it is highlighted, then press rebuild. Once that is complete, it will say "open rebuilt archive?", press yes. Then go back to "file" at the top and select close all archives. Then close open iv and make sure it is not opened when you are in-game. This has happened to me before, so I used this method and it started working. Hope this helps.

"open existing archive"? sorry man i suck at open iv thingz


Enrique Rodriguez

Director of Regional Roleplay

 

  

Share this post


Link to post
Share on other sites

If you suck at OpenIV 'thingz', then maybe you should look for tutorials on Youtube first.

Edited by Hystery

Share this post


Link to post
Share on other sites

"open existing archive"? sorry man i suck at open iv thingz

"open existing archive"? sorry man i suck at open iv thingz

Open rebuilt archive, just follow the instructions and you should be fine.

Share this post


Link to post
Share on other sites

Did you modify "police" and "police4"?

If not, you might have to use a mod menu to spawn the vehicle, or some "traffic flow" script for gta 5. I don't know if they have one yet.

Edited by PatrickGomulka

Share this post


Link to post
Share on other sites

Did you modify "police" and "police4"?

If not, you might have to use a mod menu to spawn the vehicle, or some "traffic flow" script for gta 5. I don't know if they have one yet.

yea i modify and i tried to spawn in the vechicles and like i modified more than just "police" and "police4" but those the only ones that come up 


Enrique Rodriguez

Director of Regional Roleplay

 

  

Share this post


Link to post
Share on other sites

yea i modify and i tried to spawn in the vechicles and like i modified more than just "police" and "police4" but those the only ones that come up 

You apparently didn't look up for OpenIV tutorials (which should have been the BASICS before coming here and ask people for help but not understanding one bit of what we're talking about).

TO REPLACE OTHER POLICE VEHICLES. You need to replace them in the CORRECT folder. If you want to replace police and police4, you'll need to replace the police and police4 files in x64e.rpf\levels\gta5\vehicles.rpf

If you want to replace police2, sheriff and sheriff2, you'll need to replace the police2, sheriff and sheriff2 files in update\x64\dlcpacks\patchday3ng\dlc.rpf\levels\gta5\vehicles.rpf

If you want to replace police3, you'll need to replace the police3 files in update\x64\dlcpacks\patchday4ng\dlc.rpf\levels\gta5\vehicles.rpf

If you're using a mods folder (which you should), just copy and paste the files above to the mods folder before modifying them with OpenIV. From there, if you still don't get what I'm saying, I can't do anything anymore and you should quit modding your game until you finally decide to look for TUTORIALS on Youtube.

Edited by Hystery

Share this post


Link to post
Share on other sites

You apparently didn't look up for OpenIV tutorials (which should have been the BASICS before coming here and ask people for help but not understanding one bit of what we're talking about).

TO REPLACE OTHER POLICE VEHICLES. You need to replace them in the CORRECT folder. If you want to replace police and police4, you'll need to replace the police and police4 files in x64e.rpf\levels\gta5\vehicles.rpf

If you want to replace police2, sheriff and sheriff2, you'll need to replace the police2, sheriff and sheriff2 files in update\x64\dlcpacks\patchday3ng\dlc.rpf\levels\gta5\vehicles.rpf

If you want to replace police3, you'll need to replace the police3 files in update\x64\dlcpacks\patchday4ng\dlc.rpf\levels\gta5\vehicles.rpf

If you're using a mods folder (which you should), just copy and paste the files above to the mods folder before modifying them with OpenIV. From there, if you still don't get what I'm saying, I can't do anything anymore and you should quit modding your game until you finally decide to look for TUTORIALS on Youtube.

thank you for the help figured out what was wrong

Edited by Screw4DarthVader

Enrique Rodriguez

Director of Regional Roleplay

 

  

Share this post


Link to post
Share on other sites

I'm actually super annoyed by this, I see you guys giving this person a hard time for not knowing. I started modding my game again after not playing for a while and have had the same issue. I have not been able to find the correct paths for ANY of the cars until now and there is not a list I can find anywhere that tells me where to put the cars. Most of the mods have the old paths explained in their readme files and some don't even say anything. Thanks for the help in this thread though, it's at least somewhat helped me but if someone can point me in the direction of the rest of the police car locations, perfect.

The x64e location has all of the vehicles in it but not every single one uses that path when in game, or so it appears.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...