Jump to content
kingofwar20909

i cannot go on duty

Recommended Posts

i have seen some videos of this mod and it looks epic so i wanna try it but whenever i go in game i press alt-P and nothing happens, ive tried reinstalling LCPDFR multiple times, i reinstalled c++ and the .net framework, and reinstalled the game but still wont work. heres a G17 diagnostic.

 

BEGIN *SIGNED* LCPD First Response Issue Report
Diagnostics Tool Version: 0.4.3
Operating system: Windows7 Ultimate (6.1.1.0 Build: 7601) Service Pack:Service Pack 1
System RAM (GB): 15.9
CPU cores: 6
NET Framework 4.0 installed: True
Visual C++ 2010 Redistributable installed: True
GTA IV - Installed: True
GTA IV - Install folder: D:DownloadSteamLibrarysteamappscommonGrand Theft Auto IVGTAIV
GTA IV - Version: 1, 0, 7, 0
GTA IV - Asi loader installed: True
GTA IV - Asi loader: DSOUND
GTA IV - Asi loader valid: True
GTA IV - C++ ScriptHook installed: True
GTA IV - C++ ScriptHook valid: True
GTA IV - C++ ScriptHook version: 0, 5, 1, 0
GTA IV - ScriptHookDotNet installed: True
GTA IV - ScriptHookDotNet valid: True
End of *SIGNED* LCPD First Response Issue Report
Digital signature: 2Dd1FptmiCoGsxCLjKJpNw==
 
and before you ask yes i used left alt, i ran as administrator, blah, blah, blah. I have been looking through the forums for days now and still havent found a fix.
 
 
Oh ya and also i noticed that when i look in the scripts folder and then to LCPDFR the only things there is a file for audio, the version, and GUID. Is there suppost to be more stuff?
Edited by kingofwar20909

Share this post


Link to post
Share on other sites

there is no .log of that just a .asi with a bunch of gibberish

 

Do you have these files in your root/main GTA folder:

 

-ScriptHook.dll

-ScriptHookDotNet.asi

-dsound.dll.

-AdvancedHook.dll

 

or perhaps your could take a screenshot of the folder?

Share this post


Link to post
Share on other sites

Do you have these files in your root/main GTA folder:

 

-ScriptHook.dll

-ScriptHookDotNet.asi

-dsound.dll.

-AdvancedHook.dll

 

or perhaps your could take a screenshot of the folder?

and kyle look at the diagnostic at the top

Edited by kingofwar20909

Share this post


Link to post
Share on other sites

 

 

Hmm..alright.

I'm going to try to find if the problem is on the LCPD:FR mod or on the game itself.

 

Could you download and "install" GTA IV "Simple Trainer" and see if you can get it working?

Share this post


Link to post
Share on other sites

i just reinstalled GTAIV and LCPDFR and when i opened the game the resolution was super low and then froze in a loading screen, and then when i opened it again it was back to normal

Edited by kingofwar20909

Share this post


Link to post
Share on other sites

I have the exact same problem.

:L

 

Could you try to download and install Simple Native trainer and see if you can get it working?

I'll do my best to get it fixed.

Share this post


Link to post
Share on other sites

Since the ScriptHookDotNet.log is not created, I suspect it's a dependecy issue preventing it from being loaded correctly.

 

Please check these two posts: >Post #1 & >Post #2

Post the results of the action here please.

Share this post


Link to post
Share on other sites

Since the ScriptHookDotNet.log is not created, I suspect it's a dependecy issue preventing it from being loaded correctly.

 

Please check these two posts: >Post #1 & >Post #2

Post the results of the action here please.

I already have a ScriptHookDotNet.log, although I opened it up and noticed there were some errors while starting up the script. Could these be the problems?

2013-07-24 18:59:50 - STARTING SCRIPTS...
2013-07-24 18:59:50 - Error during GetPhoneNumber (Phone checks will be disabled):
                      System.Exception: Accessing Globals failed! Invalid Memory Address!
                         at unmanaged.MemoryAccess.GetGlobalAddress(Int32 index)
                         at unmanaged.MemoryAccess.GetPhoneNumber()
                         at GTA.NetHook.CheckPhone()

Share this post


Link to post
Share on other sites

 

I already have a ScriptHookDotNet.log, although I opened it up and noticed there were some errors while starting up the script. Could these be the problems?

2013-07-24 18:59:50 - STARTING SCRIPTS...
2013-07-24 18:59:50 - Error during GetPhoneNumber (Phone checks will be disabled):
                      System.Exception: Accessing Globals failed! Invalid Memory Address!
                         at unmanaged.MemoryAccess.GetGlobalAddress(Int32 index)
                         at unmanaged.MemoryAccess.GetPhoneNumber()
                         at GTA.NetHook.CheckPhone()

 

 

i did it on scripthookdotnet.asi and for a few things it says file not found and the cpu says x64 in red even though i have a 64-bit windows

 

If you guys are using DSOUND, try using xliveless. ASI loader might be the issue.

Share this post


Link to post
Share on other sites

i did it on scripthookdotnet.asi and for a few things it says file not found and the cpu says x64 in red even though i have a 64-bit windows

 

Please post a screenshot of the tool.

 

I already have a ScriptHookDotNet.log, although I opened it up and noticed there were some errors while starting up the script. Could these be the problems?

2013-07-24 18:59:50 - STARTING SCRIPTS...
2013-07-24 18:59:50 - Error during GetPhoneNumber (Phone checks will be disabled):
                      System.Exception: Accessing Globals failed! Invalid Memory Address!
                         at unmanaged.MemoryAccess.GetGlobalAddress(Int32 index)
                         at unmanaged.MemoryAccess.GetPhoneNumber()
                         at GTA.NetHook.CheckPhone()

 

This error shouldn't matter, please post the full log.

Share this post


Link to post
Share on other sites

Please post a screenshot of the tool.

 

This error shouldn't matter, please post the full log.

2013-07-26 09:19:19 - Initializing ScriptHookDotNet v1.7.1.4 BETA (GTA IV version 1.1.2.0)
2013-07-26 09:20:25 - Direct3D device created!

2013-07-26 09:20:25 - SEARCHING FOR SCRIPTS...
2013-07-26 09:20:25 - Loading scripts in Assembly 'scriptsFirstResponse.net.dll' ...
2013-07-26 09:20:25 -  ...found script 'FirstResponse.Main.EmergencyLights'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.Main.Start'!
2013-07-26 09:20:25 -  ...found script 'CSharp.Engine.Core'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.Debugging'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.DeletionList'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.Hardcore'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.TextDraw'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCMD.Main'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCMD.Functions'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCPD.Carboot'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCPD.Disarm'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCPD.Frisk'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCPD.PullOver'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCPD.Actions'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCPD.Debug'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCPD.Flashlight'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCPD.Functions'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCPD.Partner'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCPD.inputSimulator'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCPD.Start'!
2013-07-26 09:20:25 -  ...found script 'FirstResponse.LCPD.Various'!
2013-07-26 09:20:25 - DONE! 21 valid scripts found!

2013-07-26 09:20:25 - STARTING SCRIPTS...
2013-07-26 09:20:25 - Error during GetPhoneNumber (Phone checks will be disabled):
                      System.Exception: Accessing Globals failed! Invalid Memory Address!
                         at unmanaged.MemoryAccess.GetGlobalAddress(Int32 index)
                         at unmanaged.MemoryAccess.GetPhoneNumber()
                         at GTA.NetHook.CheckPhone()
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCPD.Various'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCPD.Start'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCPD.inputSimulator'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCPD.Partner'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCPD.Functions'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCPD.Flashlight'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCPD.Debug'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCPD.Actions'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCPD.PullOver'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCPD.Frisk'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCPD.Disarm'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCPD.Carboot'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCMD.Functions'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.LCMD.Main'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.TextDraw'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.Hardcore'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.DeletionList'!
2013-07-26 09:20:25 -  ...successfully started script 'FirstResponse.Debugging'!
2013-07-26 09:20:26 -  ...successfully started script 'CSharp.Engine.Core'!
2013-07-26 09:20:26 -  ...successfully started script 'FirstResponse.Main.Start'!
2013-07-26 09:20:26 -  ...successfully started script 'FirstResponse.Main.EmergencyLights'!

I decided to install it on EFLC aswell to see if that would fix the problem, but the same thing is happening.

Perhaps its got something to do on my side?

 

NVidia GTX 670 2gb

8gb RAM

Intel i5 3.1GHz

Razer Deathstalker Ultimate keyboard

Razer Naga mouse

 

It might have something to do with the keyboard I use or something.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×