Jump to content
Guest

ScriptHookV error

Recommended Posts

Guest   
Guest

Hello.

I've recently installed GTA V again and when I try to use the latest version of ScriptHookV the game says its not supported when it is in fact up to date.
Could someone help me? 

Thanks,

Jessica

Share this post


Link to post
Share on other sites
3 hours ago, JazzyJessica said:

Hello.

I've recently installed GTA V again and when I try to use the latest version of ScriptHookV the game says its not supported when it is in fact up to date.
Could someone help me? 

Thanks,

Jessica

 

What is the version of your gta V? 1493.1?

Did you put script hook and dinput.dll in your main gta 5 directory? 

 

Share this post


Link to post
Share on other sites

GTA5 just had a recent update again...… hoping this isn't the issue or else Rockstar version users are SOL for a few weeks.

Share this post


Link to post
Share on other sites
Guest   
Guest
5 hours ago, Mikeh370 said:

GTA5 just had a recent update again...… hoping this isn't the issue or else Rockstar version users are SOL for a few weeks.

Yeah, it seems like its updating every week lol (I'm exaggerating). 

9 hours ago, Pav500 said:

 

What is the version of your gta V? 1493.1?

Did you put script hook and dinput.dll in your main gta 5 directory? 

 

1.0.1493.1 According to GTA V.exe. Now the problem is my LaunchGTAV.exe says1.0.1493.0. How do I fix this?
Also, I put dinput8.dll in my directory. 

Edited by Guest

Share this post


Link to post
Share on other sites
5 hours ago, JazzyJessica said:

Yeah, it seems like its updating every week lol (I'm exaggerating). 

1.0.1493.1 According to GTA V.exe. Now the problem is my LaunchGTAV.exe says1.0.1493.0. How do I fix this?
Also, I put dinput8.dll in my directory. 

you simply delete that .exe and verify your steam game cache, it auto downloads.

Share this post


Link to post
Share on other sites
Guest   
Guest
4 minutes ago, Pav500 said:

you simply delete that .exe and verify your steam game cache, it auto downloads.

I have a retail copy, not a steam one.

Share this post


Link to post
Share on other sites
1 minute ago, JazzyJessica said:

I have a retail copy, not a steam one.

Non-Steam versions of GTAV:

  1. Select "Start", "Run", and type "cmd" without the quotes.
  2. Hit enter.
  3. Type "cd c:\Program Files\Rockstar Games\Grand Theft Auto V" (without the quotes) in the cmd window.
    1. Note: If you’ve installed the game to a different directory, enter that directory path instead.
  4. Hit enter.
  5. Type "GTAVLauncher.exe -verify" (without the quotes)
  6. Hit enter.

Share this post


Link to post
Share on other sites
Guest   
Guest

Command prompt error: 'GTAVLauncher.exe' is not recognized as an internal or external command,
operable program or batch file.  

Thanks for the help,

Jessica

@Pavy

Share this post


Link to post
Share on other sites
10 minutes ago, JazzyJessica said:

Command prompt error: 'GTAVLauncher.exe' is not recognized as an internal or external command,
operable program or batch file.  

Thanks for the help,

Jessica

@Pavy

https://www.youtube.com/watch?v=JRBZ0q1UrpM

Double check you have the latest scripthookV files too.
http://www.dev-c.com/gtav/scripthookv/

 

Edited by Pavy

Share this post


Link to post
Share on other sites
7 minutes ago, JazzyJessica said:

I appreciate all your help. I tried to verify my game files and stuff, and I guess everything went ok but I got this error: image.png.c2f1d6b518760713c173b8f52fd103a3.png   I'm going to make sure my SHV is up to date. If it's not, what should I do?

 

If your game is up to date, and you get that error even after updating ScriptHook V, I recommend clean installing SHV.

Share this post


Link to post
Share on other sites
13 minutes ago, JazzyJessica said:

I appreciate all your help. I tried to verify my game files and stuff, and I guess everything went ok but I got this error: image.png.c2f1d6b518760713c173b8f52fd103a3.png   I'm going to make sure my SHV is up to date. If it's not, what should I do?

 

 

In some cases Gio is correct, but he didn't spot the discrepancy in your image.

Since you say you were successful in updating your game, you would be on 1.0.1493.1
The scripthookV image says support version 1.0.1493.0 Thats the previous version. You didn't correctly install the latest scripthookV 

Edited by Pavy

Share this post


Link to post
Share on other sites
Guest   
Guest
1 minute ago, Pavy said:

 

 

Since you say you were successful in updating your game, you would be on 1493.1
The scripthookV image says support version 1.0.1493.0 Thats the previous version. You didn't correctly install the latest scripthookV 

Ok
Heres some info so you can help me better:

1) My GTAV.exe is 1.0.1493.1 whereas my GTAVLauncher.exe is 1.0.1493.0. Is this an issue?

2) How do I correctly install script hook so I don't mess it up again because I'm pretty darn sure I did it right. 


Thanks again.

Share this post


Link to post
Share on other sites
Just now, JazzyJessica said:

Ok
Heres some info so you can help me better:

1) My GTAV.exe is 1.0.1493.1 whereas my GTAVLauncher.exe is 1.0.1493.0. Is this an issue?

2) How do I correctly install script hook so I don't mess it up again because I'm pretty darn sure I did it right. 


Thanks again.

You simply copy over everything inside the download from http://www.dev-c.com/gtav/scripthookv/

and drag it into the main directory and Click Replace All. You can remove the native trainer you don't need that it's optional.

 

As for the GtaVlauncher.exe Cut that exe out of the folder and verify your game again. It will download the missing file and make it 1493.1

Share this post


Link to post
Share on other sites
Guest   
Guest
14 minutes ago, Pavy said:

You simply copy over everything inside the download from http://www.dev-c.com/gtav/scripthookv/

and drag it into the main directory and Click Replace All. You can remove the native trainer you don't need that it's optional.

 

As for the GtaVlauncher.exe Cut that exe out of the folder and verify your game again. It will download the missing file and make it 1493.1

I don't need trainer stuff right? I have one already.

Share this post


Link to post
Share on other sites
17 minutes ago, Pavy said:

You can remove the native trainer you don't need that it's optional.

 

Share this post


Link to post
Share on other sites
Guest   
Guest

@Pavy Ok, and just load GTA V like I normally would with RPH right?

Share this post


Link to post
Share on other sites

Well, you don't launch Gta5 and rage hook together.
You simply run ragepluginhook.exe and that is all. Gta 5 will launch automatically. 

Share this post


Link to post
Share on other sites
Guest   
Guest

@Pavy My launcher.exe's version is now: 1.0.1365.1 and my gtav.exe is 1.0.1493.1 Grrr. What do I do?

Share this post


Link to post
Share on other sites
22 minutes ago, JazzyJessica said:

@Pavy My launcher.exe's version is now: 1.0.1365.1 and my gtav.exe is 1.0.1493.1 Grrr. What do I do?

Does that scripthook error still pop-up when launching ragepluginhook.exe?

Edited by Pavy

Share this post


Link to post
Share on other sites
Guest   
Guest

@Pavy @Giordano @Mikeh370 My game is finally working.
Thank you all so much for your help. 

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×