Jump to content
Sign in to follow this  
Jaime

install fails

Recommended Posts

Ok I am trying to install the mod, I do have ELS (should be V6) installed and it works find, mark 7 siren mod, works find with a few ELS enabled cars for GTA4, as far as im aware i have the latest patch for the game which is 1.0.7 or something like that, so I tried to install the mod and the installer keeps saying I should post this in the forums so here I am, making a post, I have attached the log dump that I was instructed to post by the installer below. im installing the 0.95 beta version if that helps anyone.

If someone would be able to assist me in figureing whats going on I would appreciate the help!!

Here is the info.

Installation component 'CppScriptHook' error'd!

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath)

at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)

at System.IO.File.WriteAllBytes(String path, Byte[] bytes)

at G17MediaSetupEngine.Stuff.ExtractResourceToPath(String resourceName, String destName, Boolean pureres)

at G17MediaSetupEngine.Stuff.ExtractResourceToPath(String resourceName, String destName)

at G17MediaSetupEngine.Installation_Components.CScriptHook.beginComponent()

at G17MediaSetupEngine.UI.Interface.wizardControl1_SelectedPageChanged(Object sender, EventArgs e)

at G17MediaSetupEngine.UI.Interface.wizardControl1_SelectedPageChanged(Object sender, EventArgs e)

again thanks for the help and hope to figure this out soon so i can try this mod my self! thanks!!!

EDIT: update, I got rid of every thing that i could find and tried the stable version (0.91) and that has appeared to install ok, I will now be testing to see if game play is effected at all and will reports at all, then I will try to upgrade to the 0.95 to see if issues still persist.

(P.S. I appoligize if this is too much info, but I used to be a beta tester as well alpha tester for other software/mods so I am used to providing as detailed reports as possible...please forgive me LOL!!!)

Edited by Jaime

Share this post


Link to post
Share on other sites

Installation component 'CppScriptHook' error'd!

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath)

at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)

at System.IO.File.WriteAllBytes(String path, Byte[] bytes)

at G17MediaSetupEngine.Stuff.ExtractResourceToPath(String resourceName, String destName, Boolean pureres)

at G17MediaSetupEngine.Stuff.ExtractResourceToPath(String resourceName, String destName)

at G17MediaSetupEngine.Installation_Components.CScriptHook.beginComponent()

at G17MediaSetupEngine.UI.Interface.wizardControl1_SelectedPageChanged(Object sender, EventArgs e)

at G17MediaSetupEngine.UI.Interface.wizardControl1_SelectedPageChanged(Object sender, EventArgs e)

This problem has been reported a myriad of times on this forum. You should have read the stickies first, as you would have found an answer right away.

But anyways, the solution to this problem is simple. Make sure that your game's root directory isn't marked as "read-only." To check for this, go to your game's install folder, right-click it, and look at the "Attributes" section near the bottom. Make sure that "read-only" is unchecked. After that, right-click on the installer program, click on "Properties" in the drop-down menu, go to the "Compatibility" tab, and then check "Run program as Administrator" near the bottom. Once you've done all this, the install should go smoothly and before you know it, you'll be enjoying LCPD:FR. ;) Be sure to also apply the same "Run as Admin" settings to LaunchGTAIV.exe for the mod to work.

im installing the 0.95 beta version if that helps anyone.

Since you are playing on patch 1.0.7.0 of GTA IV, I don't see a reason why you would want to use LCPD:FR 0.95 Beta 1, as that version is less stable and has less features as LCPD:FR 0.95 RC2, which is the current release. I only know of people (such as myself) who use the LCPD:FR 0.95 Beta 1 only because they are playing on patch 1.0.4.0. Also, if the steps above don't work out, then follow the other sticky and post a diagnostic report for further troubleshooting.

EDIT: update, I got rid of every thing that i could find and tried the stable version (0.91) and that has appeared to install ok, I will now be testing to see if game play is effected at all and will reports at all, then I will try to upgrade to the 0.95 to see if issues still persist.

This should only happen if you are attempting to install LCPD:FR 0.95 RC2, not LCPD:FR 0.95 Beta 1. And you won't have this problem for LCPD:FR 0.91 Stable because there were several new features added to LCPD:FR 0.95 RC2, such as a separate taser weapon model, that requires additional modding of the game's files, hence the need for admin privileges.

Hope this helps! Report back if you have any additional problems.

Edited by Raggio

Share this post


Link to post
Share on other sites

My bad it was the RC2 I was tring to install before, I installed the .91 and were no go there, im gonna try to install 95RC2 again and see if doing it in admin mode helps as I do have win 7 so that may be a possibility here. I also have a character mod for Niko if thats also important.

Nope, tried to "run as administrator" and were still a no go there....here is the error log as it gave me.

Installation component 'CppScriptHook' error'd!

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath)

at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)

at System.IO.File.WriteAllBytes(String path, Byte[] bytes)

at G17MediaSetupEngine.Stuff.ExtractResourceToPath(String resourceName, String destName, Boolean pureres)

at G17MediaSetupEngine.Stuff.ExtractResourceToPath(String resourceName, String destName)

at G17MediaSetupEngine.Installation_Components.CScriptHook.beginComponent()

at G17MediaSetupEngine.UI.Interface.wizardControl1_SelectedPageChanged(Object sender, EventArgs e)

at G17MediaSetupEngine.UI.Interface.wizardControl1_SelectedPageChanged(Object sender, EventArgs e)

Edited by Jaime

Share this post


Link to post
Share on other sites

some one I know had the same issue, the only way he fixed it was uninstall GTAIV, then reinstall it...bother some...but thats what worked for him ,mind you ..this is a suggestion

Share this post


Link to post
Share on other sites

well if needed Ill do that, will hate to have to reopen all the islands before modding but what ever...its a shot I guess...would prefer if possible not to...

Share this post


Link to post
Share on other sites

Nope, tried to "run as administrator" and were still a no go there....

Did you also try it with your directories not marked as "read-only" as I told you to? You did not state it above, so I'm just making sure.

Edited by Raggio

Share this post


Link to post
Share on other sites

reopening the islands is cake when you do it right...Simple Native trainer has an unlock all cheat

Share this post


Link to post
Share on other sites

well, yea, I could use that traoner, to speed it up, what the heck ;), and yes I did the whole bit about not being read only. still was no go, but uninstall and reinstall has the mod kinda working, not sure if I should make a new topic for this or not but I can "force duty" but I can't use the Alt+p to go on duty and select the police person I wish to use, using the LCPDFR 0.95RC2 so I looked and it appears to have installed correctly so not sure whats going on, random events DO happen, (already got busted for helping one) so yea now to figure out why I can't go on duty and select my police char...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×