Jump to content
Chris3281

Modding vehicles through OpenIV

Recommended Posts

Hey there, I've been trying to change out some of the police vehicles with different models for a while now and I keep getting a mixture of failed results. Either the game will load up and ill spawn the vehicle and the model will be completely outa whack. Like doors floating in mid air and tires spinning on the roof and so on. Alternatively, I'll spawn a model and the car will be the default GTA V model and nothing has changed. Yet, in both scenarios when I run OpenIV, and click on the vehicle files they are the vehicle models I changed them to. I've heard different things, am I supposed to change the models in my MODS folder or not? I've kinda done both at this point :tongue:. It's not 0.3 causing problems because i've been having trouble since i've downlaoded the mods a week or so ago. Still haven't quite figured out what I am doing wrong. Still, this mod at it's core is amazing! Any help would be appreciated, thanks!

Share this post


Link to post
Share on other sites

Have same problem. If I install police cars, I just get the default police cars. But my BCSO and rde added cars do work. Also the vehicles from SkylineGTRFreak work. It's only the police cars that don't work...

Share this post


Link to post
Share on other sites
7 minutes ago, Reyesinc said:

Have same problem. If I install police cars, I just get the default police cars. But my BCSO and rde added cars do work. Also the vehicles from SkylineGTRFreak work. It's only the police cars that don't work...

Are you sure you installed them in the right location? 

Share this post


Link to post
Share on other sites

As far as I can tell, if you have police.yft in patchday3ng and police.yft in patchday5ng, you'll end up with the one in patchday5ng. This is why you can install a police car mod in x64e (or whereever, x64e.rpf is the location for a lot of the vehicles in the game before the first patch) and it'll still appear standard - this is because it's being overridden by a newer version.

 

Usually the readme for the car mod you're trying to install will tell you where to put it, and the location they give you is usually correct. Make sure you try the method in the readme first, and if that doesn't work, try looking through some of the patchdayxng files or mpheist and such to see if the model is overridden by a later patch.

Share this post


Link to post
Share on other sites

You must be installing the cars to the wrong vehicals.rpf`s .They are all spread out in the directory.  Police1/police4 are in {X64e}, sheriff1 sheriff2 and police 2 are in {Patchday3} , And police 3 is in {Patchday 4}. That`s the weird way to do it. Most ppl use Mod folders.

Share this post


Link to post
Share on other sites

I've been using the mods folder and still having the same problem, also, when I install a mod using OpenIV it doesnt seem to save, for instance, I just installed a siren mod the way the readme explains to do it and it saves, when I play the sound through OpenIV it is the correct sound but it doesn't play in game. It's like OpenIV isn't saving the mods to the game. Any suggestions?

Share this post


Link to post
Share on other sites

I think I found a fix! I think RDE overrides all the other files you want to replace (police vehicles),  so you have to replace those too, maybe you have an added dlc that overrides other dlcs and contain the cars you want to replace. It worked for me. So you should place them in the olace which is in the readme (or patchday8ng(?) and if it's in another dlc (RDE), you should replace those too.

I hope this will work for you.

Share this post


Link to post
Share on other sites
5 minutes ago, LDMCOUTSIDER said:

what is the path to police1

 

There are multiple. In /mods/x64e/x64/levels/gta5/vehicles/vehicles.rpf

Or in /mods/update/x64/dlcpacks/ and look around.

Share this post


Link to post
Share on other sites
5 minutes ago, Reyesinc said:

There are multiple. In /mods/x64e/x64/levels/gta5/vehicles/vehicles.rpf

Or in /mods/update/x64/dlcpacks/ and look around.

ok thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×