Jump to content
WhereIsTheMod

LCPDFR Failed to find a valid installation

Recommended Posts

Okay, so I've been using LCPDFR for the past week, and I'm loving it, today I decided I should get a car mod and ELS, which went fine, I launched my game, tested out the vehicles, I was loving it.

Buuuut, when I tried to go on duty, nothing happened.

I tried to run the diagnostic tool to see if I managed to much up LCPDFR during my other installations, and it gives me this message "Failed to find a valid installation".

I reinstalled, but at the end of the installation when I tried to run the configuration program, I got the same message!

LCPDFR is very obviously in my GTAIV directory, but I can't use it, it's really bothersome, especially after getting a fancy new car.

Excuse my crummy screenshotting skills, I've never been too good at that, but here is my GTA directory. 

https://gyazo.com/804c362b2eb37ec6901c07485b98786c

(Everything below GTAIVGDF.dll) vvvvvvvvvvvvvvvvvvvv 

https://gyazo.com/170cd7b3c4d41cb655106c5ffc63d0ac

Here are the instructions that game with the vehicle mod, in case any of that could dick up LCPDFR https://gyazo.com/20717c6030f56ef91b4cd19b50c54fd8

The mod itself http://www.lcpdfr.com/files/file/4826-modified-default-vehicles-pack-2-els/

Any support is really appreciated, Happy holidays!

Share this post


Link to post
Share on other sites

Excuse me if this is breaking the rules, I cant figure out how to edit my post for the life of me, I'm able to use LCPDFR now, but I still can't use the diagnostic tools, which means I can't configure my LCPDFR settings, which means loads of crashes.

Edited by WhereIsTheMod

Share this post


Link to post
Share on other sites

Okay, after deleting everything, and reinstalling GTA, I got a message saying "LCPDFR Encountered a critical error, please check log"

Here's what the log says

[ERROR - 6:13:28 PM] [] System.FieldAccessException: Attempt by method '‌‮‫‏‌‪‌‭‮‍‮‌‪‮‮‏‫‫‌‬‌‮..ctor()' to access field 'GTA.base.HandleObject.pHandle' failed.
   at ‌‮‫‏‌‪‌‭‮‍‮‌‪‮‮‏‫‫‌‬‌‮..ctor() in d:\GTA IV\LCPDFR\SVN\branches\LCPDFR Ambient Action\LCPD First Response\LCPD First Response\Engine\Scripting\Entities\PoolUpdaterUnmanaged.cs:line 33
   at LCPD_First_Response.Engine.Main.‮‭‏‍‍‍‏‏‫‍‌‫‪‫‍‭‭‫‌‭‮() in d:\GTA IV\LCPDFR\SVN\branches\LCPDFR Ambient Action\LCPD First Response\LCPD First Response\Engine\Main.cs:line 162
   at LCPD_First_Response.Engine.Main.‌‍‪‌‬‎‭‭‍‌‮‭‌‮‏‪‍‌‪‎‫‪‮‮‮() in d:\GTA IV\LCPDFR\SVN\branches\LCPDFR Ambient Action\LCPD First Response\LCPD First Response\Engine\Main.cs:line 222
 

Sooooo... what's that mean?

Share this post


Link to post
Share on other sites

I reinstalled LCPDFR with the installer this time, and now I get no error message.

As I've been trying to get LCPDFR to work, I've noticed the automatic installer breaks ELS?

The lightbars and such it comes with are still there, but they dont flash, and you can only use GTA default controls for the sirens.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×