Jump to content
Sign in to follow this  
AndyTaylor14

"GTA IV has stopped working..." LCPDFR 1.0b issue

Recommended Posts

I have been playing on a old version of LCPDFR until recently my game broke and I didn't back up my files.... after a complete re-install (Game worked, I checked it before I installed 1.0b) I decided to go ahead and get the latest version of LCPDFR. ( I couldn't use 1.0 in the past since I was on 32 bit ). I installed it fine with the automatic install and everything seem like it was going to work. The diagnostic tool worked in advanced mode and said nothing was wrong. Although when I chose to pull up the log using the tool, it "stopped working". I then tried to run the game ( As admin ) and it says it stops working right upon start up. I'm not sure what to do, and I've looked at multiple topics that have fixes. 

 

Any help would be greatly appreciated, thanks.

Edited by AndyTaylor14

Share this post


Link to post
Share on other sites

I have been playing on a old version of LCPDFR until recently my game broke and I didn't back up my files.... after a complete re-install (Game worked, I checked it before I installed 1.0b) I decided to go ahead and get the latest version of LCPDFR. ( I couldn't use 1.0 in the past since I was on 32 bit ). I installed it fine with the automatic install and everything seem like it was going to work. The diagnostic tool worked in advanced mode and said nothing was wrong. Although when I chose to pull up the log using the tool, it "stopped working". I then tried to run the game ( As admin ) and it says it stops working right upon start up. I'm not sure what to do, and I've looked at multiple topics that have fixes. 

 

Any help would be greatly appreciated, thanks.

 

Is your GTA 4 patched to 1.0.7.0 (1.1.2.0 for EFLC)

 

are you 110 sure you installed LCPD:FR 1.0 correctly? Follow this guide to make sure - '?do=embed' frameborder='0' data-embedContent>>

 

Also many people in the past (including myself) have had problems using the automatic installer, I don't know if it was fixed or not.. but to make sure, install LCPD:FR 1.0 manually (the guide i just linked shows you how to install manually)

 

Share this post


Link to post
Share on other sites

Hello there -- welcome to LCPDFR.com and thanks for trying out LCPDFR.

You failed to read the instructions before posting in this forum. So we'll remind you of them.

Please do the following:

  • Make sure you aren't using a crack - We don't support cracks
  • Update GTA IV to 1.0.7.0 (the latest version of the game, or 1.1.2.0 for EFLC) - This sometimes fixes a wide variety of issues
  • Make sure that you run the game as an administrator.
  • Make sure that your GTA IV root folder (and every subdirectory) is not set to "read-only"
  • Ensure that ScriptHook.dll, ScriptHookDotNet.asi and Dsound.dll OR Xlive.dll are in the GTA IV ROOT folder
  • Ensure that there is a folder titled 'LCPDFR' in the ROOT GTA IV folder.
  • Check that all the above files exist, if they do not, reinstall LCPDFR with the MANUAL installation.
  • Ensure that you are using up to date versions of every LCPDFR dependency and LCPDFR itself.
  • Install these: .Net Framework 4.5Microsoft Visual C++ Redist 2012

If your problem has been solved after following these basic instructions, hit 'Mark Solved' next to this post.

If not, please now reply to this thread, and make sure that you do the following:

  • Give a clear, detailed description of the problem.
  • Explain any circumstances surrounding the problem.
  • State what solutions you have tried.
  • Post ALL relevant logs (LCPDFR.log, Scripthook.log, ScriptHookDotNet.log, AdvancedHook.log).
  • Include as much information as possible.
  • Post your system specifications.
  • Post what other mods you are using. This includes car and script mods.

Please note that failure to follow these instructions may cause this thread to be closed.

Share this post


Link to post
Share on other sites

Hello there -- welcome to LCPDFR.com and thanks for trying out LCPDFR.

You failed to read the instructions before posting in this forum. So we'll remind you of them.

Please do the following:

  • Make sure you aren't using a crack - We don't support cracks  - Purchased the game from steam, not a crack at all.
  • Update GTA IV to 1.0.7.0 (the latest version of the game, or 1.1.2.0 for EFLC) - This sometimes fixes a wide variety of issues - I thought this was my issue, but the game was already 1.0.7.0. To make sure I did in fact install it, same issue occurs.
  • Make sure that you run the game as an administrator. - Of course.
  • Make sure that your GTA IV root folder (and every subdirectory) is not set to "read-only" - I misread this on a topic and thought it had to be set to read only. So I unchecked it, same issue occurs.
  • Ensure that ScriptHook.dll, ScriptHookDotNet.asi and Dsound.dll OR Xlive.dll are in the GTA IV ROOT folder - All are in the Root folder and I have tried Xlive and Dsound, both give the same problem. 
  • Ensure that there is a folder titled 'LCPDFR' in the ROOT GTA IV folder. - Of course.
  • Check that all the above files exist, if they do not, reinstall LCPDFR with the MANUAL installation. - They exist, I have done the manual installation multiple times, replacing the files over and over, same issue occurs.
  • Ensure that you are using up to date versions of every LCPDFR dependency and LCPDFR itself. - I assume this means to make sure I'm using the latest LCPDFR, which I am using 1.0b.
  • Install these: .Net Framework 4.5Microsoft Visual C++ Redist 2012 - Already installed, will re-install.
If your problem has been solved after following these basic instructions, hit 'Mark Solved' next to this post.

If not, please now reply to this thread, and make sure that you do the following:

  • Give a clear, detailed description of the problem.
  • Explain any circumstances surrounding the problem.
  • State what solutions you have tried.
  • Post ALL relevant logs (LCPDFR.log, Scripthook.log, ScriptHookDotNet.log, AdvancedHook.log).
  • Include as much information as possible.
  • Post your system specifications.
  • Post what other mods you are using. This includes car and script mods.
Please note that failure to follow these instructions may cause this thread to be closed.

 

 

Answers were added within the quote, thanks for the quick response and i'll try to be more descriptive in the future.

Edit: I have noticed something very strange. I cannot find the LCPDFR.log anywhere inside my root folder. I checked the manual installation and it isn't there either. Besides that, here our my Scripthook.log, ScriptHookDotNet.log, and AdvancedHook.log that will be in the spoiler below. (Couldn't find the spoiler option, so I posted it in a code.

 

Scripthook.log

 

Log start: Wed May 14 22:10:53 2014
-----------------------------------------------
[INFO] GTA IV Script Hook 0.5.1 - (C) 2009, Aru - Initialized
[INFO] Process base address: 0x290000
[INFO] Auto detecting game version
[INFO] Using game version 1.0.7

ScriptHookDotNet.log

2014-05-14 22:10:53 - Initializing ScriptHookDotNet v1.7.1.7 BETA (on GTA IV version 1.0.7.0 with C++ Hook version 0.5.1)

AdvancedHook.log ( I assume you mean 'AdancedHookInit' otherwise I couldn't find 'AdvancedHook )

Log started on: 22:10:53 5-14-2014------------------------
[INFO - 22:10:53] Gameversion - 1.0.7.0
[INFO - 22:10:53] AdvancedHookInit 0.3 (C) 2013 LMS - Initialized
[INFO - 22:10:53] Attaching hooks...
[INFO - 22:10:53] CPools::InstallHooks: Hooking CPool__Initialize
[INFO - 22:10:53] CPools::InstallHooks: Hooking CPedFactory
[INFO - 22:10:53] XLiveLess present - skipping xlive changes
[INFO - 22:10:53] Disabling network connection check
[INFO - 22:10:53] Spawning patcher thread
[INFO - 22:10:53] Patching files
Edited by AndyTaylor14

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×