Jump to content
NVME31

GTA IV hookdotnet not valid?

Recommended Posts

Hello fellow gamers,

After seening LCPDFR on a couple youtube videos, I knew I wanted to play it.

I bought GTA IV at Meijers, got that installed and was able to play it.

so now I wanted to try and play LCPDFR 1.0

I also turned off UAC, and still try to run everything that I can as administrator too.

I downloaded and was able to manual install (automatic didn't work for some reason) the mod.

I then started up the game, and when I got outside the apartment I hit ALT-P as instructed. All it did was turn blurry on me.

I did some more research, and it was just to turn defination on and off. It didnot say if I was onduty, or the nearest police station shown on the map.

so then I downloaded the G17 IV Diagnostics tool to find out what why it wasn't working. Here are the results...

BEGIN *SIGNED* LCPD First Response Issue Report

Diagnostics Tool Version: 0.4.3

Operating system: Windows7 HomePremium (6.1.0.0 Build: 7600) Service Pack:

System RAM (GB): 3

CPU cores: 4

NET Framework 4.0 installed: True

Visual C++ 2010 Redistributable installed: True

GTA IV - Installed: True

GTA IV - Install folder: R:program filesRockstar GamesGrand Theft Auto IV

GTA IV - Version: 1, 0, 7, 0

GTA IV - Asi loader installed: True

GTA IV - Asi loader: DSOUND

GTA IV - Asi loader valid: True

GTA IV - C++ ScriptHook installed: True

GTA IV - C++ ScriptHook valid: True

GTA IV - C++ ScriptHook version: 0, 5, 1, 0

GTA IV - ScriptHookDotNet installed: True

GTA IV - ScriptHookDotNet valid: False

EFLC - Installed: False

EFLC - Install folder:

EFLC - Version:

EFLC - Asi loader installed: False

EFLC - Asi loader:

EFLC - Asi loader valid: False

EFLC - C++ ScriptHook installed: False

EFLC - C++ ScriptHook valid: False

EFLC - C++ ScriptHook version:

EFLC - ScriptHookDotNet installed: False

EFLC - ScriptHookDotNet valid: False

End of *SIGNED* LCPD First Response Issue Report

Digital signature: IsW1yS1y6qYpa+Hh+KCMmQ==

on the previous screen it said GTA IV:.NET Scripthook found but out of date

Ive tried to reinstall LCPDFR 1.0 to see if that fixes the issue of having the lastest update. no such luck.

I searched the web and found the website (http://www.hazardx.com/details.php?file=83) for an updated scripthook files(V1.7.1.7b, because I have the 1.0.7.0), and replaced them in the GTA ROOT folder, and re-ran the Diagnostics tool, and still got the same answer that it is running an old version. Is it possible that the one in the LCPDFR, is more updated than the website I got that from?

so now, am I missing another important step? I kinda hit a brick wall here, so any help would be greatly appreciated. I hope I have gave enough information to get my mod to work correctly.

Share this post


Link to post
Share on other sites

Hello fellow gamers,

After seening LCPDFR on a couple youtube videos, I knew I wanted to play it.

I bought GTA IV at Meijers, got that installed and was able to play it.

so now I wanted to try and play LCPDFR 1.0

I also turned off UAC, and still try to run everything that I can as administrator too.

I downloaded and was able to manual install (automatic didn't work for some reason) the mod.

I then started up the game, and when I got outside the apartment I hit ALT-P as instructed. All it did was turn blurry on me.

I did some more research, and it was just to turn defination on and off. It didnot say if I was onduty, or the nearest police station shown on the map.

so then I downloaded the G17 IV Diagnostics tool to find out what why it wasn't working. Here are the results...

BEGIN *SIGNED* LCPD First Response Issue Report

Diagnostics Tool Version: 0.4.3

Operating system: Windows7 HomePremium (6.1.0.0 Build: 7600) Service Pack:

System RAM (GB): 3

CPU cores: 4

NET Framework 4.0 installed: True

Visual C++ 2010 Redistributable installed: True

GTA IV - Installed: True

GTA IV - Install folder: R:program filesRockstar GamesGrand Theft Auto IV

GTA IV - Version: 1, 0, 7, 0

GTA IV - Asi loader installed: True

GTA IV - Asi loader: DSOUND

GTA IV - Asi loader valid: True

GTA IV - C++ ScriptHook installed: True

GTA IV - C++ ScriptHook valid: True

GTA IV - C++ ScriptHook version: 0, 5, 1, 0

GTA IV - ScriptHookDotNet installed: True

GTA IV - ScriptHookDotNet valid: False

EFLC - Installed: False

EFLC - Install folder:

EFLC - Version:

EFLC - Asi loader installed: False

EFLC - Asi loader:

EFLC - Asi loader valid: False

EFLC - C++ ScriptHook installed: False

EFLC - C++ ScriptHook valid: False

EFLC - C++ ScriptHook version:

EFLC - ScriptHookDotNet installed: False

EFLC - ScriptHookDotNet valid: False

End of *SIGNED* LCPD First Response Issue Report

Digital signature: IsW1yS1y6qYpa+Hh+KCMmQ==

on the previous screen it said GTA IV:.NET Scripthook found but out of date

Ive tried to reinstall LCPDFR 1.0 to see if that fixes the issue of having the lastest update. no such luck.

I searched the web and found the website (http://www.hazardx.com/details.php?file=83) for an updated scripthook files(V1.7.1.7b, because I have the 1.0.7.0), and replaced them in the GTA ROOT folder, and re-ran the Diagnostics tool, and still got the same answer that it is running an old version. Is it possible that the one in the LCPDFR, is more updated than the website I got that from?

so now, am I missing another important step? I kinda hit a brick wall here, so any help would be greatly appreciated. I hope I have gave enough information to get my mod to work correctly.

Did you delete the folder "LCPDFR Install(ASI Loaders)"?  Also the G17 media diagnostics tool does not work for LCPDFR 1.0

Edited by lcpdsergeant

Share this post


Link to post
Share on other sites

Delete your LCPDFR ASI LOADER folder, since you no longer need it. you only needed to choose 1 of it's contents (dsound or xlive) you already have dsound. so you can remove the folder now.

Share this post


Link to post
Share on other sites

Delete your LCPDFR ASI LOADER folder, since you no longer need it. you only needed to choose 1 of it's contents (dsound or xlive) you already have dsound. so you can remove the folder now.

 

yeah, that didn't work.

.

lcpdsergeant said that G17 don't work for the 1.0? should I download and try an older version of lcpdfr, what was it, .95 or something?

 

updated screenshot, hoping that I deleted the right folder

Share this post


Link to post
Share on other sites

yeah, that didn't work.

.

lcpdsergeant said that G17 don't work for the 1.0? should I download and try an older version of lcpdfr, what was it, .95 or something?

 

updated screenshot, hoping that I deleted the right folder

 

the diagnostic tool only helps figure out the problem, it has no impact on the game.

 

remove all of your LCPDFR files for your gta 4 directory then follow this method - '?do=embed' frameborder='0' data-embedContent>>

Share this post


Link to post
Share on other sites

the diagnostic tool only helps figure out the problem, it has no impact on the game.

 

remove all of your LCPDFR files for your gta 4 directory then follow this method - '?do=embed' frameborder='0' data-embedContent>>

 

 

right,I understood that tool, what I mean't was ,should I install a previous version of the LCPDFR mod, to see if it will still work

 

come to find out now tho, after going through the installation again, that my microsoft .net framework was only at version 4.0 instead of 4.5. Im not sure if I overlooked that one, or if it didn't install correctly, but now I have another issue now is that I downloaded the full "dotNetFx45_Full_setup" and try to run it, (both with and without administrator),and all it does is just still there, not doing anything to my cpu.

Share this post


Link to post
Share on other sites

right,I understood that tool, what I mean't was ,should I install a previous version of the LCPDFR mod, to see if it will still work

 

come to find out now tho, after going through the installation again, that my microsoft .net framework was only at version 4.0 instead of 4.5. Im not sure if I overlooked that one, or if it didn't install correctly, but now I have another issue now is that I downloaded the full "dotNetFx45_Full_setup" and try to run it, (both with and without administrator),and all it does is just still there, not doing anything to my cpu.

 

downgrading isn't really necessary since 0.95 is no longer supported.

 

you could try restarting your computer, re-download the dotnet setup file and try it again? that normally fixes my problems when something won't install. you probably have a background program open that is not letting the installer do it's job

 

Share this post


Link to post
Share on other sites

downgrading isn't really necessary since 0.95 is no longer supported.

 

you could try restarting your computer, re-download the dotnet setup file and try it again? that normally fixes my problems when something won't install. you probably have a background program open that is not letting the installer do it's job

 

 

 

I got it to work! I think it was just that the framework wasn't upgraded to 4.5 for some reason, but it works now, I love it!

 

thanks for your help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×