Jump to content
Zanoscar

AdvancedHook.dll problem

Recommended Posts

GTA EFLC works fine, but the LCPDFR mod wont, i have tried different solutions including the download here, all have failed however.

 

">"

i will post my log

 

[iNFO - 7:57:07 PM] [Log] Started

[iNFO - 7:57:07 PM] [Main] Main: Initializing...
[iNFO - 7:57:07 PM] [Main] Main: LCPDFR Engine © 2011-2013 LMS
[iNFO - 7:57:07 PM] [Main] Main: DO NOT USE THIS WITHOUT PERMISSION. YOU MAY NOT SHARE, MODIFY OR DECOMPILE THIS FILE.
[ERROR - 7:57:07 PM] [] System.IO.FileLoadException: A procedure imported by 'AdvancedHook.dll' could not be loaded.
File name: 'AdvancedHook.dll'
   at freval_187.fr0()
   at freval_187..ctor()
   at LCPD_First_Response.Engine.Main.eval_fr4()
   at LCPD_First_Response.Engine.Main.fr3()
 

i don't know what to do and am completely stuck.

Help?

 

-Zan

Share this post


Link to post
Share on other sites

GTA EFLC works fine, but the LCPDFR mod wont, i have tried different solutions including the download here, all have failed however.

i will post my log

i don't know what to do and am completely stuck.

Help?

 

-Zan

Hi,

 

Can you post a screenshot of your GTA IV directory please, and also have you used the diagnostics tool to check your installation?

There is a guide on that here '?do=embed' frameborder='0' data-embedContent>>

Share this post


Link to post
Share on other sites

Hi,

 

Can you post a screenshot of your GTA IV directory please, and also have you used the diagnostics tool to check your installation?

There is a guide on that here '?do=embed' frameborder='0' data-embedContent>>

i looked at the thread you made, the files you were talking about are in their right places, the diagnostics tool says .Net Framework 4.5 isn't there even though it IS, anyway, the logs say it's a problem with "AdvancedHook.dll"

 

Anyway, im using "The Ballad of Gay Tony" and not the basic GTA IV and your tutorial shows a diagnostics tool that differs from mine.

hWIcNgw.jpg

Also, im using Windows 8, would that mean different solutions?

 

 

Help?

Edited by Zanoscar

Share this post


Link to post
Share on other sites

i looked at the thread you made, the files you were talking about are in their right places, the diagnostics tool says .Net Framework 4.5 isn't there even though it IS, anyway, the logs say it's a problem with "AdvancedHook.dll"

 

Anyway, im using "The Ballad of Gay Tony" and not the basic GTA IV and your tutorial shows a diagnostics tool that differs from mine.

 

Also, im using Windows 8, would that mean different solutions?

 

 

Help?

 

If it says the .net framework 4.5 is missing, then it was unable to detect the .net framework, so verify by going to chapter 3 of that guide, find the .net framework and install it (not just download)

 

Also, we don't have different versions of the diagnostics tool. I'm running on windows 7, you are on windows 8. They are 2 totally different GUI's so the diagnostic tool will look different, it inherits form the system's GUI.

Share this post


Link to post
Share on other sites

If it says the .net framework 4.5 is missing, then it was unable to detect the .net framework, so verify by going to chapter 3 of that guide, find the .net framework and install it (not just download)

 

Also, we don't have different versions of the diagnostics tool. I'm running on windows 7, you are on windows 8. They are 2 totally different GUI's so the diagnostic tool will look different, it inherits form the system's GUI.

i CAN'T install it

 

because i already HAVE

 

when using the installer it tells me i already have it, and the LCPDFR doesn't understand that i already have it, same with the C++ thing.

 

and here is a screenshot of the GTA IV:EFLC directory you wanted

Z6JunhP.jpg

Edited by Zanoscar

Share this post


Link to post
Share on other sites

i CAN'T install it

 

because i already HAVE

 

when using the installer it tells me i already have it, and the LCPDFR doesn't understand that i already have it, same with the C++ thing.

 

and here is a screenshot of the GTA IV:EFLC directory you wanted

 

Alright I see.

 

Running GTA IV as an administrator? Also try Running it in a compatibility mode with windows 7 and see if that helps.

Share this post


Link to post
Share on other sites

Alright I see.

 

Running GTA IV as an administrator? Also try Running it in a compatibility mode with windows 7 and see if that helps.

 

Was that a typo? i have no access to windows 7

 

and would running it as administrator really help? i usually boot it directly from steam.

 

and i don't want to be rude, but the logs say its a problem with the "AdvancedHook.dll" thingy.

gonna boot it as Admin and send you the latest log if it fails.

 

 

Edited by Zanoscar

Share this post


Link to post
Share on other sites

Was that a typo? i have no access to windows 7

 

and would running it as administrator really help? i usually boot it directly from steam.

 

and i don't want to be rude, but the logs say its a problem with the "AdvancedHook.dll" thingy.

gonna boot it as Admin and send you the latest log if it fails.

 

No. You can run an application in compatibility mode with a previous version of windows. For example, I use windows 7. I can run my applications in compatability mode with vista, or xp. etc.

Yes running it as administrator could help.

 

And post the Advancedhook.log and the AdvancedhookInit.log as well and I'll take a look at those.

Share this post


Link to post
Share on other sites

No. You can run an application in compatibility mode with a previous version of windows. For example, I use windows 7. I can run my applications in compatability mode with vista, or xp. etc.

Yes running it as administrator could help.

 

And post the Advancedhook.log and the AdvancedhookInit.log as well and I'll take a look at those.

Couldnt find a way to boot GTA as admin, windows 8 doesn't support the bloody thing

 

 

[iNFO - 11:01:04 PM] [Log] Started

[iNFO - 11:01:04 PM] [Main] Main: Initializing...
[iNFO - 11:01:04 PM] [Main] Main: LCPDFR Engine © 2011-2013 LMS
[iNFO - 11:01:04 PM] [Main] Main: DO NOT USE THIS WITHOUT PERMISSION. YOU MAY NOT SHARE, MODIFY OR DECOMPILE THIS FILE.
[ERROR - 11:01:07 PM] [] System.IO.FileLoadException: A procedure imported by 'AdvancedHook.dll' could not be loaded.
File name: 'AdvancedHook.dll'
   at freval_187.fr0()
   at freval_187..ctor()
   at LCPD_First_Response.Engine.Main.eval_fr4()
   at LCPD_First_Response.Engine.Main.fr3()
 

as usual, i started it, i got into the game and it said "Error in script LCPDFR_Loader.Loader."

 

and i couldn't find the other logs you wanted.

Share this post


Link to post
Share on other sites

Couldnt find a way to boot GTA as admin, windows 8 doesn't support the bloody thing

 

as usual, i started it, i got into the game and it said "Error in script LCPDFR_Loader.Loader."

 

and i couldn't find the other logs you wanted.

It should do o.0

Go to your GTA IV directory, right click the LaunchGTA.exe and then click "Run as Administrator". If the option isn't there you may not have administrator privileges, in which case you will need to log into an account which is an administrator account.

 

As for the logs, you don't seem to have them at all. (I checked your screenshot to verify)

What I would suggest doing at this point, is completely uninstalling GTA IV, and clean out the entire directory. Then, reinstall GTA IV and make a clean backup of the game.

When that is done, go ahead and install LCPDFR 1.0b and try it again.

 

If it still doesn't work, go into the system control panel, uninstall programs, and uninstall the 2010 and 2012 redistributables, and uninstall the .net 4.5 framework. then go ahead, and download them from the links provided in the guide, reinstall them (only the 86x versions for the 2010 and 2012 files. The 64x ones aren't used)

 

Let me know how that goes.

Share this post


Link to post
Share on other sites

It should do o.0

Go to your GTA IV directory, right click the LaunchGTA.exe and then click "Run as Administrator". If the option isn't there you may not have administrator privileges, in which case you will need to log into an account which is an administrator account.

 

As for the logs, you don't seem to have them at all. (I checked your screenshot to verify)

What I would suggest doing at this point, is completely uninstalling GTA IV, and clean out the entire directory. Then, reinstall GTA IV and make a clean backup of the game.

When that is done, go ahead and install LCPDFR 1.0b and try it again.

 

If it still doesn't work, go into the system control panel, uninstall programs, and uninstall the 2010 and 2012 redistributables, and uninstall the .net 4.5 framework. then go ahead, and download them from the links provided in the guide, reinstall them (only the 86x versions for the 2010 and 2012 files. The 64x ones aren't used)

 

Let me know how that goes.

REINSTALL GTA?

 

all i have is the carmageddon mod, thats all, everything else is clean...

 

and it is EFLC, so it might not be.... right?

im not sure.

 

i tried using the shortcut, im going to do the .exe in admin mode, ill tell you howitgoes

 

EDIT: it wasn't going to work, i use steam to make it windowed and to give myself enough memory to get graphics working.

 

running it as admin doesn't make it go through steam, therefore preventing me from getting it to look presentable at least.

 

sooo, i dont want to reinstall and i cant run it in administrator mode unless you can give me a way to put these steam launch settings into the actual game

 

-availablevidmem 9.3 -nomemrestrict -norestrictions -windowed

 

Edited by Zanoscar

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×