Jump to content
EvilJackCarver

LCPDFR crash - freval_211.eval_fr0(freval_19 A_0)

Recommended Posts

I was chasing a Securicar in an armed-robbery callout. A short ways into the pursuit, I called in for NOoSE backup. That is the last bit of text to show up on the text wall before LCPDFR's hotkeys stopped responding, and the police search area on the map stopped updating. I was recording a video at the time but I'm reluctant to post it because I believe it would feel like advertising (something I'd like to avoid getting a warning for)

Here's the log. Datestamp 2014-02-28:

 

[INFO - 17:24:22] [Log] Started
[INFO - 17:24:22] [Main] Main: Initializing...
[INFO - 17:24:22] [Main] Main: LCPDFR Engine (C) 2011-2013 LMS
[INFO - 17:24:22] [Main] Main: DO NOT USE THIS WITHOUT PERMISSION. YOU MAY NOT SHARE, MODIFY OR DECOMPILE THIS FILE.
[INFO - 17:24:24] [PluginManager] Initialize: Loading custom plugins
[INFO - 17:24:24] [Settings] ReadSettings: Adding HAKUMAI
[INFO - 17:24:24] [Settings] ReadSettings: Adding FEROCI
[INFO - 17:24:24] [Settings] ReadSettings: Suspect transporter POLICE
[INFO - 17:24:24] [Settings] ReadSettings: Suspect transporter POLICE2
[INFO - 17:24:24] [Settings] ReadSettings: Suspect transporter PSTOCKADE
[INFO - 17:24:24] [Settings] ReadSettings: Suspect transporter FBI
[WARNING - 17:24:24] [SettingsFile] GetValue: Value not found: PreloadAllModels (Main)
[WARNING - 17:24:24] [SettingsFile] GetValue: Value not found: UsingPoliceStationMod (Main)
[INFO - 17:24:24] [Main] Main: Initializing done
[INFO - 17:24:26] [ServerCommunication] InitializeConnection: Internet connection available
[INFO - 17:24:26] [Stats] CollectSystemInformation: Server stats updated
[INFO - 17:24:30] [ServerCommunication] InitializeConnection: Public IP Address is: 68.███.███.███
[INFO - 17:24:31] [ServerCommunication] InitializeConnection: Connected to the LCPDFR server
[INFO - 17:24:31] [NetworkManager] NetworkManager: In network session: False Is host: False
[INFO - 17:24:31] [Authentication] Authentication: Server available, using online authentication
[ERROR - 17:24:32] [Authentication] Authentication: Error 0x320
[ERROR - 17:24:32] [Authentication] Authentication: Authentication failed
[INFO - 17:24:32] [Authentication] Authentication: Failed to authenticate
[WARNING - 17:30:44] [AudioDatabase] GetAudioFileForAction: No file found for: DENVER-EXETER_AVE
[WARNING - 17:32:37] [AudioDatabase] GetAudioFileForAction: No file found for: OBSIDIAN_ST
[WARNING - 17:33:57] [AudioDatabase] GetAudioFileForAction: No file found for: LORIMAR_ST
[WARNING - 17:34:01] [Script.Disturbance] OnCalloutAccepted: Failed to spawn at least one ped
[ERROR - 17:34:22] [Main] CRITICAL ERROR DURING MAINLOOP! REPORT THIS ISSUE AT LCPDFR.COM BY INCLUDING THIS LOGFILE.
[ERROR - 17:34:22] [] GTA.NonExistingObjectException: Invalid call to an object that doesn't exist anymore!
at GTA.Ped.isInVehicle(Vehicle vehicle)
at freval_211.eval_fr0(freval_19 A_0)
at freval_125.fr19()
at freval_120.eval_fr6()
at freval_104.fr7(freval_202 A_0)
at freval_3.eval_fr2(freval_202 A_0)
at freval_37.fr8()
at LCPD_First_Response.Engine.Main.fr2()
AdvancedHook logfile was since overwritten.

Share this post


Link to post
Share on other sites

Hi. The freval error was fixed for some users by doing this: Open up your LCPDFR.ini, look under "Main", it should look something like this by default:

[Main]
AdditionalCopCarModels= 
SuspectTransporterModels=POLICE;POLICE2;PSTOCKADE; 
VehicleTrunkWeapons=Shotgun_Baretta; 
AllTextMode=False 
AmbientScenariosMaximum=2 
AmbientScenariosMultiplier=250 
DepartmentName=Liberty City Police Department
DepartmentShortName=LCPD
FirstStart=True
UsingPoliceStationMod=False

Now, add to the bottom of that part

PreloadAllModels=True
The "Main" part should now look like this:

[Main]
AdditionalCopCarModels= 
SuspectTransporterModels=POLICE;POLICE2;PSTOCKADE; 
VehicleTrunkWeapons=Shotgun_Baretta; 
AllTextMode=False 
AmbientScenariosMaximum=2 
AmbientScenariosMultiplier=250 
DepartmentName=Liberty City Police Department
DepartmentShortName=LCPD
FirstStart=True
UsingPoliceStationMod=False
PreloadAllModels=True

Share this post


Link to post
Share on other sites

Will test it, though I haven't had any problems with LCPDFR since that.

Edit: Will mark solved for now, if I have more problems with it I'll post in a separate thread or bump this one.

Edited by EvilJackCarver

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×