Jump to content
Sign in to follow this  
bravozero

Zmod: Removing lightbar extras without removing other extras

Recommended Posts

As the title says, I am creating a slicktop version of the car I've been working on. I can remove the lightbar body, but the extras lighting is still there. However, those extras are also attached to the mirror lights, front and rear strobes, rambar lights, etc.

 

How do I go about just isolating and removing the lightbar extras, while leaving the rest of the car alone?

Share this post


Link to post
Share on other sites

You have to select all the lights, also the L1 files and go in "Vertex Mode". Then the lights you wanna delete select them again in "Vertex Mode" and hit DELETE.

The leave "Vertex Mode" and you done. 

 

I hope I helped you with your problem.

If you have still problems PM me.

 

JokerMods

Share this post


Link to post
Share on other sites

Worked, thanks.

 

However, now I'm getting the RC20 error.

 

All I've done with the car, that was perfectly functional before, is remove the lightbar completely from the hierarchy, removed Extra 5 and Extra 6 since they were the takedowns on the lightbar, and removed just the extras lighting on the lightbar. The mirror lights, front and rear strobes and rambar lights are still present and still mapped. 

 

I do only have Extras 1, 2, 3 and 4. Extras 5 and 6 were takedowns, and 7-9 didn't exist.

Share this post


Link to post
Share on other sites

Update... after messing with it, I've come to the conclusion that it's the lightbar itself, not the extras lighting.

 

I went the route of removing the lights from the lightbar, and keeping the lightbar there. The car spawns fine, the lightbar is still on the car, but it doesn't light up since I removed those Extras from it.

 

Now, I have to figure out how to remove the lightbar from the car completely and not have the RC20 crash.  Any ideas?

Share this post


Link to post
Share on other sites

Fix the hierarchy, check to see that there is nothing out of place. That might be the problem, check the Chassis too, Search the polys for some odd ones and stuff. 

 

I always remove lightbars from my upcoming model and it works fine ingame, just remember to remove the textures from the .wtd

 

 

Side Note:

 

Also I would like to give you a suggestion, lose the rambar, personally i like to convert slicktops to unmarked, swap out the rambar lights for grill lights :D

Share this post


Link to post
Share on other sites

Now I've narrowed it down to the lightbar glass. The physical lightbar assembly is gone, and now the lightbar glass is floating above the car.

 

However, I can keep spawning the car all day long and it won't crash. The moment I remove the glass from the model, it RC20's.


Fix the hierarchy, check to see that there is nothing out of place. That might be the problem, check the Chassis too, Search the polys for some odd ones and stuff. 

 

I always remove lightbars from my upcoming model and it works fine ingame, just remember to remove the textures from the .wtd

 

 

Side Note:

 

Also I would like to give you a suggestion, lose the rambar, personally i like to convert slicktops to unmarked, swap out the rambar lights for grill lights :D

 

Which texture are you referring to?

Share this post


Link to post
Share on other sites

Some visuals, maybe that can shine some light on what I'm doing wrong.

 

This is after I've removed the ELS lights from  the lightbar, the lightbar itself does not function when the emergency equipment activates. The lightbar itself still intact.

 

before_zps6776a14a.png

 

I remove the body of the lightbar,  only leaving the glass. Oddly enough, I can spawn this car numerous times and the game still runs fine, despite a  big hunk of glass hovering over the car.

 

during_zpsfbf6680f.png

 

That's where the RC20 error begins. Once I've removed the glass and it becomes an actual slicktop, I can't get the car to  spawn at all.

 

after_zpsb0133fa9.png

 

That being said, again I'm at a loss. If there was a way to make the glass invisible, I'd do it. However, I can't figure out why the glass is causing the RC20 error.

Share this post


Link to post
Share on other sites

Some visuals, maybe that can shine some light on what I'm doing wrong.

 

This is after I've removed the ELS lights from  the lightbar, the lightbar itself does not function when the emergency equipment activates. The lightbar itself still intact.

 

-SNIP-

 

 

I remove the body of the lightbar,  only leaving the glass. Oddly enough, I can spawn this car numerous times and the game still runs fine, despite a  big hunk of glass hovering over the car.

 

-SNIP-

 

That's where the RC20 error begins. Once I've removed the glass and it becomes an actual slicktop, I can't get the car to  spawn at all.

 

-SNIP-

 

That being said, again I'm at a loss. If there was a way to make the glass invisible, I'd do it. However, I can't figure out why the glass is causing the RC20 error.

Your lb_glass needs to be deleted, first, select everything in there (l0,l1,l2) Then right click on the lb_glass and go to edit - delete, 

try that

Edited by Sgt.Hoffers

Share this post


Link to post
Share on other sites

Your lb_glass needs to be deleted, first, select everything in there (l0,l1,l2) Then right click on the lb_glass and go to edit - delete, 

try that

 

No dice. Tried just removing the glass only, then removed the glass and lightbar using the same method.

 

For the hell of it, I removed the lightbar completely and all ELS extras, just to see if it still might be related to the lighting. It still crashed.

 

So again, it has something to do with the damn lightbar glass. Once you mess with it, the car will cause the game to crash. I don't get it.

Share this post


Link to post
Share on other sites

No dice. Tried just removing the glass only, then removed the glass and lightbar using the same method.

 

For the hell of it, I removed the lightbar completely and all ELS extras, just to see if it still might be related to the lighting. It still crashed.

 

So again, it has something to do with the damn lightbar glass. Once you mess with it, the car will cause the game to crash. I don't get it.

Hm thats a bitch

 

maybe something is conflicting with it?

 

My model i am creating I had to start again cause of a fuck up i couldnt of fixed. But dont go to that extreme

Share this post


Link to post
Share on other sites

But what though?  That's what I'm confused about. I can remove everything I need to except the lightbar glass. It isn't tied in or attached to anything, its sitting there dormant by itself. Once you mess with it in any way, even just removing a single polygon from it, the game crashes on spawn.

Share this post


Link to post
Share on other sites

Send me your Skype name, if you've Skype.

I can help you.

Sgt.Hoffers was right but not completly, you have to delete the textures (emerglights/_emis) and in the material editir (the red ball :D) you have to delete all lightbar materials, and of course the lightbar itself with L0,L1 and L2 (if L2 exist sometimes you have L2 somtimes not).

 

As I said Skype name, I'll add you and if you have still or more problems I can help ^^

 

JokerMods

Share this post


Link to post
Share on other sites

Thanks dude.

 

I think I might have solved my problem. What I did was take the major parts of the vehicle that had the emergency lights, which included the frame (with the rambar), the front doors, the trunk and a couple of other parts, pulled them from the host car that I've been having problems with. I then opened the unlocked CVPI by Bugs, replaced those parts with the ones from the host car, re-added the correct textures and tried it in-game. Hasn't crashed yet. So, it has something to do with how Boatinman set up his CVPI. I am now running a full slicktop with existing emergency equipment with no problems.

 

Now I just need to figure out how to add a Whelen Avenger, put it in the windshield and call it a day.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×