Jump to content
Zontar

LCPDFR not working properly

Recommended Posts

Alt+p does not work, but when I do Alt+ctrl+p I go on duty but It does not work quite right. Some scripts work like taser and callouts but I cannot change my appearance to a cop inside the police station and I cannot leave once I go it. A message comes up in the to left corner "An unhandled exception occurred within LCPDFR".

 

This is my diagnostic message

 

BEGIN *SIGNED* LCPD First Response Issue Report
Diagnostics Tool Version: 0.4.3
Operating system: Windows7 Ultimate (6.1.1.0 Build: 7601) Service Pack:Service Pack 1
System RAM (GB): 15.98
CPU cores: 8
NET Framework 4.0 installed: True
Visual C++ 2010 Redistributable installed: True
GTA IV - Installed: True
GTA IV - Install folder: C:Program Files (x86)SteamsteamappscommonGrand Theft Auto IVGTAIV
GTA IV - Version: 1, 0, 7, 0
GTA IV - Asi loader installed: True
GTA IV - Asi loader: DSOUND
GTA IV - Asi loader valid: True
GTA IV - C++ ScriptHook installed: True
GTA IV - C++ ScriptHook valid: True
GTA IV - C++ ScriptHook version: 0, 5, 1, 0
GTA IV - ScriptHookDotNet installed: True
GTA IV - ScriptHookDotNet valid: True
===============BEGIN .NET SCRIPTHOOK LOG===============
2013-07-13 00:35:48 - Initializing ScriptHookDotNet v1.7.1.4 BETA (GTA IV version 1.0.7.0)
2013-07-13 00:36:56 - Direct3D device created!
 
2013-07-13 00:36:56 - SEARCHING FOR SCRIPTS...
2013-07-13 00:36:56 - Loading scripts in Assembly 'scriptsFirstResponse.net.dll' ...
2013-07-13 00:36:56 -  ...found script 'FirstResponse.Main.EmergencyLights'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.Main.Start'!
2013-07-13 00:36:56 -  ...found script 'CSharp.Engine.Core'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.Debugging'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.DeletionList'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.Hardcore'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.TextDraw'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCMD.Main'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCMD.Functions'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCPD.Carboot'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCPD.Disarm'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCPD.Frisk'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCPD.PullOver'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCPD.Actions'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCPD.Debug'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCPD.Flashlight'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCPD.Functions'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCPD.Partner'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCPD.inputSimulator'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCPD.Start'!
2013-07-13 00:36:56 -  ...found script 'FirstResponse.LCPD.Various'!
2013-07-13 00:36:56 - DONE! 21 valid scripts found!
 
2013-07-13 00:36:56 - STARTING SCRIPTS...
2013-07-13 00:36:56 - Error during GetPhoneNumber (Phone checks will be disabled):
                      System.Exception: Accessing Globals failed! Invalid Memory Address!
                         at unmanaged.MemoryAccess.GetGlobalAddress(Int32 index)
                         at unmanaged.MemoryAccess.GetPhoneNumber()
                         at GTA.NetHook.CheckPhone()
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCPD.Various'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCPD.Start'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCPD.inputSimulator'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCPD.Partner'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCPD.Functions'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCPD.Flashlight'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCPD.Debug'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCPD.Actions'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCPD.PullOver'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCPD.Frisk'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCPD.Disarm'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCPD.Carboot'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCMD.Functions'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.LCMD.Main'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.TextDraw'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.Hardcore'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.DeletionList'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.Debugging'!
2013-07-13 00:36:56 -  ...successfully started script 'CSharp.Engine.Core'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.Main.Start'!
2013-07-13 00:36:56 -  ...successfully started script 'FirstResponse.Main.EmergencyLights'!
2013-07-13 00:37:42 - Error during NetHook.Tick:
                      System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
                         at unmanaged.NativeContext3.Invoke(Int32 nameptr, Byte[] args, Int32 argnum, NativeContext3* cxt)
                         at GTA.ScriptDomain.RemoteEvent(RemoteEventArgs ev)
                         at GTA.ScriptDomain.ProcessRemoteEvents()
                         at GTA.ScriptDomain.Tick()
                         at GTA.NetHook.Tick()
2013-07-13 00:37:59 - Direct3D device lost!
2013-07-13 00:37:59 - Direct3D device created!
2013-07-13 00:38:07 - Direct3D device lost!
2013-07-13 00:38:08 - Direct3D device created!
2013-07-13 00:38:19 - Direct3D device lost!
2013-07-13 00:38:19 - Direct3D device created!
 
===============END .NET SCRIPTHOOK LOG===============
End of *SIGNED* LCPD First Response Issue Report
Digital signature: o474g3mPH3ILRr6J6qjLBQ==
 
I've been looking on the forums for a while and nothing in the first few pages have worked.

Share this post


Link to post
Share on other sites

I had this error too, do not remember how I fixed it. 

 

Firstly, are you 100% sure it does not work? I am in no way calling you stupid, but sometimes the controls are a little weird.

Are you using the left-alt key? 

 

Oh, and is it a legal copy of the game? :)

 

Share this post


Link to post
Share on other sites

Yeah 100%. I've been at it for days trying to fix it. I've tried both left and right alt and nothing seems to work.

 

It's a legal copy, I bought it off steam.

Share this post


Link to post
Share on other sites

Yeah 100%. I've been at it for days trying to fix it. I've tried both left and right alt and nothing seems to work.

 

It's a legal copy, I bought it off steam.

 

Have you tried re-installing it? It's a long-shot but it may work. 

Share this post


Link to post
Share on other sites

I just reinstalled. Same thing keeps happening and I get the same error message from the diagnostic tool. I also ran the installer and LaunchGTAIV.exe as administrator and same thing happened.

Share this post


Link to post
Share on other sites

I just reinstalled. Same thing keeps happening and I get the same error message from the diagnostic tool. I also ran the installer and LaunchGTAIV.exe as administrator and same thing happened.

 

Just thought of this, are you using the Simple Native Trainer? 

Share this post


Link to post
Share on other sites

No I'm not using it.

 

Just copying this from the guidelines :

 

  • Make sure you aren't using a crack - We don't support cracks
  • Update GTA IV to 1.0.7.0 (the latest version of the game, or 1.1.2.0 for EFLC) - This sometimes fixes a wide variety of issues
  • Make sure that you run the game as an administrator.
  • Make sure that your GTA IV root folder (and every subdirectory) is not set to "read-only"
  • Ensure that FirstResponse.net.dll is in the SCRIPTS folder and that AdvancedHook.dll is in the GTA IV ROOT folder.
  • Ensure that ScriptHook.dll, ScriptHookDotNet.asi and Dsound.dll OR Xlive.dll are in the GTA IV ROOT folder
  • Ensure that there is a folder titled 'LCPDFR' in the SCRIPTS folder.
  • Check that all the above files exist, if they do not, reinstall LCPDFR with the automatic installation.
  • Ensure that you are using up to date versions of every LCPDFR dependency and LCPDFR itself.
  • Install these: http://www.microsoft...9f-b21f31ab88b7http://www.microsoft...&displaylang=en

Share this post


Link to post
Share on other sites

Whenever I download and install LCPDFR my game keeps on crashing any else get this problem

MODERATOR NOTICE

Please don't necropost nor hijack someone else's topic. Create your own topic about your issue in the appropriate section, providing as much information as you can about your issue.

Saying "my game keeps crashing after installing LCPDFR" will get you no-where as it could be a multitude of different factors contributing to the crash.

Nothing to see here!


This topic has been closed by LCPDFR.com staff.

If you feel that this topic has been closed in error, please report this post.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×