Jump to content

"LCPD First Reponse.dll" causing an error

Recommended Posts

I'm trying to get LCPDFR to work on GTA IV. Previously had it working, but I had to reformat my drive so I'm trying to reinstall it. I've got the based GTA IV working and running perfectly, but I can't get the LCPDFR mod to work. This issue seems to be posted on the forum a few times, but none of the suggestions seem to work for me. My ScriptHookDotNet log says:



2018-12-06 20:22:53 - STARTING SCRIPTS...
2018-12-06 20:22:54 - INFO: Phone number checks are not available!
2018-12-06 20:22:54 -  ...successfully started script 'LCPDFR_Loader.PublicScript'!
2018-12-06 20:22:54 -  ...successfully started script 'LCPDFR_Loader.Loader'!
2018-12-06 20:22:54 -  ...successfully started script 'Alpr.Alpr'!
2018-12-06 20:22:55 - Error during Tick in script 'LCPDFR_Loader.Loader':
                      System.IO.IOException: The process cannot access the file 'C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV\LCPD First Response.dll' because it is being used by another process.
                         at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
                         at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
                         at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
                         at LCPDFR_Loader.Test.LoadFile(String path)
                         at LCPDFR_Loader.Test.LoadAssembly()
                         at LCPDFR_Loader.Loader.Load()
                         at LCPDFR_Loader.Loader.Loader_Tick(Object sender, EventArgs e)
                         at GTA.Script.TryTick()
                         at GTA.Script.DoTick()
                         at GTA.ScriptThread.OnTick()
2018-12-06 20:23:30 - SCRIPTS TERMINATED!


Which is the error. It appears to be something to do with the LCPD First Response.dll file. I've already tried reinstalling C++, reinstalling .NET, reinstalling LCPDFR (both the xlive and dsound ASI launchers), manually installing LCPDFR, setting all GTA EXE files to run as admin, ensuring all files are not read-only and downgrading the GTA IV version (as explained on the forum). None of this works and the mod does not work. Pressing Alt + P does nothing and the "LCPDFR_Loader.Loader" script fails to start.


There is nothing that would have that DLL file open. I've even tried disabling my firewall and anti-virus, with no luck.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now