Jump to content
JoelS

Police lights & Sirens not working

Recommended Posts

I haven't played LSPDFR in awhile and I had seen that there was a small patch for GTA V so i updated Scripthook and GTA V but as soon as I got in and spawned my cars the Lights or sirens stopped working is there a way to fix this? I have reverted the game back to before the patch but everytime I try to play it trys to update. I have the Social club version of GTA V.

Share this post


Link to post
Share on other sites
16 minutes ago, JoelS said:

 but as soon as I got in and spawned my cars the Lights or sirens stopped working is there a way to fix this?

You have to be more specific here. What exactly happens.

Do the lights turn on? Do you hear sirens?

Edited by Pavy

Share this post


Link to post
Share on other sites

The lights turn on but stay static and they arent all on its just like half way. Sirens are muted no sound at all.

Share this post


Link to post
Share on other sites
1 hour ago, JoelS said:

The lights turn on but stay static and they arent all on its just like half way. Sirens are muted no sound at all.

If sirens are muted you need to verify your game files and rename ur mods folder to mods_

 

As for the static els go to openiv >tools>ask manager and uninstall the 3 things and click install. Restart your computer. 

Share this post


Link to post
Share on other sites

By verify you mean check everything and make sure its still the same as in before it got patched? And also to rename it to mods_? Because I did check Open IV after the patch and saw a file I did not recognize I didnt want to delete it because I didnt want to crash my game so I instead reverted to before the patch. 

If you need any images let me know ill be sure to include them

Share this post


Link to post
Share on other sites
38 minutes ago, JoelS said:

By verify you mean check everything and make sure its still the same as in before it got patched? And also to rename it to mods_? Because I did check Open IV after the patch and saw a file I did not recognize I didnt want to delete it because I didnt want to crash my game so I instead reverted to before the patch. 

If you need any images let me know ill be sure to include them

Go to Grand Theft Auto V\x64\audio\sfx\RESIDENT.rpf\    take that vehicles.awc and copy it into the modded location.
Grand Theft Auto V\mods\x64\audio\sfx\RESIDENT.rpf\    Test ur game out. Keep mods named mods

Share this post


Link to post
Share on other sites

Oh your saying to reuse my stock sirens from my og copy. Well I'm using some modded sirens that i installed and had to mute some other pointless sounds to get them to work. Shouldn't i just copy the modded resident.rpf into the new one after the game patches? I wouldn't want to go through the trouble of having to find the pointless sounds and remute everything.

Edited by JoelS

Share this post


Link to post
Share on other sites

I apologize, and No i haven't reupdated GTA V yet, because taking my stock audio files from the game and reusing them will by default replace my modded sirens that i have installed and for some reason those sirens take up alot of audio space. Hence why i had to mute useless sounds and the old sirens. Do you have a discord? I could send you images of what I'm talking about and so you can have visuals since this website only allows certain file sizes to be sent through.

Share this post


Link to post
Share on other sites
21 minutes ago, Pavy said:

You are making this very confusing.

Do your sirens work in-game yes or no

 

8 minutes ago, JoelS said:

I apologize, and No i haven't reupdated GTA V yet, because taking my stock audio files from the game and reusing them will by default replace my modded sirens that i have installed and for some reason those sirens take up alot of audio space. Hence why i had to mute useless sounds and the old sirens. Do you have a discord? I could send you images of what I'm talking about and so you can have visuals since this website only allows certain file sizes to be sent through.

I don't need any screenshots.

Your sentences are run-on and making things confusing.

You still didn't answer my question. 
What is CURRENTLY the issue you are having.

Share this post


Link to post
Share on other sites

As I said before I am hesitant to update my game to its latest patch because by doing so my lights turn static (no flashing) and sirens are muted. I dont know what that patch added but it added something or replaced something when I updated the game. I currently have my game reverted at version 1.0.1493.0. The Version that caused me the issue I explained above was version 1.0.1493.1. My Rage Plugin Hook is version 0.63.1224.15140. My Scripthook is updated to the latest. If I do the steps you mentioned for the sirens it will replace them. So will I just have to find another sound to mute? I just dont understand why it would mute after updating since nothing got added. As for the flashing lights issue I'll go ahead and do the steps you mentioned previously whenever I update my game.

Share this post


Link to post
Share on other sites
3 minutes ago, JoelS said:

As I said before I am hesitant to update my game to its latest patch because by doing so my lights turn static (no flashing) and sirens are muted. I dont know what that patch added but it added something or replaced something when I updated the game. I currently have my game reverted at version 1.0.1493.0. The Version that caused me the issue I explained above was version 1.0.1493.1. My Rage Plugin Hook is version 0.63.1224.15140. My Scripthook is updated to the latest. If I do the steps you mentioned for the sirens it will replace them. So will I just have to find another sound to mute? I just dont understand why it would mute after updating since nothing got added. As for the flashing lights issue I'll go ahead and do the steps you mentioned previously whenever I update my game.

 

Updating your game has absolute nothing to do with Sirens and lights. The update itself was like 60mb or something.

Each DLC changes the update.rpf in your game. Inside update.rpf contains basically any Visual graphical mods, the gameconfig.xml which controls the amount of modded cars you have,

your dlclist.xml which you need to add lines if you have any Add-on dlc packs you created. Nothing else.

Your audio files are located elsewhere. 

Share this post


Link to post
Share on other sites

So your saying I basically just have check everything and make sure its the same as before? And if not then fix it right?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×