Jump to content
Double Doppler

OpenIV randomly corrupts vehicle model files?

Recommended Posts

Hi,

 

So I’ve been modding my cars in-game recently. I’ve used police car modifications, transport and ambulances etc. with no issue in the past.

 

I’ve now installed several civilian car modifications to the game, testing each one to make sure it works. However, upon occasional CTDs and playing the game for a while, I’ve noticed I get an ERR_ZLIB error. I check my vehicles.rpf and some vehicle files cannot be open - they’ve become corrupted.

This has happened on two different occasions, with the exact same vehicle modes used where different files have been corrupted. What’s happening here? Why are my car model files being indiscrinately corrupted?

 

My vehicles.rpf is over 2GB but less that 3GB - it should still work technically and it has done for a few game sessions of over 1 hour each, however the files appear to be randomly corrupted.

 

Any helpful feedback would be appreciated - this issue is quite difficult to backtrack and I’d appreciate anyone who had good knowledge of installing lots of car mods and OpenIV to help out!

Share this post


Link to post
Share on other sites
On 9/1/2018 at 9:59 PM, Double Doppler said:

Hi,

 

So I’ve been modding my cars in-game recently. I’ve used police car modifications, transport and ambulances etc. with no issue in the past.

 

I’ve now installed several civilian car modifications to the game, testing each one to make sure it works. However, upon occasional CTDs and playing the game for a while, I’ve noticed I get an ERR_ZLIB error. I check my vehicles.rpf and some vehicle files cannot be open - they’ve become corrupted.

This has happened on two different occasions, with the exact same vehicle modes used where different files have been corrupted. What’s happening here? Why are my car model files being indiscrinately corrupted?

 

My vehicles.rpf is over 2GB but less that 3GB - it should still work technically and it has done for a few game sessions of over 1 hour each, however the files appear to be randomly corrupted.

 

Any helpful feedback would be appreciated - this issue is quite difficult to backtrack and I’d appreciate anyone who had good knowledge of installing lots of car mods and OpenIV to help out!

 

The corruption thing is a mystery to me as well.  I recently had my patchday18 vehicles corrupt randomly.  A post I read said it has something to do with moving files while in edit mode - I can't recall exactly.  It might've been that trying to move cars - while in edit mode - to your desktop causes it.  I recommend creating a folder on your desktop named vehicles rpf backup, and either throwing the good rpf in there, or the individual car files.  That way, if it corrupts, you have a nice backup.

 

Personally, I recommend just copying the vehicles over.  If the archive corrupts, you can easily remake it and you know it'll be fresh.

Share this post


Link to post
Share on other sites

An update regarding this - creating separate .rpfs in different dlc packs appeared to resolve this issue. Keeping the archive files individually below 2GB. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×