Jump to content
Sign in to follow this  
silentless

Problems with LCPDFR 0.95 black screen

Recommended Posts

Hello guys!

I have troubles with LCPDFR 0.95

I have legal steam version of GTA IV (eng ver) but after installing the mod, I start the game, load my save and... I see only radar, some textures, and Niko hair.Then I am trying to get outside I see only black screen with radar and can hear sounds of game.

the version of game 1.0.0.7, install mod without problems (successful), also I download diagnostic tool so you can see my screen.

Plz help me with this, and sorry for my crappy English, I am from Russia :D

Share this post


Link to post
Share on other sites

Hello guys!

I have troubles with LCPDFR 0.95

I have legal steam version of GTA IV (eng ver) but after installing the mod, I start the game, load my save and... I see only radar, some textures, and Niko hair.Then I am trying to get outside I see only black screen with radar and can hear sounds of game.

the version of game 1.0.0.7, install mod without problems (successful), also I download diagnostic tool so you can see my screen.

Plz help me with this, and sorry for my crappy English, I am from Russia :D

Greetings, and welcome to the world of GTA IV modding! :biggrin: Let's try to sort this problem out!

First off, can you post the entire message from the diagnostic tool? There is an entire section at the bottom (of your screenshot) that is cut off, and it may or may not indicate errors with the game and the mod. Right now, the portions that I can see look good, so the mod was installed successfully so far. Since you're saying you're only seeing a black screen, that can mean a problem with the graphics. Do you have any graphics mods installed at this time? Your GPU should be able to handle the game no problem.

also I look this topic with video

but it doesnt help me :(

Yeah, this isn't going to help if you've installed the mod correctly.

Hope we can find a solution for you to get the mod working!

Edited by Raggio

Share this post


Link to post
Share on other sites

Thankssss :D

I install this mod on fresh version without mods, i dont have any problems with graphic and GPU (HD 5870), and before this mod I play GTA IV :)

how can i put this diagnostic message?

in txt or like a post here?

Share this post


Link to post
Share on other sites

Thankssss :D

I install this mod on fresh version without mods, i dont have any problems with graphic and GPU (HD 5870), and before this mod I play GTA IV :)

how can i put this diagnostic message?

in txt or like a post here?

You're welcome! I just want to help you so that you can enjoy the mod as well! :wink:

Yes, you can just copy/paste the text from the diagnostics tool into a post here. This is just to see if there's any problems thats occuring that's not shown in your screenshot. Since you say this is a fresh install of the game with no other mods, and the game ran without the mod, then the mod has to be the culprit, as the beginning of the diagnostics report indicates you have all the proper files and programs needed to run the mod. After posting it, I'll see if I can help you troubleshoot with other methods to get it to work if the rest of the report is clean.

Edited by Raggio

Share this post


Link to post
Share on other sites

BEGIN *SIGNED* LCPD First Response Issue Report

Diagnostics Tool Version: 0.4.3

Operating system: Windows7 HomePremium (6.1.1.0 Build: 7601) Service Pack:Service Pack 1

System RAM (GB): 7,93

CPU cores: 8

NET Framework 4.0 installed: True

Visual C++ 2010 Redistributable installed: True

GTA IV - Installed: True

GTA IV - Install folder: D:Program Files (x86)SteamsteamappscommonGrand Theft Auto IVGTAIV

GTA IV - Version: 1, 0, 7, 0

GTA IV - Asi loader installed: True

GTA IV - Asi loader: DSOUND

GTA IV - Asi loader valid: True

GTA IV - C++ ScriptHook installed: True

GTA IV - C++ ScriptHook valid: True

GTA IV - C++ ScriptHook version: 0, 5, 1, 0

GTA IV - ScriptHookDotNet installed: True

GTA IV - ScriptHookDotNet valid: True

===============BEGIN .NET SCRIPTHOOK LOG===============

2012-05-08 13:35:08 - Initializing ScriptHookDotNet v1.7.1.4 BETA (GTA IV version 1.0.7.0)

2012-05-08 13:36:09 - Direct3D device created!

2012-05-08 13:36:10 - SEARCHING FOR SCRIPTS...

2012-05-08 13:36:11 - Loading scripts in Assembly 'scriptsFirstResponse.net.dll' ...

2012-05-08 13:36:11 - ...found script 'FirstResponse.Main.EmergencyLights'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.Main.Start'!

2012-05-08 13:36:11 - ...found script 'CSharp.Engine.Core'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.Debugging'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.DeletionList'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.Hardcore'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.TextDraw'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCMD.Main'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCMD.Functions'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCPD.Carboot'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCPD.Disarm'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCPD.Frisk'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCPD.PullOver'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCPD.Actions'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCPD.Debug'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCPD.Flashlight'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCPD.Functions'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCPD.Partner'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCPD.inputSimulator'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCPD.Start'!

2012-05-08 13:36:11 - ...found script 'FirstResponse.LCPD.Various'!

2012-05-08 13:36:11 - DONE! 21 valid scripts found!

2012-05-08 13:36:11 - STARTING SCRIPTS...

2012-05-08 13:36:11 - Error during GetPhoneNumber (Phone checks will be disabled):

System.Exception: Accessing Globals failed! Invalid Memory Address!

at unmanaged.MemoryAccess.GetGlobalAddress(Int32 index)

at unmanaged.MemoryAccess.GetPhoneNumber()

at GTA.NetHook.CheckPhone()

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCPD.Various'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCPD.Start'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCPD.inputSimulator'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCPD.Partner'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCPD.Functions'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCPD.Flashlight'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCPD.Debug'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCPD.Actions'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCPD.PullOver'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCPD.Frisk'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCPD.Disarm'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCPD.Carboot'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCMD.Functions'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.LCMD.Main'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.TextDraw'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.Hardcore'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.DeletionList'!

2012-05-08 13:36:11 - ...successfully started script 'FirstResponse.Debugging'!

2012-05-08 13:36:12 - ...successfully started script 'CSharp.Engine.Core'!

2012-05-08 13:36:13 - ...successfully started script 'FirstResponse.Main.Start'!

2012-05-08 13:36:13 - ...successfully started script 'FirstResponse.Main.EmergencyLights'!

2012-05-08 13:41:55 - Direct3D device lost!

2012-05-08 13:41:55 - SCRIPTS TERMINATED!

===============END .NET SCRIPTHOOK LOG===============

End of *SIGNED* LCPD First Response Issue Report

Digital signature: ZZDSb+Cz6H0ehFhyxVofjg==

Share this post


Link to post
Share on other sites

Hmm, this report appears fine. I was expecting a little more (and possibly some sort of error) at the end because the one in your screenshot (different report) looks like it has much more when scrolled down. But no matter, we can try some troubleshooting steps. Just to check, you are only seeing a black screen, but are not experiencing any errors/crashes? And also, have you enabled "Run as Admin" on LaunchGTAIV.exe and are using that to start the game? I'm wondering the cause behind the black screen, because the game works fine without the mod.

Edited by Raggio

Share this post


Link to post
Share on other sites

Hey man thanks for helping, i delete this mod, then i check for errors in steam for GTA IV, then install this mod again and YAHHOO its work)

but now I have problems with ahah i dont know how to say it on english (flashing,Luminescence) it doesnt work :) I hear sounds but dont see it)

i install it http://gtapolicemods.com/downloads.php?do=file&id=493 is it good mod?

From Russia, with big love!!! :D

Share this post


Link to post
Share on other sites

Hey man thanks for helping, i delete this mod, then i check for errors in steam for GTA IV, then install this mod again and YAHHOO its work)

You're welcome! I'm glad the mod is now working for you! I'm sorry the troubleshooting steps didn't work, but sometimes all it takes is a reinstall of the mod, and that was something I was thinking of if it didn't work after additional troubleshooting steps.

but now I have problems with ahah i dont know how to say it on english (flashing,Luminescence) it doesnt work :) I hear sounds but dont see it)

Alright, in terms of your new problem, what do you mean the "flashing" doesn't work? Do you mean that the police car lights aren't flashing? Or do you mean they aren't bright/illuminating enough? Only modified police vehicles need additional mods for them to look good; the default police vehicles are kind of crappy as far as their lights go.

i install it http://gtapolicemods...?do=file&id=493 is it good mod?

If you want to try that, you can feel free to do so (or did you mean you already installed it?). But I suggest manually installing the mods you want, as that will save you trouble (at the cost of time) in the end. As you can see, that installer has some things that you already have (e.g. LCPD:FR, ASI Loader), and so if you forget to uncheck those, you may end up breaking the mod again. Not to mention, this mod pack is really out of date anyways. I don't suggest installing mod packs, as it makes it harder to fix problems if they happen. (e.g. Car mods packs are classic examples--any one of the hundreds of car mods they install can cause a game to crash. But if you install each one yourself, you can test them out to make sure they are stable for your game)

If you want police cars that have bright, realistic flashing lightbars, then you'll need to install ELS and ELS-enabled car mods. That will definitely enhance your experience while playing LCPD:FR, that's for sure! ( to see what I'm talking about; customization makes it all the more fun!) If you want tips, suggestions, etc., feel free to ask me.

From Russia, with big love!!! :D

Same thing right back at you, from the US! :biggrin:

Edited by Raggio

Share this post


Link to post
Share on other sites

Yep, I mean that the police car lights aren't flashing.

Yeaah your pics are amazing!!! so cool)

okay I install ELS and ELS-enabled car mods.

and If you do not have hard to show what name of all your mods :thumbsup:

all mods on your pics are very interesting :biggrin:

Share this post


Link to post
Share on other sites

Yep, I mean that the police car lights aren't flashing.

Yeaah your pics are amazing!!! so cool)

okay I install ELS and ELS-enabled car mods.

and If you do not have hard to show what name of all your mods :thumbsup:

all mods on your pics are very interesting :biggrin:

Thanks for the complements! Those police vehicle and ped skins you see are my latest work that's unreleased at the moment. I am making SFPD (San Francisco Police Department) skins for a few more car mods, and adding more details to the ped mods as well. I am also making CHP (California Highway Patrol) and FOXHOUND texture mods as well, as you saw in my gallery!

I actually have a very long list of mods installed, lol! I am fine with telling you what mods I am using, but I think it is best if you narrow it down, because I have a myriad of mods in use right now! I have a graphics (ENB) mod installed (and it's why you see the fancy eye candy reflections and nice graphics in my screenshots), I have realistic texture mods (e.g. vegetation, roads) installed, I have car mods installed, I have weapon mods installed, I have sound mods installed, and I have script mods installed. On top of all that, I have custom skins/textures installed for the car and ped mods that I'm using as well. Is there anything specific you would like to know? Because I can type out a long list of mods, and I don't think that'll help you much. I chose all the mods I use because I like them very much, but another may not have the same feelings. If you let me know the things you want, like specific vehicles, weapons, etc., I can help you out more. Also, if you want to try searching for mods, there are tons of mods out there, and good sites to grab them from are gta4-mods.com, gtagarage.com, gtagaming.com, and many others. I specifically like gtainside.com for vehicle mods and am-team.ru for weapon mods.

To enhance your experience, I recommend you install Simple Native Trainer as well. It comes in handy at times! :wink:

Edited by Raggio

Share this post


Link to post
Share on other sites

And where i can download your mods :biggrin:SFPD, CHP, and FOXHOUND mods

I thank you for your interest in my mods! My mods are actually not released yet...sorry about that! :sad: The screenshots are previews for you to see my latest work in progress (WIP). I've been busy lately, and I'm still working on them to make them high quality and as close to perfect as I can get them. If and when I release them, I'll let you know! :wink:

But if you would like other suggestions for mods, I'd be more than happy to help you out! Just post in the GTA IV: Content Modification section, or send me a PM! :happy:

Happy modding, and have fun! :smile:

Edited by Raggio

Share this post


Link to post
Share on other sites

ahaha and do you have problems then car lights flashing and doors+ all devices in police car are shaking?)

When you use ELS, all it does is basically reload the same car model very fast but with different light textures each time, so it looks like the lights are flashing. This will cause the car to become indestructable, and you will see the doors shaking back and forth when you open and close them while using ELS. This is a normal bug of ELS, and won't be fixed since the developer has stopped working on it. We can only wait for as it doesn't require reloading the car model at high rates of speed. Other than that, the devices in the car shouldn't be shaking, because they are all part of the car's model and don't move.

Share this post


Link to post
Share on other sites

Raggio

Thanks a lot for your help!

I dont know,what I do without your help!!!

Thank you! :yes:

You are absolutely welcome, my friend! :happy:

Have a good time playing with the mods! And feel free to contact me whenever you have questions and/or want suggestions for mods! I'd be more than happy to help out! :wink:

See you around!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×