Jump to content
jared27

unhandled exeption once at p.d. with lcpdfr

Recommended Posts

My issue is not with the install as far as I know! I installed lcpdfr as shown and it took no problem ran as admin everything. now when I load the game it asks me about responing to calls lets me go on duty but when I arrive at the police department to check in right after I hit the red circle it takes me inside and says an unhandled exeption happened and wont let me leave the pd or go through with going on duty. I did the diagnostic and cant seem to see anything wrong. I also have a vehicle mod program its just the gta 4 vehicle modulator v1.3 off of the gtamod website. any help would be great

Share this post


Link to post
Share on other sites
  • Make sure you aren't using a crack - We don't support cracks
  • Update GTA IV to 1.0.7.0 (the latest version of the game, or 1.1.2.0 for EFLC) - This sometimes fixes a wide variety of issues
  • Make sure that you run the game as an administrator.
  • Make sure that your GTA IV root folder (and every subdirectory) is not set to "read-only"
  • Ensure that FirstResponse.net.dll is in the SCRIPTS folder and that AdvancedHook.dll is in the GTA IV ROOT folder.
  • Ensure that ScriptHook.dll, ScriptHookDotNet.asi and Dsound.dll OR Xlive.dll are in the GTA IV ROOT folder
  • Ensure that there is a folder titled 'LCPDFR' in the SCRIPTS folder.
  • Check that all the above files exist, if they do not, reinstall LCPDFR with the automatic installation.
  • Ensure that you are using up to date versions of every LCPDFR dependency and LCPDFR itself.
  • Install these: http://www.microsoft...9f-b21f31ab88b7http://www.microsoft...&displaylang=en
  • Run a diagnostic report (found here:  title="">http://www.lcpdfr.co...agnostics-tool/) which will point any errors it can find and will be used later on if you need to post a topic.

Also, update the GTA IV Vehicle Mod Installer to 1.6 version (http://gtavmi.com/en/download).

Share this post


Link to post
Share on other sites

Ok I installed all of this and it still does the same thing I can go on duty but when I go to check in as soon as I load into the pd it says an unhandled occurrence happened in the script. And then something in parentheses it flashes away to fast.

Share this post


Link to post
Share on other sites

Ok I installed all of this and it still does the same thing I can go on duty but when I go to check in as soon as I load into the pd it says an unhandled occurrence happened in the script. And then something in parentheses it flashes away to fast.

 

Go to your GTA IV/EFLC directory, open ScriptHookDotNet.log and LCPDFR.log files then copy and paste the contents here with the spoilers tags.

 

 Insert text here 



			
		

Share this post


Link to post
Share on other sites

Im not seeing either one of these this is what shows up in c:/programfiles(x86)/rockstargames/gta4

common  (file

config    (file

directX_update  (file

lang_readme   (file

movies   (file

offlineactivation  (file

pc  (file

rgsc  (file

scripts  (file

v1.6  (file

876bd1d9393712ac  (vlc media file

advancedhook.dll

advancedhook

alf.dll

amb_nailgun.wdr

amb_nailgun.wtd

asilog

binkw32.dll

dfa.dll

dsound.dll

files

firewallinstallhelper.dll

gameuxinstallhelper.dll

gta4browser

gtaencoder

gtaiv

gtaiv.exe

gtaiv.exe.cdf

gta.exe.cfg

gtaiv

gtaivgdf.dll

lang

lang_dfa

launchgtaiv

lcpdfr

liblua51.dll

livetokenhelper.dll

logo-paul

lua4net.dll

paul.dll

readme

revoke license

scripthook.dll

scripthook

scripthookdotnet.asi

scripthookdotnet

top

 

this is the main gta IV folder I want to say something looks to be missing but I can seem to figure out what besides maybe what you are bringing up. I hope this helps. still new to this. lol.

 

Share this post


Link to post
Share on other sites

that made it not work at all so i set it back. what it says is there was an unhandle exeption to see logfile then something at the end about program does not go back to a program it only flashes a couple seconds then im trapped with a red circle inside.

Share this post


Link to post
Share on other sites

Open ScriptHookDotNet text file then select all, copy and paste the contents here with the spoilers tags.

 

 Insert text here 



			
		

Share this post


Link to post
Share on other sites

it wont let me paste in the area up there so i dont know how else to put the spoiler tags on.

 

 

 

 

 

 

 

2013-09-17 19:35:37 - Initializing ScriptHookDotNet v1.7.1.4 BETA (GTA IV version 1.0.7.0)
2013-09-17 19:36:54 - Direct3D device created!

2013-09-17 19:36:55 - SEARCHING FOR SCRIPTS...
2013-09-17 19:36:55 - Loading scripts in Assembly 'scriptsFirstResponse.net.dll' ...
2013-09-17 19:36:55 -  ...found script 'FirstResponse.Main.EmergencyLights'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.Main.Start'!
2013-09-17 19:36:55 -  ...found script 'CSharp.Engine.Core'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.Debugging'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.DeletionList'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.Hardcore'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.TextDraw'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCMD.Main'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCMD.Functions'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCPD.Carboot'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCPD.Disarm'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCPD.Frisk'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCPD.PullOver'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCPD.Actions'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCPD.Debug'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCPD.Flashlight'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCPD.Functions'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCPD.Partner'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCPD.inputSimulator'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCPD.Start'!
2013-09-17 19:36:55 -  ...found script 'FirstResponse.LCPD.Various'!
2013-09-17 19:36:55 - DONE! 21 valid scripts found!

2013-09-17 19:36:56 - STARTING SCRIPTS...
2013-09-17 19:36:56 - Error during GetPhoneNumber (Phone checks will be disabled):
                      System.Exception: Accessing Globals failed! Invalid Memory Address!
                         at unmanaged.MemoryAccess.GetGlobalAddress(Int32 index)
                         at unmanaged.MemoryAccess.GetPhoneNumber()
                         at GTA.NetHook.CheckPhone()
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCPD.Various'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCPD.Start'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCPD.inputSimulator'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCPD.Partner'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCPD.Functions'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCPD.Flashlight'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCPD.Debug'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCPD.Actions'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCPD.PullOver'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCPD.Frisk'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCPD.Disarm'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCPD.Carboot'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCMD.Functions'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.LCMD.Main'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.TextDraw'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.Hardcore'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.DeletionList'!
2013-09-17 19:36:56 -  ...successfully started script 'FirstResponse.Debugging'!
2013-09-17 19:36:58 -  ...successfully started script 'CSharp.Engine.Core'!
2013-09-17 19:36:58 -  ...successfully started script 'FirstResponse.Main.Start'!
2013-09-17 19:36:58 -  ...successfully started script 'FirstResponse.Main.EmergencyLights'!
2013-09-17 19:39:08 - Error during NetHook.Tick:
                      System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
                         at unmanaged.NativeContext3.Invoke(Int32 nameptr, Byte[] args, Int32 argnum, NativeContext3* cxt)
                         at GTA.ScriptDomain.RemoteEvent(RemoteEventArgs ev)
                         at GTA.ScriptDomain.ProcessRemoteEvents()
                         at GTA.ScriptDomain.Tick()
                         at GTA.NetHook.Tick()
2013-09-17 19:39:34 - Direct3D device lost!
2013-09-17 19:39:35 - SCRIPTS TERMINATED!

Share this post


Link to post
Share on other sites

 

  • Make sure you aren't using a crack - We don't support cracks
  • Update GTA IV to 1.0.7.0 (the latest version of the game, or 1.1.2.0 for EFLC) - This sometimes fixes a wide variety of issues
  • Make sure that you run the game as an administrator.
  • Make sure that your GTA IV root folder (and every subdirectory) is not set to "read-only"
  • Ensure that FirstResponse.net.dll is in the SCRIPTS folder and that AdvancedHook.dll is in the GTA IV ROOT folder.
  • Ensure that ScriptHook.dll, ScriptHookDotNet.asi and Dsound.dll OR Xlive.dll are in the GTA IV ROOT folder
  • Ensure that there is a folder titled 'LCPDFR' in the SCRIPTS folder.
  • Check that all the above files exist, if they do not, reinstall LCPDFR with the automatic installation.
  • Ensure that you are using up to date versions of every LCPDFR dependency and LCPDFR itself.
  • Install these: http://www.microsoft...9f-b21f31ab88b7http://www.microsoft...&displaylang=en
  • Run a diagnostic report (found here:  title="">http://www.lcpdfr.co...agnostics-tool/) which will point any errors it can find and will be used later on if you need to post a topic.

 

 

Share this post


Link to post
Share on other sites

ok it better stay this time. I switched them all off and now it says their on read only so I will launch again and see.


so i uncheck and apply and as soon as i go back into properties the read only is checked again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×