Jump to content
Sign in to follow this  
MajorRod

How to change Control Keys for LCPD:FR

Recommended Posts

I found out that my keyboard on my MacBook Pro does not support "Fn" "Control" "Option/Alt" "Command" in GTA IV to enable On Duty. I am looking in the script file and wanted to know what Key meant. I could change P to something else, but that is not the issue. What does "Key" mean. What can I change it to so I can hit "Shift + P" to "Go on duty"? 

 

Cheers!

Share this post


Link to post
Share on other sites

"Key" in this case is the "command-key" for LCPDFR. It's the LeftAlt key. 

How and where can I go into the script and change this?

What would I need to do/type to change it so I can hit Shift+P to go on duty, if you know. =]

Cheers!

Share this post


Link to post
Share on other sites

You can't. The controls you see there are the ones you can change I believe. You could try using an key emulator to bind that key function to another key. 

Share this post


Link to post
Share on other sites

You can't. The controls you see there are the ones you can change I believe. You could try using an key emulator to bind that key function to another key. 

Could you recommend any that would work in this case. (It is a MacBook Pro 15" keyboard).

Share this post


Link to post
Share on other sites

Could you recommend any that would work in this case. (It is a MacBook Pro 15" keyboard).

I know some for Windows, but not mac. Hopefully someone else can point you there. Just search for "MAC key emulator" or something like that :)

Share this post


Link to post
Share on other sites

I know some for Windows, but not mac. Hopefully someone else can point you there. Just search for "MAC key emulator" or something like that :)

I'm on a Windows 7 Partition Boot Camped on my MBP.

Share this post


Link to post
Share on other sites

Ineseri, you've been a great help and I appreciate it a bunch. I actually used SharpKeys to change it to Shift instead of Option, and it worked! Thanks so much.

Now my issue is that GTA will not start. I got it to work for one gaming session, and I had to switch windows to check the ELS controls and it wouldn't let me go back. Now it will not start, any idea's? The G17 Media IV Diagnostics is not giving any error, other than all of a sudden the ASI Loader disappeared.

 

Edit: I got the game to work. Problem now, and has always been a problem is my ELS is not working even though I have pro ELS cars.

Edit 2: Got ELS to work. Forgot to make seperate ELS folder. All is well.


Edited by MajorRod

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×