Jump to content
OfficerJRiley

what is required to be installed to play LCPD:FR?

Recommended Posts

I am just starting with lcpd:fr and before I download it, what needs to be installed on my computer?

 

I have a windows 8 computer, upgraded from Windows 7.

 

Thanks in advance,

 

Josh

Share this post


Link to post
Share on other sites

Well for starters, you need a legal copy of Grand Theft Auto IV, or EFLC. 

 

Grand Theft Auto IV

(http://store.steampowered.com/app/12210/?snr=1_7_15__13

Grand Theft Auto IV: Complete

(http://store.steampowered.com/app/901583/?snr=1_7_15__13)

EFLC

(http://store.steampowered.com/app/12220/)

 
Edited by ineseri

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×