Jump to content
CD45 Productions

GTA IV Laggy Radeon HD 7950 & FX 8350

Recommended Posts

Hey guys, hows it going?

 

I'm bringing up a problem that I cannot solve no matter how many google searches I do.

 

Before you tell me to update my drivers or GTA IV is poorly ported game, I have this problem on every game I play..and I have the most up to date drivers. I have a steady 10 - 20 FPS all the time, even when recording with FRAPS. I just know, even if GTA IV is poorly ported, that I should be getting much more than this..especially with my specs.

 

Heres a complete list of my specs

 

 

Processor: AMD FX 8350 @ 4.0 GHz

Graphics Card: AMD Radeon HD 7950 3GB DDR5 by Gigabyte

RAM: Corsair Vengeance 8GB 1600MHz DDR3

1TB Seagate Hard Drive

120 GB Solid State Drive

Motherboard: MSI 970A-G46

 

Any help will be appreciated! 

 

Thanks,

CD45 Productions

 

Share this post


Link to post
Share on other sites

how many mods do you have if you've modded all the cars there is no need to just do the police vehicles...... it could be other programs you're running at the same time,try defraging gta..... i have a 2.1ghz processed and a mobility radeon hd 4250 and i have very little lagg so you should be doing good

Share this post


Link to post
Share on other sites

I have nothing other than Teamspeak 3 in the background. No processes what so ever.

 

Also like to add the hard drive is brand new.

Like I said, even with mods, GTA IV isn't the only game with this problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×