Jump to content
Sign in to follow this  
N00bLeader91

Random Boats Spawining Instead of cars

Recommended Posts

So as the title suggests I have boats spawning, so far the Squalo and Reefer, instead of a car. I have the following mods installed:

 

Trainer

LCPD:FR

ELS

DAS

Police Helper

Traffic Flow

RCMP car/mod pack (From the RCMP GTA IV Clan)

Google Maps Radar

Indicator Script

 

There might be something in the RCMP pack that is changing the vehicles that spawn but I looked through the files and didn't see a Traffic Flow type of file in the pack, and I've used the pack before with no problems.

 

The game runs with no other problems aside from the boats spawning on the streets and the crashing that I'm pretty sure everyone gets. (It would be nice if there was a fix for this too ;) )

 

PC:

8gb RAM

Radeon 6450

i5-2390T

Windows 7 64-Bit

Share this post


Link to post
Share on other sites

* Use Open IV or Spark to verify the models from the RCMP package.

* Check the # POPCYCLE_GROUP_COPS line within the cargrp.dat file to make sure that line isn't screwed up. It should be similar to this: police, police2, polpatriot, noose, pstockade, nstockade, fbi, police3, police4, policeb, predator,

Share this post


Link to post
Share on other sites
* Use Open IV or Spark to verify the models from the RCMP package.

* Check the # POPCYCLE_GROUP_COPS line within the cargrp.dat file to make sure that line isn't screwed up. It should be similar to this: police, police2, polpatriot, noose, pstockade, nstockade, fbi, police3, police4, policeb, predator,

 

I looked and that seems to check out. I should've clarified that it's not the cop cars spawning as boats, boats just show up with a civilian driving them slowly grinding to a halt down the road.

 

EDIT: I dispatched/requested some roadblocks in Police Helper and it turns out that whatever is supposed to spawn comes up as a Reefer. I haven't found the culprit for the other boats yet.

Edited by N00bLeader91

Share this post


Link to post
Share on other sites

Well thats just weird, what i would do is get inside the boat driving and see what name comes up, could tell you something, and if it just comes up as the boats name im really not sure what to tell ya, sorry haha

Share this post


Link to post
Share on other sites

Perhaps you accidently replaced certain car models with boats? Try throwing in a clean vehicles.img file and see if that fixes anything.

Share this post


Link to post
Share on other sites

This comes right from the RCMP clan forums.. Its referencing a video of the problem in mulitplayer which up to now the developers of the mod said only had the issue in single player.

SSgt Crocker- "Ok, I'll need to see that. That's odd, because the only thing that has really changed in this pack from previous packs is the vehicles. It's just not possible that a vehicle model update could cause this issue. The only thing that can cause this issue is the GTA 4 taxi bug. I'm not sure why it decided to start spawning boats instead of taxis. It might be related to some edits in the cargrp.dat file." 

 

The other issue with this mod is that firefighters are often shown in place of police on calls. For example firefighters drive police cars, and attend shootouts etc armed and shooting.

 

That said I see more and more ppl having this problem, myself included. They need to support their releases better in my humble opinion.

 

+++NOTE+++
The "pack" is a download from the above mentioned clan and is not installed through SparksIV or similar, its just a matter of overwriting various files with those provided. I wonder if this installation process might have something to do with it?

Edited by Nortie

Share this post


Link to post
Share on other sites

This comes right from the RCMP clan forums.. Its referencing a video of the problem in mulitplayer which up to now the developers of the mod said only had the issue in single player.

SSgt Crocker- "Ok, I'll need to see that. That's odd, because the only thing that has really changed in this pack from previous packs is the vehicles. It's just not possible that a vehicle model update could cause this issue. The only thing that can cause this issue is the GTA 4 taxi bug. I'm not sure why it decided to start spawning boats instead of taxis. It might be related to some edits in the cargrp.dat file." 

 

The other issue with this mod is that firefighters are often shown in place of police on calls. For example firefighters drive police cars, and attend shootouts etc armed and shooting.

 

That said I see more and more ppl having this problem, myself included. They need to support their releases better in my humble opinion.

 

+++NOTE+++

The "pack" is a download from the above mentioned clan and is not installed through SparksIV or similar, its just a matter of overwriting various files with those provided. I wonder if this installation process might have something to do with it?

 

Ah, ok, I did have a look around there but didn't really find anything. The firefighter skin is on purpose though. I'm pretty sure for their role-playing games, its just easier to pick a firefighter skin the way they have it. It doesn't necessarily bother me; its not a huge deal like crashing into a boat during a pursuit on the freeway is :P

 

Well thats just weird, what i would do is get inside the boat driving and see what name comes up, could tell you something, and if it just comes up as the boats name im really not sure what to tell ya, sorry haha

 

Yeah, when I get in the boat it has the boat name, not a car. It must be like a Taxi Bug but with boats, like what Nortie said.

Share this post


Link to post
Share on other sites

Thanks everyone for the help, it turns out that the problem was in the cargrp.dat file and Sgt Crocker is uploading a new a mirror for it soon for those of you who have the RCMP pack and are having the same problem.

Share this post


Link to post
Share on other sites

Curious about news on the updated cargrp file?? anyone have it or know where it can be downloaded can't find it on the clan site

Share this post


Link to post
Share on other sites

ATTENTION! Thanks for everyones help, but the problem has been resolved literally 10 minutes ago.

 

Sgt. Crocker from the GTA IV RCMP clan posted a forum thread with the fix.

 

If you are using the RCMP pack candidate 6.5, then put the file in the GTAIV/common/data folder.

 

File is here http://gta-rcmpclan.ca/forum/post/last/m/4724576/viewthread/5406878-boat-spawning-issue-fix-for-65-rc-1#last

 

You may have to just rename the file to cargrp because when I downloaded it there were a bunch of numbers but that couldve just been my firefox.

Share this post


Link to post
Share on other sites

when I try to view the download in the clan site it says: "You do not have sufficient access to view this page."
 

 



any other mirror that you have to download this file? I really needed...!!!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×