Jump to content
Sign in to follow this  
rifledude

Issues with vehicles.meta

Recommended Posts

So I am trying to add 3 sheriff vehicles to the Christmas dlc. I already have a bunch of working vehicles in it. The issue is when I add any of these three vehicles into the file it crashes when the game is populating the world.

Thing is, these vehicle values are exactly copied and pasted from the defaults (these 3 are variants of default vehicles) and renamed to create new vehicles.

At first I thought I must have hit some sort of restriction in the Christmas dlc, so I put them in a custom DLC pack I had downloaded, and I got the same result which was a crash during loading.

So that's my issue. I have tested this a dozen times, and my game works great without any of these three vehicles, but crashes if I try adding any of them via any DLC. I have already checked for conflicts in other data files, and I can't find anything.

I'm not exactly an expert at modding so if there's something that you think I missed I'd appreciate any help.

Share this post


Link to post
Share on other sites
3 hours ago, rifledude said:

So I am trying to add 3 sheriff vehicles to the Christmas dlc. I already have a bunch of working vehicles in it. The issue is when I add any of these three vehicles into the file it crashes when the game is populating the world.

Thing is, these vehicle values are exactly copied and pasted from the defaults (these 3 are variants of default vehicles) and renamed to create new vehicles.

At first I thought I must have hit some sort of restriction in the Christmas dlc, so I put them in a custom DLC pack I had downloaded, and I got the same result which was a crash during loading.

So that's my issue. I have tested this a dozen times, and my game works great without any of these three vehicles, but crashes if I try adding any of them via any DLC. I have already checked for conflicts in other data files, and I can't find anything.

I'm not exactly an expert at modding so if there's something that you think I missed I'd appreciate any help.

You've exceeded the limit as defined in gameconfig.xml and you need to edit it.

See this thread:

 

Edited by Kilyin

Share this post


Link to post
Share on other sites

Of course there's a hard limit. I just assumed there wasn't because people are slinging add on DLCs like its nothing.

Thanks for your help man. Everything is working perfectly now, I can stop beating my head on the wall.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×