Jump to content
TheTerminatorNY

LCPD:FR 0.95 - Can't go on duty

Recommended Posts

This mod has always interested me, so I purchased GTA IV from Steam the other day just to play with this mod. I downloaded the game, downloaded the mod and installed it. Now, when I press Alt+P in the game, nothing happens! When I press Ctrl+P it'll say "Duty Forced" on the screen and I'll get random crimes and call-outs, but that's playing as Niko. I can't actually go on duty as a police officer.

 

Just for the hell of it, I downloaded version 0.91 and it worked. I was able to go on duty and everything worked perfectly. So I tried installing 0.95 again and I still can't go on duty.

 

Thanks for any help.

 

I downloaded the diagnostic tool and this is what I got:

 

 

 

BEGIN *SIGNED* LCPD First Response Issue Report
Diagnostics Tool Version: 0.4.3
Operating system: WindowsVista HomePremium (6.0.1.0 Build: 6001) Service Pack:Service Pack 1
System RAM (GB): 4
CPU cores: 2
NET Framework 4.0 installed: True
Visual C++ 2010 Redistributable installed: True
GTA IV - Installed: True
GTA IV - Install folder: C:Program Files (x86)SteamsteamappscommonGrand Theft Auto IVGTAIV
GTA IV - Version: 1, 0, 7, 0
GTA IV - Asi loader installed: True
GTA IV - Asi loader: DSOUND
GTA IV - Asi loader valid: True
GTA IV - C++ ScriptHook installed: True
GTA IV - C++ ScriptHook valid: True
GTA IV - C++ ScriptHook version: 0, 5, 1, 0
GTA IV - ScriptHookDotNet installed: True
GTA IV - ScriptHookDotNet valid: True
===============BEGIN .NET SCRIPTHOOK LOG===============
2013-07-21 12:31:59 - Initializing ScriptHookDotNet v1.7.1.4 BETA (GTA IV version 1.0.7.0)
2013-07-21 12:33:28 - Direct3D device created!

2013-07-21 12:33:29 - SEARCHING FOR SCRIPTS...
2013-07-21 12:33:29 - Loading scripts in Assembly 'scriptsFirstResponse.net.dll' ...
2013-07-21 12:33:29 -  ...found script 'FirstResponse.Main.EmergencyLights'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.Main.Start'!
2013-07-21 12:33:29 -  ...found script 'CSharp.Engine.Core'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.Debugging'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.DeletionList'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.Hardcore'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.TextDraw'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCMD.Main'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCMD.Functions'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCPD.Carboot'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCPD.Disarm'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCPD.Frisk'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCPD.PullOver'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCPD.Actions'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCPD.Debug'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCPD.Flashlight'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCPD.Functions'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCPD.Partner'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCPD.inputSimulator'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCPD.Start'!
2013-07-21 12:33:29 -  ...found script 'FirstResponse.LCPD.Various'!
2013-07-21 12:33:29 - Loading scripts in Assembly 'scriptsStrobes.net.dll' ...
2013-07-21 12:33:29 -  ...found script 'FullStrobes.FullStrobes'!
2013-07-21 12:33:29 - DONE! 22 valid scripts found!

2013-07-21 12:33:29 - STARTING SCRIPTS...
2013-07-21 12:33:30 - Error during GetPhoneNumber (Phone checks will be disabled):
                      System.Exception: Accessing Globals failed! Invalid Memory Address!
                         at unmanaged.MemoryAccess.GetGlobalAddress(Int32 index)
                         at unmanaged.MemoryAccess.GetPhoneNumber()
                         at GTA.NetHook.CheckPhone()
2013-07-21 12:33:30 -  ...successfully started script 'FullStrobes.FullStrobes'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCPD.Various'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCPD.Start'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCPD.inputSimulator'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCPD.Partner'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCPD.Functions'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCPD.Flashlight'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCPD.Debug'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCPD.Actions'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCPD.PullOver'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCPD.Frisk'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCPD.Disarm'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCPD.Carboot'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCMD.Functions'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.LCMD.Main'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.TextDraw'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.Hardcore'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.DeletionList'!
2013-07-21 12:33:30 -  ...successfully started script 'FirstResponse.Debugging'!
2013-07-21 12:33:31 -  ...successfully started script 'CSharp.Engine.Core'!
2013-07-21 12:33:32 -  ...successfully started script 'FirstResponse.Main.Start'!
2013-07-21 12:33:32 -  ...successfully started script 'FirstResponse.Main.EmergencyLights'!
2013-07-21 12:45:11 - Direct3D device lost!
2013-07-21 12:45:12 - SCRIPTS TERMINATED!

===============END .NET SCRIPTHOOK LOG===============
===============BEGIN LCPD FIRST RESPONSE LOG===============
[7/20/2013 10:56:03 AM] [ASTATS] Sending: {"CPUCount":2,"GTAVersion":16779008,"LCPDGUID":"b334fdc9-7d52-4dc6-a2b0-9782859a919b","LCPDVersion":"0.91","RAMCount":0,"WinVersion":"Microsoft Windows NT 6.0.6001 Service Pack 1"}
[7/20/2013 10:56:03 AM] [sTATISTICS] System.Net.WebException: The underlying connection was closed: The connection was closed unexpectedly.
   at System.Net.HttpWebRequest.GetResponse()
   at 0.1.LCPDFR-Obfuscated-12.0.4(Object A_0)
[7/20/2013 10:56:04 AM] [ASTATS] Anonymous usage stats not sent: possible server failure or no connectivity.
[7/20/2013 10:58:03 AM] [uPDATECHECK] System.Net.WebException: The remote name could not be resolved: 'update.lcpdfr.com'
   at System.Net.HttpWebRequest.GetResponse()
   at 0.1.LCPDFR-Obfuscated-12.1(Object A_0)
[7/20/2013 10:58:30 AM] [sTATISTICS] System.Net.WebException: The underlying connection was closed: The connection was closed unexpectedly.
   at System.Net.HttpWebRequest.GetResponse()
   at 0.1.LCPDFR-Obfuscated-12.0.4(Object A_0)
[7/20/2013 11:00:42 AM] [uPDATECHECK] System.Net.WebException: The remote name could not be resolved: 'update.lcpdfr.com'
   at System.Net.HttpWebRequest.GetResponse()
   at 0.1.LCPDFR-Obfuscated-12.1(Object A_0)
[7/20/2013 11:02:37 AM] [sTATISTICS] System.Net.WebException: The underlying connection was closed: The connection was closed unexpectedly.
   at System.Net.HttpWebRequest.GetResponse()
   at 0.1.LCPDFR-Obfuscated-12.0.4(Object A_0)

===============END LCPD FIRST RESPONSE LOG===============
End of *SIGNED* LCPD First Response Issue Report
Digital signature: VRv3+7LNABPkvzr7z1UIpA==

Share this post


Link to post
Share on other sites

Try this... goto the console and type "reloadscripts"

 

See if that helps. Also look at the text that the console is spitting out at you. Make sure there are no errors with the scripts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×