Jump to content
Rareroblox

GTA IV Black/White screen after loading into game

Recommended Posts

Hello. I installed a new siren for GTA IV, and then when I went into the game to test it out, my game just went black/white when spawning into game. This doesn't happen when it loads the cutscene stuff, only when physically spawned in. Here is a picture of what I'm talking about, and this has not happened. Hopefully this can be resolved. Thanks.

image.png.9338aa74531f557ec2a21701bf2caeec.png

Share this post


Link to post
Share on other sites

Is your game original from steam/standalone? If steam, try verifying the integrity of your game files, will CERTAINLY solve it out;
 

Instructions 1.png
 

Instructions 2.png

 

If you're using standalone version, try this: Create a new text document named “commandline.txt” and place it in the root game folder with "-verify" (without the quotes) in it. Then run the game.
It works in GTA 5, and hopefully in GTA 4, but I am not sure because I use Steam version.

I am almost sure it wasn't caused by the siren you installed, since it's .WAV file that shouldn't mess up with your graphics, unless it was a trap mod.


EDIT: Sorry for portuguese stuff, I tried to clarify as much as I could

Edited by Hamilton.

Share this post


Link to post
Share on other sites
1 hour ago, Sgt. Hamilton said:

Is your game original from steam/standalone? If steam, try verifying the integrity of your game files, will CERTAINLY solve it out;
 

Instructions 1.png
 

Instructions 2.png

 

If you're using standalone version, try this: Create a new text document named “commandline.txt” and place it in the root game folder with "-verify" (without the quotes) in it. Then run the game.
It works in GTA 5, and hopefully in GTA 4, but I am not sure because I use Steam version.

I am almost sure it wasn't caused by the siren you installed, since it's .WAV file that shouldn't mess up with your graphics, unless it was a trap mod.


EDIT: Sorry for portuguese stuff, I tried to clarify as much as I could

I am using steam, but if I verify integrity cache, it will delete all of my vehicles, sirens, etc. I'll try the command line thing. Thanks.

Share this post


Link to post
Share on other sites
On 13/01/2018 at 12:49 AM, Rareroblox said:

I am using steam, but if I verify integrity cache, it will delete all of my vehicles, sirens, etc. I'll try the command line thing. Thanks.

Yes that's true, but it's a good option since it is 100% sure of fix.
Try backuping the vehicle files' directory, as in GTA V they are like x64e, x64d etc. then you do the files integrity stuff

Share this post


Link to post
Share on other sites
22 hours ago, Sgt. Hamilton said:

Yes that's true, but it's a good option since it is 100% sure of fix.
Try backuping the vehicle files' directory, as in GTA V they are like x64e, x64d etc. then you do the files integrity stuff

Okay, I have fixed it by reinstalling the game. The only problem now is, is that me and my friend are trying to play LCPDFR 1.1, but it keeps keeps kicking me out of the multiplayer session and taking me back to Single Player. The only way I can play is by using LCPDFR 0.95, and it's really annoying. We are both using the same mods. My friend is not having this issue.

Share this post


Link to post
Share on other sites

Hey, 

 

For the first issue that was caused by texture losing, you should create a commanline inside your game folder in order to fix it. 

 

Second, for multiplayer, how did you connect to the server, whether by LAN or LIVE? Either way, make sure you download GFWL(games for windows live), and login to the windows live program. And minimize the GFWL window, don't quit. Then launch the game. If you can sigin to GFWL then you won't have any problem with play online, the major problem I've seen and 

experienced was the GFWL signin problem, caused online problem.   

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...