Jump to content
Him1250

ELS V8 crashing when entering a ELS enabled vehicle

Recommended Posts

Hey Guys, ever since ELS V8 has been released I've only been able to play once without it crashing. And my problem is whenever I enter a ELS enabled vehicle my game crashes. I've tried at least 20 different vehicles that I have either made or other people have made. Here's my logs:
Log started on: 4:56:48 5-14-2014
------------------------
[iNFO - 4:56:48] Gameversion - 1.0.7.0
[iNFO - 4:56:48] Data unprotected
[iNFO - 4:56:48] Game patched
[iNFO - 4:56:48] Xlive protections disabled
[iNFO - 4:56:48] AdvancedHook 0.1f14 LCPD:FR 0.95 © 2010-2011 LMS - Initialized
[iNFO - 4:56:48] Thanks to listener, aru and #iv-modding
[iNFO - 4:56:48] Attaching exception handler...
[iNFO - 4:56:48] Exception handler attached
[iNFO - 4:56:48] Patching game functions...
[iNFO - 4:56:48] New instance created: ELS
[iNFO - 4:58:30] An exception occured
[iNFO - 4:58:30] Process: D90000

 Address: 5

 Code: C0000005

 Registerdump - EAX: 3E8 EBP: 75DBBBF0 EBX: 5 ECX: 6295BCF8 EDI: F5AFA1C EDX: 51F3160 EIP: 5 ESI: F7911F8 ESP: 692AFC68


Log start: Wed May 14 04:56:48 2014
-----------------------------------------------
[iNFO] GTA IV Script Hook 0.5.1 - © 2009, Aru - Initialized
[iNFO] Process base address: 0x1190000
[iNFO] Auto detecting game version
[iNFO] Using game version 1.0.7
[iNFO] Initiating: Luxart Emergency Lighting System (ELS) by Lt.Caine
[iNFO] (ELS) Script started: ELS V8.0 R-000
[iNFO] (ELS) Files - General information retrieved.
[iNFO] (ELS) Files - VMID [002] 'AMBULANCE',
[iNFO]       <ACTIVE> Using data from file: 'default_config'
[iNFO]       wrn_type: leds
[iNFO]       pri_type: leds
[iNFO]       sec_type: leds
[iNFO] (ELS) Files - VMID [027] 'FBI',
[iNFO]       <ACTIVE> Using data from file: 'default_config'
[iNFO]       wrn_type: leds
[iNFO]       pri_type: leds
[iNFO]       sec_type: leds
[iNFO] (ELS) Files - VMID [031] 'FIRETRUCK',
[iNFO]       <ACTIVE> Using data from file: 'default_config'
[iNFO]       wrn_type: leds
[iNFO]       pri_type: leds
[iNFO]       sec_type: leds
[iNFO] (ELS) Files - VMID [052] 'NOOSE',
[iNFO]       <ACTIVE> Using data from file: 'default_config'
[iNFO]       wrn_type: leds
[iNFO]       pri_type: leds
[iNFO]       sec_type: leds
[iNFO] (ELS) Files - VMID [063] 'POLICE',
[iNFO]       <ACTIVE> Using data from file: 'default_config'
[iNFO]       wrn_type: leds
[iNFO]       pri_type: leds
[iNFO]       sec_type: leds
[iNFO] (ELS) Files - VMID [064] 'POLICE2',
[iNFO]       <ACTIVE> Using data from file: 'default_config'
[iNFO]       wrn_type: leds
[iNFO]       pri_type: leds
[iNFO]       sec_type: leds
[iNFO] (ELS) Files - VMID [065] 'POLPATRIOT',
[iNFO]       <ACTIVE> Using data from file: 'default_config'
[iNFO]       wrn_type: leds
[iNFO]       pri_type: leds
[iNFO]       sec_type: leds
[iNFO] (ELS) Files - Vehicle information retrieved. Detected [7] ELS-enabled models.
[iNFO] [AdvScriptThread] Thread started
[iNFO] [EmergencyLightingSystem] Thread started
[iNFO] [simpleTrainer] Thread started
[iNFO] [scriptHookDotNet] Thread started


2014-05-14 04:56:48 - Initializing ScriptHookDotNet v1.7.1.4 BETA (GTA IV version 1.0.7.0)
2014-05-14 04:58:07 - Direct3D device created!

2014-05-14 04:58:07 - SEARCHING FOR SCRIPTS...
2014-05-14 04:58:07 - Loading scripts in Assembly 'scriptsFirstResponse.net.dll' ...
2014-05-14 04:58:07 -  ...found script 'FirstResponse.Main.EmergencyLights'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.Main.Start'!
2014-05-14 04:58:07 -  ...found script 'CSharp.Engine.Core'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.Debugging'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.DeletionList'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.Hardcore'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.TextDraw'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCMD.Main'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCMD.Functions'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Carboot'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Disarm'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Frisk'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.PullOver'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Actions'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Debug'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Flashlight'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Functions'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Partner'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.inputSimulator'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Start'!
2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Various'!
2014-05-14 04:58:07 - DONE! 21 valid scripts found!

2014-05-14 04:58:07 - STARTING SCRIPTS...
2014-05-14 04:58:07 - Error during GetPhoneNumber (Phone checks will be disabled):
                      System.Exception: Accessing Globals failed! Invalid Memory Address!
                         at unmanaged.MemoryAccess.GetGlobalAddress(Int32 index)
                         at unmanaged.MemoryAccess.GetPhoneNumber()
                         at GTA.NetHook.CheckPhone()
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Various'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Start'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.inputSimulator'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Partner'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Functions'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Flashlight'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Debug'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Actions'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.PullOver'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Frisk'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Disarm'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Carboot'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCMD.Functions'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCMD.Main'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.TextDraw'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.Hardcore'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.DeletionList'!
2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.Debugging'!
2014-05-14 04:58:07 -  ...successfully started script 'CSharp.Engine.Core'!
2014-05-14 04:58:08 -  ...successfully started script 'FirstResponse.Main.Start'!
2014-05-14 04:58:08 -  ...successfully started script 'FirstResponse.Main.EmergencyLights'!




Hope someone can point me in the right direction on how to fix it. :)

 

 

   -Him1250

 

 

Edit: So I have reinstalled my game about 3 times and I moved the scripts folder out of the IV main directory to see if there are any script conflicts. Still crashes.

Edited by Him1250

Share this post


Link to post
Share on other sites

 

Hey Guys, ever since ELS V8 has been released I've only been able to play once without it crashing. And my problem is whenever I enter a ELS enabled vehicle my game crashes. I've tried at least 20 different vehicles that I have either made or other people have made. Here's my logs:

Log started on: 4:56:48 5-14-2014

------------------------

[iNFO - 4:56:48] Gameversion - 1.0.7.0

[iNFO - 4:56:48] Data unprotected

[iNFO - 4:56:48] Game patched

[iNFO - 4:56:48] Xlive protections disabled

[iNFO - 4:56:48] AdvancedHook 0.1f14 LCPD:FR 0.95 © 2010-2011 LMS - Initialized

[iNFO - 4:56:48] Thanks to listener, aru and #iv-modding

[iNFO - 4:56:48] Attaching exception handler...

[iNFO - 4:56:48] Exception handler attached

[iNFO - 4:56:48] Patching game functions...

[iNFO - 4:56:48] New instance created: ELS

[iNFO - 4:58:30] An exception occured

[iNFO - 4:58:30] Process: D90000

 Address: 5

 Code: C0000005

 Registerdump - EAX: 3E8 EBP: 75DBBBF0 EBX: 5 ECX: 6295BCF8 EDI: F5AFA1C EDX: 51F3160 EIP: 5 ESI: F7911F8 ESP: 692AFC68

Log start: Wed May 14 04:56:48 2014

-----------------------------------------------

[iNFO] GTA IV Script Hook 0.5.1 - © 2009, Aru - Initialized

[iNFO] Process base address: 0x1190000

[iNFO] Auto detecting game version

[iNFO] Using game version 1.0.7

[iNFO] Initiating: Luxart Emergency Lighting System (ELS) by Lt.Caine

[iNFO] (ELS) Script started: ELS V8.0 R-000

[iNFO] (ELS) Files - General information retrieved.

[iNFO] (ELS) Files - VMID [002] 'AMBULANCE',

[iNFO]       <ACTIVE> Using data from file: 'default_config'

[iNFO]       wrn_type: leds

[iNFO]       pri_type: leds

[iNFO]       sec_type: leds

[iNFO] (ELS) Files - VMID [027] 'FBI',

[iNFO]       <ACTIVE> Using data from file: 'default_config'

[iNFO]       wrn_type: leds

[iNFO]       pri_type: leds

[iNFO]       sec_type: leds

[iNFO] (ELS) Files - VMID [031] 'FIRETRUCK',

[iNFO]       <ACTIVE> Using data from file: 'default_config'

[iNFO]       wrn_type: leds

[iNFO]       pri_type: leds

[iNFO]       sec_type: leds

[iNFO] (ELS) Files - VMID [052] 'NOOSE',

[iNFO]       <ACTIVE> Using data from file: 'default_config'

[iNFO]       wrn_type: leds

[iNFO]       pri_type: leds

[iNFO]       sec_type: leds

[iNFO] (ELS) Files - VMID [063] 'POLICE',

[iNFO]       <ACTIVE> Using data from file: 'default_config'

[iNFO]       wrn_type: leds

[iNFO]       pri_type: leds

[iNFO]       sec_type: leds

[iNFO] (ELS) Files - VMID [064] 'POLICE2',

[iNFO]       <ACTIVE> Using data from file: 'default_config'

[iNFO]       wrn_type: leds

[iNFO]       pri_type: leds

[iNFO]       sec_type: leds

[iNFO] (ELS) Files - VMID [065] 'POLPATRIOT',

[iNFO]       <ACTIVE> Using data from file: 'default_config'

[iNFO]       wrn_type: leds

[iNFO]       pri_type: leds

[iNFO]       sec_type: leds

[iNFO] (ELS) Files - Vehicle information retrieved. Detected [7] ELS-enabled models.

[iNFO] [AdvScriptThread] Thread started

[iNFO] [EmergencyLightingSystem] Thread started

[iNFO] [simpleTrainer] Thread started

[iNFO] [scriptHookDotNet] Thread started

2014-05-14 04:56:48 - Initializing ScriptHookDotNet v1.7.1.4 BETA (GTA IV version 1.0.7.0)

2014-05-14 04:58:07 - Direct3D device created!

2014-05-14 04:58:07 - SEARCHING FOR SCRIPTS...

2014-05-14 04:58:07 - Loading scripts in Assembly 'scriptsFirstResponse.net.dll' ...

2014-05-14 04:58:07 -  ...found script 'FirstResponse.Main.EmergencyLights'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.Main.Start'!

2014-05-14 04:58:07 -  ...found script 'CSharp.Engine.Core'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.Debugging'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.DeletionList'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.Hardcore'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.TextDraw'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCMD.Main'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCMD.Functions'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Carboot'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Disarm'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Frisk'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.PullOver'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Actions'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Debug'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Flashlight'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Functions'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Partner'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.inputSimulator'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Start'!

2014-05-14 04:58:07 -  ...found script 'FirstResponse.LCPD.Various'!

2014-05-14 04:58:07 - DONE! 21 valid scripts found!

2014-05-14 04:58:07 - STARTING SCRIPTS...

2014-05-14 04:58:07 - Error during GetPhoneNumber (Phone checks will be disabled):

                      System.Exception: Accessing Globals failed! Invalid Memory Address!

                         at unmanaged.MemoryAccess.GetGlobalAddress(Int32 index)

                         at unmanaged.MemoryAccess.GetPhoneNumber()

                         at GTA.NetHook.CheckPhone()

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Various'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Start'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.inputSimulator'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Partner'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Functions'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Flashlight'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Debug'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Actions'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.PullOver'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Frisk'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Disarm'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCPD.Carboot'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCMD.Functions'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.LCMD.Main'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.TextDraw'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.Hardcore'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.DeletionList'!

2014-05-14 04:58:07 -  ...successfully started script 'FirstResponse.Debugging'!

2014-05-14 04:58:07 -  ...successfully started script 'CSharp.Engine.Core'!

2014-05-14 04:58:08 -  ...successfully started script 'FirstResponse.Main.Start'!

2014-05-14 04:58:08 -  ...successfully started script 'FirstResponse.Main.EmergencyLights'!

Hope someone point me in the right direction on how to fix it. :)

 

 

   -Him1250

 

 

Edit: So I have reinstalled my game about 3 times and I moved the scripts folder out of the IV main directory to see if there are any script conflicts. Still crashes

Do you have LCPDFR 1.0b installed?

 

-Edit: I see that you have 0.95. I am having the same problem but I would try setting compatilbity to Windows XP Service Pack 3 or Windows Vista Service Pack 2

Edited by mrhexable

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×