Jump to content
Sign in to follow this  
XPZKModzHD

Random Slow Motion

Recommended Posts

So i just got a new desktop today and installed GTA IV. But as im playing my game just enters slow motion for like 15-30secs. This isnt lag i have experienced lag before and i can tell this is slow motion. 

My Specs:

 
Processor: AMD FX-8120 Eight-Core Processor 3.1GHz
Ram: 6GB DDR3
OS: Windows 8 64-bit 
Graphics Card: AMD Radeon HD 7670 Series

Share this post


Link to post
Share on other sites

Hello, this sounds like the anti-piracy measure put in by Rockstar. Do you have a legal copy of the game? 

Yes this is a 100% legal copy of the game. When i had it installed on my laptop i never had the problem. My laptop was terrible to run the game.

Share this post


Link to post
Share on other sites

What kind of mods are you using? ELS-Cars maybe?

I do have mods but this happend when i didn't have mods in after i first installed the game. So i know its the game and not the mods.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...