Jump to content

Traffic Policer (Breathalyzer, Traffic Offences, Speed Detection & more) 6.15.0.0

   (294 reviews)

14 Screenshots

 

https://www.youtube.com/albo1125

Traffic Policer is now open source. https://github.com/Albo1125/Traffic-Policer

 

Welcome to Traffic Policer! This script modification for LSPDFR greatly enhances not only traffic policing, but policing in general. It sports various major features that will make your shift as a police officer much more realistic, and, above all, fun! 

Requirements - some of these are included (credits go to their appropriate authors):

  • LSPDFR 0.4 (not included)
  • Albo1125.Common 6.6.3.0 or higher (included)
  • RAGENativeUI 1.6.3.0 or higher (included)
  • RAGEPluginHook 0.51 or higher (not included)
  • A legal copy of GTA V (versions 1.0.1011.1-1.0.1604.1).

Installation Instructions are provided in the ReadMe & Documentation files.

Traffic Policer's Features are explained in the Documentation files & video.

 

Support - what to do if you encounter a bug or have problems:

  1. Watch the installation video for my modifications here.
  2. Use this tool: http://www.lcpdfr.com/files/file/9755-lspdfr-troubleshooter-by-albo1125/ 
  3. Read the documentation file if you're having trouble getting a specific feature to work.
  4. Suggestions can be made here.
  5. If all else fails: Please leave a comment (not a review). Include your RAGEPluginHook.log file, located in your Grand Theft Auto V folder. Also, please provide an accurate description of what happened. This allows me to help you as fast as possible.

Redistribution is prohibited.

 

https://www.youtube.com/albo1125


What's New in Version 6.15.0.0

Released

6.15.0.0 (01-03-2019)

Added compatibility for LSPDFR 0.4 (thanks @PeterU and RiverGrande for the contributions!)
Exception catching in motorcyclist without a helmet event until the crash can be narrowed down (thanks RiverGrande!)
Added licence plate randomisation in all callouts (thanks PeterU!) and ambient events
The default Mimic keybinding has been changed to Ctrl R (from Ctrl Q) to avoid an LSPDFR keybinding conflict.
INI has been updated with the default Mimic key.

 

6.14.3.0 (29-11-2018)
Fixed an issue where the NoLightsAtDark ambient event chance in the INI was not respected.
Some code cleanup.
Open sourced at https://github.com/Albo1125/Traffic-Policer
Updated licence.
Removed obfuscation.

Some more information on the open-sourcing and my 'retirement'

 

Use comments to ask for support. Do NOT use reviews to ask for support! You will get ignored and reported as this is against community guidelines.

Albo1125
- All donators and those who have supported my work
- RiverGrande for his contributions to the repository
- PeterU for his contributions to the repository
- LMS - Great support & help with creating the API and some other complicated stuff
- TheUniT - for his contributions to the Street Race ambient event, namely writing the code to mod the vehicles.



User Feedback

Recommended Comments



34 minutes ago, fayaz786aire said:

one more thing bro i am also facing issue with the LSPDFR+ when every i try to pullover any suspect the the default  pull over key Lshiftkey will not function

Did you ever change your sprint key? Is capslock on? if it is, turn it off

Edited by Kal74

Share this comment


Link to comment
Share on other sites

Also, if you have any further issues with LSPDFR+  post over on the LSPDFR+ page as this page is for Traffic Policer. and no problem

Edited by Kal74

Share this comment


Link to comment
Share on other sites
29 minutes ago, Kal74 said:

Also, if you have any further issues with LSPDFR+  post over on the LSPDFR+ page as this page is for Traffic Policer. and no problem

sure bro thank you again bye tc

Share this comment


Link to comment
Share on other sites
12 hours ago, johnspecht0625 said:

 

Agreed!! People DO NOT listen or read ini files!

 

Did you try and just load the MARKSMANPISTOL in the trainer?



 

Yes, that way it work but not the get all weapons, but for now I don't mind the get all weapons. Just letting yall know thats all :)

Edited by Silentaire

Share this comment


Link to comment
Share on other sites
41 minutes ago, Razor343 said:

im having a crash and was wondering if someone could help me. every time i go on duty after installing albo's plugins, lspdfr crashes. it runs fine without his plugins installed

 

  It seems your crash happens as it tries to initialize the custom key bindings, scrap your ini file and replace it with a fresh one and see if that helps. 

 

Share this comment


Link to comment
Share on other sites
59 minutes ago, Razor343 said:

im having a crash and was wondering if someone could help me. every time i go on duty after installing albo's plugins, lspdfr crashes. it runs fine without his plugins installed

 

rph log: https://pastebin.com/X8vuv2iA


This is exactly what's happening to me @GunnDawg now you have information to go off of. i had the exact rph log. 

Edited by dead2self89

Share this comment


Link to comment
Share on other sites

@dead2self89 not sure if you meant to tag me in that reply or not because you tagged my name and then mentioned an entirely different problem than I am having. Nothing crashes for me, I just can't properly use marksmanpistol in the car.

Share this comment


Link to comment
Share on other sites
4 hours ago, dead2self89 said:

Dude.....anybody.....please help....

https://pastebin.com/X8vuv2iA
 

 

Update your RAGENativeUI.dll (you are on 1.5.1.0) You should be on 1.6.3.0

 

https://github.com/alexguirre/RAGENativeUI/releases

 

Also, make sure you're using the most current version of Albo1125.Common.dll (6.6.0.0)

 

If you have Albos plugins updated, those files were included in the Zip from the download. You should of replaced the outdated ones unless you never moved them into your GTAV Folder or you haven't updated any plugins from Albo1125

Edited by Kal74

Share this comment


Link to comment
Share on other sites

@Albo1125  Since no one has asked, will there be an update to stop FPS drop in game I wish there was an option too revert back to the old 6.13.6 version, if someone has them could they please send.

Share this comment


Link to comment
Share on other sites
5 hours ago, Troopercharles said:

@Albo1125  Since no one has asked, will there be an update to stop FPS drop in game I wish there was an option too revert back to the old 6.13.6 version, if someone has them could they please send.

Nobody but Albo1125 is allowed to send you any of his files. It says right in the Licence agreement

 

5a7c29771336b_2018-02-0805_39_26-Licence-Notepad.png.fc4e53342ec9e7cb0c5fdfd6f05b7b8b.png

 

 

Share this comment


Link to comment
Share on other sites
On 2/7/2018 at 10:37 PM, Troopercharles said:

@Albo1125  Since no one has asked, will there be an update to stop FPS drop in game I wish there was an option too revert back to the old 6.13.6 version, if someone has them could they please send.

 

Aside from what Kal74 said, it's against our guidelines for users to redistribute content/mods that isn't theirs.  You've been on the forum long enough to know this. 

Share this comment


Link to comment
Share on other sites

Hi there,

 

When I pull over a vehicle and try to use CTRL + T to move it while in a pull over, it says "Unable to detect pulled over vehicle." Do you have any ideas why this is happening?
 

Thanks in advance.

Share this comment


Link to comment
Share on other sites
25 minutes ago, BlazingFlames said:

Hi there,

 

When I pull over a vehicle and try to use CTRL + T to move it while in a pull over, it says "Unable to detect pulled over vehicle." Do you have any ideas why this is happening?
 

Thanks in advance.

I think ctrl+t is follow mode. Then you have to be in front of the vehicle you have stopped. With ctrl+q they mimick you when you’re  behind the vehicle you’ve  stopped. 

Share this comment


Link to comment
Share on other sites
15 minutes ago, BlazingFlames said:

Hi there,

 

When I pull over a vehicle and try to use CTRL + T to move it while in a pull over, it says "Unable to detect pulled over vehicle." Do you have any ideas why this is happening?
 

Thanks in advance.

Are you in front or behind the vehicle when pressing that? Unless you changed something in the .ini you should be in front of the car when pressing CTRL + T

CTRL + T = FollowMe(in front of suspects car)

CTRL + Q = Mimic (behind suspect car)

CTRL + W = Custom Pullover (behind suspect car)

Share this comment


Link to comment
Share on other sites

May I get some help so I can downgrade my albo mod's to RageNativeUI 1.2, receiving tons of lag when approaching vehicles (10-20fps). My system is fine GTX 1070, i7 4770k, 16gb of RAM. I have seen many other people with the same issue and it has been resolved by downgrading albo's mods; however, I truly don't know how to downgrade them.

Share this comment


Link to comment
Share on other sites
On 16/01/2018 at 7:32 AM, Recklessjay said:

It says that since the update. It, in fact, works perfectly fine. As long as you have his common file updated its pretty much good. 

Fixed it a long time ago mate, i was new to modding. Appreciate that you took the time to reply though.

Share this comment


Link to comment
Share on other sites

Alrighty, so I got an issue. Been using all your mods for years. Recently, however, when I go on duty and get in a car, the game crashes. I have narrowed it down to traffic policer. I have done a clean install of my game on a new hard drive, installed only traffic policer and it still happens. I've been using an old version of Traffic policer for the past day now and that works, however, it prevents smart radio from working since it's an outdated version. The issue only happens after I go on duty, whenever I enter a car. The game freezes and crashes. Anyway, I've searched through the Rage logs, to no avail, posted on the forums, etc.  If you could help me out, that'd be great.

EDIT: I also recently discovered that it crashes when I take out the Marksman Pistol, which I know is the radar gun by default. So I know it must be something to do with TP as a whole. The callouts work as far as I'm aware. But basically, anything else to do with TP seems to cause a crash

RagePluginHook.log

Edited by JackLabs

Share this comment


Link to comment
Share on other sites

Sorry if this has already been discussed, but when I use the marksman pistol as a speed gun, it still fires like the unmodded marksman pistol; I do however get a readout of the vehicle speed.  It's weird in that it seems to only be "half modded."  I've never had an issue installing this mod in the past.  Does anyone know what the issue could be?  Conflicting with another mod like Rippler's realism or something? Thanks

Share this comment


Link to comment
Share on other sites

I have problems with the mewest version of this mod, when i go in a vehicle, my game crashes, i had seen my menyoo lok stoped recording and of cause of reserges, i had find than it must be this mod, after downgrading it works fantastic but just police smart radio, i have no prewierst version

Share this comment


Link to comment
Share on other sites

Think before you post. Toxic behavior will not be tolerated. Unconstructive, toxic or unnecessarily sarcastic comments will be removed and warnings issued.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...