Jump to content

Traffic Policer (Breathalyzer, Traffic Offences, Speed Detection & more) 6.15.0.0

   (294 reviews)

14 Screenshots

 

https://www.youtube.com/albo1125

Traffic Policer is now open source. https://github.com/Albo1125/Traffic-Policer

 

Welcome to Traffic Policer! This script modification for LSPDFR greatly enhances not only traffic policing, but policing in general. It sports various major features that will make your shift as a police officer much more realistic, and, above all, fun! 

Requirements - some of these are included (credits go to their appropriate authors):

  • LSPDFR 0.4 (not included)
  • Albo1125.Common 6.6.3.0 or higher (included)
  • RAGENativeUI 1.6.3.0 or higher (included)
  • RAGEPluginHook 0.51 or higher (not included)
  • A legal copy of GTA V (versions 1.0.1011.1-1.0.1604.1).

Installation Instructions are provided in the ReadMe & Documentation files.

Traffic Policer's Features are explained in the Documentation files & video.

 

Support - what to do if you encounter a bug or have problems:

  1. Watch the installation video for my modifications here.
  2. Use this tool: http://www.lcpdfr.com/files/file/9755-lspdfr-troubleshooter-by-albo1125/ 
  3. Read the documentation file if you're having trouble getting a specific feature to work.
  4. Suggestions can be made here.
  5. If all else fails: Please leave a comment (not a review). Include your RAGEPluginHook.log file, located in your Grand Theft Auto V folder. Also, please provide an accurate description of what happened. This allows me to help you as fast as possible.

Redistribution is prohibited.

 

https://www.youtube.com/albo1125


What's New in Version 6.15.0.0

Released

6.15.0.0 (01-03-2019)

Added compatibility for LSPDFR 0.4 (thanks @PeterU and RiverGrande for the contributions!)
Exception catching in motorcyclist without a helmet event until the crash can be narrowed down (thanks RiverGrande!)
Added licence plate randomisation in all callouts (thanks PeterU!) and ambient events
The default Mimic keybinding has been changed to Ctrl R (from Ctrl Q) to avoid an LSPDFR keybinding conflict.
INI has been updated with the default Mimic key.

 

6.14.3.0 (29-11-2018)
Fixed an issue where the NoLightsAtDark ambient event chance in the INI was not respected.
Some code cleanup.
Open sourced at https://github.com/Albo1125/Traffic-Policer
Updated licence.
Removed obfuscation.

Some more information on the open-sourcing and my 'retirement'

 

Use comments to ask for support. Do NOT use reviews to ask for support! You will get ignored and reported as this is against community guidelines.

Albo1125
- All donators and those who have supported my work
- RiverGrande for his contributions to the repository
- PeterU for his contributions to the repository
- LMS - Great support & help with creating the API and some other complicated stuff
- TheUniT - for his contributions to the Street Race ambient event, namely writing the code to mod the vehicles.



User Feedback

Recommended Comments



Hello I have to install traffic police and he tells me that the version is not compatible with the game while it is the latest version available all other plungins work well except the one and when I run on duty I receive an intervention my crash game followed by 3 beeps and yet the depanneur d'albo detects nothing at all thank you for helping me galley for days

Share this comment


Link to comment
Share on other sites

Albo, how to i change the talkback key in this plugin? Cus i have X as my autocallout key (dont know how to change) but i also have X as my talkback key...

Share this comment


Link to comment
Share on other sites

I have been using the most current update for this plugin with no problem, until last Monday. Now when I try to go on duty the game freezes up, and I get a message saying that Traffic policer is not compatible with the current version of the game.

 

Follow Up: I think I may have found what was causing my issue. I'm not 100% sure why the error was telling me that it was this mod causing issues, but it - at least for me - was another plugin:  Attempted Crime Callouts. Once I removed it from my Plugins folder, everything loaded smoothly.

Edited by GoldenBuffy

Share this comment


Link to comment
Share on other sites

Help! When I go on duty it says all your scripts have to be updated (LSPDFR+, Traffic, Arrest manager, and radio) I have the latest version of GTA 5 on steam, the latest version of RPH, and the latest versions of your scripts.

Share this comment


Link to comment
Share on other sites

At first:

This mod is amazing!

But scince i reinstalled GTA V and all my mods, something doesnt work correctly in this mod.

Everey time i click on 'issue Ticket' LSPDFR crashes and i have to reload all. Please Help me!

 

1 minute ago, crisimisi said:

At first:

This mod is amazing!

But scince i reinstalled GTA V and all my mods, something doesnt work correctly in this mod.

Everey time i click on 'issue Ticket' LSPDFR crashes and i have to reload all. Please Help me!

 

 

Share this comment


Link to comment
Share on other sites

Hey Albo! Love this mod, but can you please update this so it works on the latest build of gta 5 (even if you were to wait until after the Doomsday Heist DLC that'd be perfectly understandable) because myself and other user of this mod are having major stability issues as long as Traffic Policer is installed.  Mine is whenever i get out of my car, LSPD:FR crashes.  i've tried taking every other mod besides T.P. out, but with no luck.  once i took traffic policer out, the problem stopped.  Im guessing its just because it was last updated back in September.

Share this comment


Link to comment
Share on other sites
3 hours ago, tume said:

hey, i need help. when i open up speed checker i cant move the red circle thingy anywhere.

 

You need NUM LOCK on. Then use the numberpad.

Share this comment


Link to comment
Share on other sites

@Albo1125 Is it possible to add a function to albo1125common.dll to continue on own risk if it is an unsupported version instead of having to wait for an update to come out?

Share this comment


Link to comment
Share on other sites

traffic policer error says game is a newer version and not compatible please help :(

10 minutes ago, throbak1991 said:

traffic policer error says game is a newer version and not compatible please help :(

please update it crashes my game because it is not compatible!

Share this comment


Link to comment
Share on other sites
On 10/25/2017 at 4:45 PM, Exectuor101 said:

anyone please help me traffic policer is making my game crash every time it says that traffic policer is outdated but there is no new version. please albo anyone help me

Please tell me there is a solution 

Share this comment


Link to comment
Share on other sites
On 12/1/2017 at 6:17 AM, GoldenBuffy said:

I have been using the most current update for this plugin with no problem, until last Monday. Now when I try to go on duty the game freezes up, and I get a message saying that Traffic policer is not compatible with the current version of the game.

 

Follow Up: I think I may have found what was causing my issue. I'm not 100% sure why the error was telling me that it was this mod causing issues, but it - at least for me - was another plugin:  Attempted Crime Callouts. Once I removed it from my Plugins folder, everything loaded smoothly.

That did not work lol

On 12/3/2017 at 12:26 AM, bur587 said:

Help! When I go on duty it says all your scripts have to be updated (LSPDFR+, Traffic, Arrest manager, and radio) I have the latest version of GTA 5 on steam, the latest version of RPH, and the latest versions of your scripts.

SAME any solutions !?

Share this comment


Link to comment
Share on other sites

hey it hasn't worked for me since this latest gta update. I just got my own computer to play lspdfr and I'm trying to set up all the right plugins to play how I want to and one of the most needed parts isn't compatible :(

Share this comment


Link to comment
Share on other sites
3 hours ago, Dreamallday1408 said:

hey it hasn't worked for me since this latest gta update. I just got my own computer to play lspdfr and I'm trying to set up all the right plugins to play how I want to and one of the most needed parts isn't compatible :(

Guys update to the newest RPH just released , it fixed it for people

Share this comment


Link to comment
Share on other sites

Think before you post. Toxic behavior will not be tolerated. Unconstructive, toxic or unnecessarily sarcastic comments will be removed and warnings issued.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...