Jump to content

Emergency Lighting System 1.05

   (177 reviews)

Cyan

Some anti-virus software flag ELS as unsafe. We have independently verified there is nothing unsafe in ELS. You do not need to create a thread about it, instead, you should whitelist the folder or disable anti-virus software.

Message added by Cyan

3 Screenshots

Emergency Lighting System V brings one of the most popular modifications ever created for a GTA title (ELS-IV) to Grand Theft Auto V. ELS-V will add a whole new dimension to  your patrols. With a fresh look and many more features than its predecessor, it's also sure to brighten up your game and satisfy the emergency lighting enthusiast in anyone.

 

DESCRIPTION
− ELS provides an alternate and incredibly in-depth way of controlling emergency vehicle lights and sounds.
− ELS requires vehicle models specifically designed to make use of its features.
− ELS includes over 200 unique lighting patterns scattered across 4 light groups and lighting formats.

 

NOTES
Please consult the ELS USER GUIDE and other provided documentation prior to using ELS.

− As of V1.00 ELS is not compatible with any form of multiplayer.
− A visual enhancement mod is recommended to improve the appearance of ELS lights in game.

 

BASIC INSTALLATION
− A GTAV ScriptHook must be installed for any .asi modification to work. The original may be found HERE.
− Using script modifications in GTA Online can result in a temporary or permanent ban from the service.

− 1. Place ELS.asi, ELS.ini, the ELS folder, and  AdvancedHookV.dll inside your main GTA V game directory.
− 2. Download and install (a) pro-ELS vehicle model(s).
− 3. Start your game.

 

CREDITS
− ELS is coded by Lt.Caine.

− AdvancedHookV and vehicle damage feature coded by LMS.
− ELS-V testing team (alphabetical order): Albo1125, BxBugs123, GravelRoadCop, PoliceWag, and Prophet.


What's New in Version 1.05

Released

  • Removed auto deletion of discarded ELS vehicles to prevent crashes when using certain LSPDFR plugins.
  • Removed ELS manipulation of AI vehicles as persistent/not persistent for same reason.
  • Removed strobe corona flash sounds (while retaining sound effects for halogen patterns).
  • Toggling the ELS information panel will now reload everything in the ELS.ini.
  • Fixed error in ELS User Guide that incorrectly associated SCNL with extra_11 and TKDL with extra_12 (the opposite is true).
  • Updated ELS User Guide to reflect new changes.
  • ELS.ini change: Added "AllowController" option to CONTROL section to allow enabling/disabling controller input for ELS.
  • ELS.ini change: Added "TogKeysLock" option to CONTROL section to allow changing ELS key lock button.
Lt.Caine
LMS



User Feedback

Recommended Comments



When I first installed ELS, it worked perfectly. But now when i press the J key, the lights don't turn on. I don't know why. Anybody have a solution?

Share this comment


Link to comment
Share on other sites

Hey guys I am still new to LSPDFR, Love absolutely love the game and plan on being an officer sometime soon. However, I have had nothing but problems with installing the ELS cars, and the lighting working. Are there any step by step installation videos? If so please let me know! Thank you!!

 

Share this comment


Link to comment
Share on other sites

Awesome Mod !!! However i have a problem in using the siren change using the T button , it only blurps manually but when  i press it to change from current tone it doesnt  go to or stay on the next tone. Also if i press my cinematic camera button the cinematic view doesnt work and it sounds the manual siren tone. Does anyone have ideas as to why?

Share this comment


Link to comment
Share on other sites
17 minutes ago, Kurse said:

Awesome Mod !!! However i have a problem in using the siren change using the T button , it only blurps manually but when  i press it to change from current tone it doesnt  go to or stay on the next tone. Also if i press my cinematic camera button the cinematic view doesnt work and it sounds the manual siren tone. Does anyone have ideas as to why?

the button T is not a switch siren, its just a blip button. IF you press T and Y you will get the secondary or third siren tone. IF you want to switch siren press 1, 2, 3 ,4 or 5 to switch siren. About the the cinematic button, i have the same problem to and idk why. 

Share this comment


Link to comment
Share on other sites

cant seem to figure out what i did wrong, i dont half the els control panel in the bottom right of my screen. anyway i can fix? but els still works just i dont have the control panel.

Share this comment


Link to comment
Share on other sites

great mod, but can you eliminate the bug that enables some spawned els vehicles from disappearing, conflicts with better ems, and maybe siren mastery integration

Share this comment


Link to comment
Share on other sites

HELP! There is a problem when I try to pull suspects over with LSPDFR, the button I normally use to pull people over no longer works. Also when I Call for backup from the LSPDFR backup menu the police come with no lights on, and continue to have no lights on I have it set to were it should be on but its not any help would be nice.

Share this comment


Link to comment
Share on other sites
On 1/15/2017 at 9:24 PM, RogueThunder said:

So has anyone noticed that if you change siren tones behind a fleeing suspect they just drive straight?? Its like the siren keys are canceling out the AI's driving pursuit path.  

Same

Share this comment


Link to comment
Share on other sites
1 hour ago, RogueThunder said:

ya if you disable the traffic control in the ELS.ini it fix's the issue

I saw ur forum. Still would be nice to not have to turn that off. Thanks mayne

Share this comment


Link to comment
Share on other sites
22 hours ago, XboyX said:

HELP! There is a problem when I try to pull suspects over with LSPDFR, the button I normally use to pull people over no longer works. Also when I Call for backup from the LSPDFR backup menu the police come with no lights on, and continue to have no lights on I have it set to were it should be on but its not any help would be nice.

Make Sure that they are pro ELS cars , also that in the .INI file you have the ELS for AI set to true and max els vehicles set to a decent number, Also make sure during all installation of ELS vehicles to have each vehicles VCF file placed in ELS folder in gta 5 directory pack default, whichever slot the vehicle is in the corresponding VCF should have that name

 

This has by far been one of my favorite additions to LSPDFR ! 

Edited by Kurse

Share this comment


Link to comment
Share on other sites
2 hours ago, Kurse said:

Make Sure that they are pro ELS cars , also that in the .INI file you have the ELS for AI set to true and max els vehicles set to a decent number, Also make sure during all installation of ELS vehicles to have each vehicles VCF file placed in ELS folder in gta 5 directory pack default, whichever slot the vehicle is in the corresponding VCF should have that name

 

This has by far been one of my favorite additions to LSPDFR ! 

Still no luck I changed everything and the ai was already set to 'true'. The lights work its just that the ai do not turn lights on, and the button to pull over does not work.

Share this comment


Link to comment
Share on other sites

What sound do you change in Open iV that corresponds with the alternate 2 siren? Right now it is the default one and I dont know what to change to make it a different one.

Share this comment


Link to comment
Share on other sites

anyone else has cars, with lights dont work? im sure the car ive installed is els enabled, ive placed the els file into the proper place but why doesnt it work? 

Share this comment


Link to comment
Share on other sites

im having an issue when i load the game i can use the els cars without a problem but as soon as i load lspdfr none of the els will work, i cant even get the els panel to close off the screen
. does anyone have any ideas i could try?

Share this comment


Link to comment
Share on other sites

Whenever I pull people over before they fully stop they start driving all over the road on top of mountains and everything it only started happening after I got ELS anyone know if there's a fix?

Share this comment


Link to comment
Share on other sites
1 hour ago, ShoTzz said:

Whenever I pull people over before they fully stop they start driving all over the road on top of mountains and everything it only started happening after I got ELS anyone know if there's a fix?

Make sure you read previous comments as they may contain the solution to your problems already. Your issue is caused by the ELS Traffic Control function. Open your ELS.ini in your main directory and find the line "ElsTrafCtrlOn = true". Change the value "true" to "false" and save the document. Launch your game, test, and profit. 

 

You're welcome.

Share this comment


Link to comment
Share on other sites
9 minutes ago, DefenderOfThisHouse said:

Make sure you read previous comments as they may contain the solution to your problems already. Your issue is caused by the ELS Traffic Control function. Open your ELS.ini in your main directory and find the line "ElsTrafCtrlOn = true". Change the value "true" to "false" and save the document. Launch your game, test, and profit. 

 

You're welcome.

It did not work, I still can't pull people over and the LSPDFR backup do not arrive with there lights on

Share this comment


Link to comment
Share on other sites

I have looked at several videos, including the one listed here on the mini-forum, but to no avail. I have no idea of what to do. Can someone help?

Share this comment


Link to comment
Share on other sites

hey man, so i installed ELS 1.5 today, downloaded 1 car. Went in game, went on duty and ELS worked, but the lights were not bright.... at all, i could not see them in the day time, but at night, you could see the lights on buildings around me. but the actual light bar were very dim. I have screenshots if needed. Can someone help me solve this? Also, the add-on to the car, IE antenna and pushbar, would disappear and reaper with the lights on.  HELP PLEASE.

Share this comment


Link to comment
Share on other sites
11 hours ago, LSPDsanjay said:

anyone else has cars, with lights dont work? im sure the car ive installed is els enabled, ive placed the els file into the proper place but why doesnt it work? 

yes, that has happened to me, stage 3 at night will kinda work, but the lights are still VERY dim and the Addons flash on and off (IE the pushbar)

Share this comment


Link to comment
Share on other sites
3 hours ago, RJT426 said:

hey man, so i installed ELS 1.5 today, downloaded 1 car. Went in game, went on duty and ELS worked, but the lights were not bright.... at all, i could not see them in the day time, but at night, you could see the lights on buildings around me. but the actual light bar were very dim. I have screenshots if needed. Can someone help me solve this? Also, the add-on to the car, IE antenna and pushbar, would disappear and reaper with the lights on.  HELP PLEASE.

same deal. I tried it on 6 different cars and the same issue is happening. the light bar, grill lights, and window lights are on, but very dim and the radiation off of objects is very bright, no idea how to fix this at all

 

Share this comment


Link to comment
Share on other sites

I have no idea what is stemming this issue. I booted up GTA V today and ELS done-quit on me. None of my current ELS cars work. This is completely out of the blue as the game worked fine yesterday. Come to think of it, the horns/lights/sirens won't activate on any emergency vehicle period, ELS or not, including civilian vehicles with caution lights (tow truck, tractor, etc.). All the VCFs are still in their regular location. The VCF folder and the main ELS files have not been touched in regards to editing their settings.

Share this comment


Link to comment
Share on other sites

Think before you post. Toxic behavior will not be tolerated. Unconstructive, toxic or unnecessarily sarcastic comments will be removed and warnings issued.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...