Jump to content

Welcome to LCPDFR.com
Want to get involved? Make an account with us to start posting your own content, get full access to our massive downloads section, download files at a faster speed, and interact with 121587 other members. Already a member? login here - otherwise create an account for free today!


advertise here

Photo

"Object does not match target type" Question


Best Answer Matosh, 06 August 2013 - 05:55 AM

Delete those and extract scripthook files as I said in my previous post.

Go to the full post


Warning!
Guest, the last post of this topic was over 30 days ago and you should not bump this topic, unless you have a very valid reason for doing so.
Bumping a topic for an invalid reason may be a community guidelines violation and your account may be sanctioned.


  • You cannot reply to this topic
This support issue is OPEN. Feel free to add an answer. If you'd like to ask your own question, create a new topic instead of replying to this one.
6 replies to this topic

#1
AirCanada190

AirCanada190

    Newbie

  • Members
  • 3 posts

Posted 05 August 2013 - 03:26 PM

Hi Everyone,

 

First off, great mod! I've been using it error free for about a year now, but last week tried to install the bait car mod. When it didnt work, I uninstalled it, but now I get an error message after I select my player uniform. After selecting the uniform for my Officer to wear, in the top left corner I get, "An unhandled exception has occured within the LCPDFR. Please see the logfile for more details (Object does not match target type.) I was wondering what the fix is for this? I'm running the DVD copy of GTAIV and it is a legit copy. I tried uninstalling and reinstalling scripthooks and LCPDFR as well. Thanks for the help!

 

BEGIN *SIGNED* LCPD First Response Issue Report
Diagnostics Tool Version: 0.4.3
Operating system: Windows7 HomePremium (6.1.1.0 Build: 7601) Service Pack:Service Pack 1
System RAM (GB): 7.9
CPU cores: 4
NET Framework 4.0 installed: True
Visual C++ 2010 Redistributable installed: True
GTA IV - Installed: True
GTA IV - Install folder: C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV
GTA IV - Version: 1, 0, 7, 0
GTA IV - Asi loader installed: True
GTA IV - Asi loader: DSOUND
GTA IV - Asi loader valid: True
GTA IV - C++ ScriptHook installed: True
GTA IV - C++ ScriptHook valid: True
GTA IV - C++ ScriptHook version: 0, 5, 1, 0
GTA IV - ScriptHookDotNet installed: True
GTA IV - ScriptHookDotNet valid: True
===============BEGIN .NET SCRIPTHOOK LOG===============
2013-08-05 10:49:27 - Initializing ScriptHookDotNet v1.7.1.7 BETA (on GTA IV version 1.0.7.0 with C++ Hook version 0.5.1)
2013-08-05 10:49:27 - Error during GetPhoneNumber (Phone checks will be disabled):
                      System.Exception: Accessing Globals failed! Invalid Memory Address!
                         at unmanaged.MemoryAccess.GetGlobalAddress(Int32 index)
                         at unmanaged.MemoryAccess.GetPhoneNumber()
                         at GTA.NetHook.CheckPhone()
2013-08-05 10:49:27 - Direct3D device created!

2013-08-05 10:49:27 - SEARCHING FOR SCRIPTS...
2013-08-05 10:49:27 - Loading scripts in Assembly 'scripts\FirstResponse.net.dll' ...
2013-08-05 10:49:27 -  ...found script 'FirstResponse.Main.EmergencyLights'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.Main.Start'!
2013-08-05 10:49:27 -  ...found script 'CSharp.Engine.Core'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.Debugging'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.DeletionList'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.Hardcore'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.TextDraw'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCMD.Main'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCMD.Functions'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCPD.Carboot'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCPD.Disarm'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCPD.Frisk'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCPD.PullOver'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCPD.Actions'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCPD.Debug'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCPD.Flashlight'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCPD.Functions'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCPD.Partner'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCPD.inputSimulator'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCPD.Start'!
2013-08-05 10:49:27 -  ...found script 'FirstResponse.LCPD.Various'!
2013-08-05 10:49:27 - Loading scripts in Assembly 'scripts\TrafficFlow.net.dll' ...
2013-08-05 10:49:27 -  ...found script 'TrafficFlow.Taxi'!
2013-08-05 10:49:27 - DONE! 22 valid scripts found!

2013-08-05 10:49:27 - STARTING SCRIPTS...
2013-08-05 10:49:27 - INFO: Phone number checks are not available!
2013-08-05 10:49:27 -  ...successfully started script 'TrafficFlow.Taxi'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCPD.Various'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCPD.Start'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCPD.inputSimulator'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCPD.Partner'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCPD.Functions'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCPD.Flashlight'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCPD.Debug'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCPD.Actions'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCPD.PullOver'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCPD.Frisk'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCPD.Disarm'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCPD.Carboot'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCMD.Functions'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.LCMD.Main'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.TextDraw'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.Hardcore'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.DeletionList'!
2013-08-05 10:49:27 -  ...successfully started script 'FirstResponse.Debugging'!
2013-08-05 10:49:28 -  ...successfully started script 'CSharp.Engine.Core'!
2013-08-05 10:49:28 -  ...successfully started script 'FirstResponse.Main.Start'!
2013-08-05 10:49:28 -  ...successfully started script 'FirstResponse.Main.EmergencyLights'!

===============END .NET SCRIPTHOOK LOG===============
End of *SIGNED* LCPD First Response Issue Report
Digital signature: BLYrbMretfNXeId2sbxRCA==
 



#2
yankeesfan8998

yankeesfan8998

    Newbie

  • Members
  • 3 posts

Posted 05 August 2013 - 07:33 PM

i haven the same thing

 



#3
Matosh

Matosh

    No pain, no gain

  • Members
  • PipPipPipPipPipPip
  • 724 posts
  • LocationCroatia

Posted 05 August 2013 - 08:48 PM

You can try to download then extract ScriptHook.dll and ScriptHookDotNet.asi to your GTA IV folder and click replace if you are asked to do it.

 

http://www.hazardx.c...ils.php?file=83


Edited by Matosh, 05 August 2013 - 09:06 PM.


#4
AirCanada190

AirCanada190

    Newbie

  • Members
  • 3 posts

Posted 06 August 2013 - 12:50 AM

You can try to download then extract ScriptHook.dll and ScriptHookDotNet.asi to your GTA IV folder and click replace if you are asked to do it.

 

http://www.hazardx.c...ils.php?file=83

 

Thanks for the reply, I stil get the error message though. I also noticed I have all of these in my directory. Seems like an awful lot of the same thing?

 

ScriptHook.dll

ScriptHook

ScriptHookDotNet.asi

ScriptHookDotNet.dll

ScriptHookDotNet



#5
Matosh

Matosh

    No pain, no gain

  • Members
  • PipPipPipPipPipPip
  • 724 posts
  • LocationCroatia

Posted 06 August 2013 - 05:55 AM   Best Answer

Delete those and extract scripthook files as I said in my previous post.


Edited by Matosh, 06 August 2013 - 03:26 PM.


#6
AirCanada190

AirCanada190

    Newbie

  • Members
  • 3 posts

Posted 06 August 2013 - 02:59 PM

Perfect! All fixed! Thanks for your help Matosh!



#7
Matosh

Matosh

    No pain, no gain

  • Members
  • PipPipPipPipPipPip
  • 724 posts
  • LocationCroatia

Posted 06 August 2013 - 03:28 PM

No problem, enjoy! :smile:






Warning!
Guest, the last post of this topic was over 30 days ago and you should not bump this topic, unless you have a very valid reason for doing so.
Bumping a topic for an invalid reason may be a community guidelines violation and your account may be sanctioned.



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users