Jump to content
Thot Patrol

I need help installing a custom siren for Siren Mastery.

Recommended Posts

Hello! I have been trying to install a custom siren for siren mastery but I have had no luck doing so. Siren mastery crashes upon loading it I presume it has something to do with the xml file. Here is it:

<?xml version="1.0" encoding="utf-8"?>
<SirenControl>
<VehicleSirenSetup>
<VehicleModel>Police</VehicleModel>
<VehicleModel>Police2</VehicleModel>
<VehicleModel>Police3</VehicleModel>
<VehicleModel>Police4</VehicleModel>
<Sirens>
<Siren1 SirenType="Primary">Main</Siren1>
<Siren2 SirenType="Secondary">POLICEMAIN2</Siren2>
<Siren3 SirenType="Secondary">RamHiLo1</Siren3>
<Siren4 SirenType="Secondary">RamHiLo2</Siren4>
<Siren5 SirenType="Secondary">RamHiLo3</Siren5>
<Siren6 SirenType="Secondary">RamHiLo4</Siren6>
<Siren7 SirenType="Secondary">RamHiLo5</Siren7>
<Siren10 SirenType="Horn">horn</Siren10>
</Sirens>
</VehicleSirenSetup>
</SirenControl>
Use This One
<?xml version="1.0" encoding="utf-8"?>
<SirenControl>
<VehicleSirenSetup>
<VehicleModel>POLICE</VehicleModel>
<VehicleModel>POLICE2</VehicleModel>
<VehicleModel>POLICE3</VehicleModel>
<VehicleModel>POLICE4</VehicleModel>
<Sirens>
<Siren1 SirenType="Primary">Main</Siren1>
<Siren2 SirenType="Secondary">POLICEMAIN2</Siren2>
<Siren3 SirenType="Secondary">RamHiLo1</Siren3>
<Siren4 SirenType="Secondary">RamHiLo2</Siren4>
<Siren5 SirenType="Secondary">RamHiLo3</Siren5>
<Siren6 SirenType="Secondary">RamHiLo4</Siren6>
<Siren7 SirenType="Secondary">RamHiLo5</Siren7>
<Siren10 SirenType="Horn">horn</Siren10>
</Sirens>
</VehicleSirenSetup>
</SirenControl>

And here is the link to the mod:

I have been trying to get support from the mod author but I have had no luck. Please help if you need any additional info I will supply it.

Share this post


Link to post
Share on other sites

There shouldn't be a <SirenControl> line, it should be <SirenMastery> instead. Try this.

<?xml version="1.0" encoding="utf-8"?>
<SirenMastery>
<VehicleSirenSetup>
<VehicleModel>Police</VehicleModel>
<VehicleModel>Police2</VehicleModel>
<VehicleModel>Police3</VehicleModel>
<VehicleModel>Police4</VehicleModel>
<Sirens>
<Siren1 SirenType="Primary">Main</Siren1>
<Siren2 SirenType="Secondary">POLICEMAIN2</Siren2>
<Siren3 SirenType="Secondary">RamHiLo1</Siren3>
<Siren4 SirenType="Secondary">RamHiLo2</Siren4>
<Siren5 SirenType="Secondary">RamHiLo3</Siren5>
<Siren6 SirenType="Secondary">RamHiLo4</Siren6>
<Siren7 SirenType="Secondary">RamHiLo5</Siren7>
<Siren10 SirenType="Horn">horn</Siren10>
</Sirens>
</VehicleSirenSetup>
</SirenMastery>

Thot Patrol likes this

Share this post


Link to post
Share on other sites
5 minutes ago, Illusionyary said:

There shouldn't be a <SirenControl> line, it should be <SirenMastery> instead. Try this.

<?xml version="1.0" encoding="utf-8"?>
<SirenMastery>
<VehicleSirenSetup>
<VehicleModel>Police</VehicleModel>
<VehicleModel>Police2</VehicleModel>
<VehicleModel>Police3</VehicleModel>
<VehicleModel>Police4</VehicleModel>
<Sirens>
<Siren1 SirenType="Primary">Main</Siren1>
<Siren2 SirenType="Secondary">POLICEMAIN2</Siren2>
<Siren3 SirenType="Secondary">RamHiLo1</Siren3>
<Siren4 SirenType="Secondary">RamHiLo2</Siren4>
<Siren5 SirenType="Secondary">RamHiLo3</Siren5>
<Siren6 SirenType="Secondary">RamHiLo4</Siren6>
<Siren7 SirenType="Secondary">RamHiLo5</Siren7>
<Siren10 SirenType="Horn">horn</Siren10>
</Sirens>
</VehicleSirenSetup>
</SirenMastery>

Will do! I will get back to you in a second

9 minutes ago, Illusionyary said:

There shouldn't be a <SirenControl> line, it should be <SirenMastery> instead. Try this.

<?xml version="1.0" encoding="utf-8"?>
<SirenMastery>
<VehicleSirenSetup>
<VehicleModel>Police</VehicleModel>
<VehicleModel>Police2</VehicleModel>
<VehicleModel>Police3</VehicleModel>
<VehicleModel>Police4</VehicleModel>
<Sirens>
<Siren1 SirenType="Primary">Main</Siren1>
<Siren2 SirenType="Secondary">POLICEMAIN2</Siren2>
<Siren3 SirenType="Secondary">RamHiLo1</Siren3>
<Siren4 SirenType="Secondary">RamHiLo2</Siren4>
<Siren5 SirenType="Secondary">RamHiLo3</Siren5>
<Siren6 SirenType="Secondary">RamHiLo4</Siren6>
<Siren7 SirenType="Secondary">RamHiLo5</Siren7>
<Siren10 SirenType="Horn">horn</Siren10>
</Sirens>
</VehicleSirenSetup>
</SirenMastery>

Still Crashes

Share this post


Link to post
Share on other sites
8 minutes ago, ACop said:

Still Crashes

Hmm... that was the only obvious thing I could see wrong with the xml file. Are you sure it's SirenMastery? Maybe you should contact Albo.

Share this post


Link to post
Share on other sites
4 minutes ago, Illusionyary said:

Hmm... that was the only obvious thing I could see wrong with the xml file. Are you sure it's SirenMastery? Maybe you should contact Albo.

I try to load it and it crashes. I presume its siren mastery

Share this post


Link to post
Share on other sites
5 minutes ago, ACop said:

I try to load it and it crashes. I presume its siren mastery

What other mods are you using? I've never had any issues with SirenMastery, but I've got the first version before it was updated.

Share this post


Link to post
Share on other sites

 

4 minutes ago, Illusionyary said:

What other mods are you using? I've never had any issues with SirenMastery, but I've got the first version before it was updated.

agency callouts computer plus, herocop code 3 callouts, assorted callouts, panic button really all I use is an enb a modded crown vic and siren callouts

Share this post


Link to post
Share on other sites
6 minutes ago, ACop said:

agency callouts computer plus, herocop code 3 callouts, assorted callouts, panic button really all I use is an enb a modded crown vic and siren callouts

So quite a few lol, I don't really know anything about any of those so... does the game work without SirenMastery? If it does then you know it's SirenMastery that's causing it.

Share this post


Link to post
Share on other sites

Yes it does, the game doesn't crash just the plug in

11 minutes ago, Illusionyary said:

So quite a few lol, I don't really know anything about any of those so... does the game work without SirenMastery? If it does then you know it's SirenMastery that's causing it.

Thanks for help I will contact albo.

Share this post


Link to post
Share on other sites
16 hours ago, ACop said:

Yes it does, the game doesn't crash just the plug in

Thanks for help I will contact albo.

try using albos troubleshooter. itl check to see if everything is up to date and installed right

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×