Jump to content

Psssst. We thought it'd be fun to share the winter-defying warmth of our meltingly cute snowman, so we stuck him on a t-shirt!

Want one? You can order this limited edition shirt now at Spreadshirt (US), or Redbubble

Ninja--Squirrels

Why do none of my mods work for GTA 4?

Recommended Posts

I have tried every LCPDFR Possible, the native trainer, and a couple other mods. I can't seem to use any of them. I am pretty sure I am installing them right, especially LCPDFR since it installs for me and when I got to enable it (ALT + P) It just makes my screen a little more blury! Help Me Please!!

Share this post


Link to post
Share on other sites

You need to post an error log. Also, have you installed patch 1.0.0.7 for GTA IV?

Share this post


Link to post
Share on other sites

Why you posted 3 topics :/

And in three different forums....

@Thread

The blurry screen is built in to GTA IV, just press P again. We recommend changing the keybinding for "Definition" in GTA's settings.

All mods should be installed to the main GTA IV folder, unless they have .net.dll in their name, then they should go into a folder called "scripts," which should be in your main folder.

Share this post


Link to post
Share on other sites

I'm sorry for posting 3 of them, I was just trying to get the help as soon as I could... Where do I get the error log from, and I do believe I might have installed that patch... Sorry for being soo, Noobish haha

Share this post


Link to post
Share on other sites

I don't have that file, The only one I can find for the LCPDFR is a configuration file:

'// G17 Media

'// LCPD First Response

'// GTAIV

'

'// ---------------------------------------------------

'// LCPDFR CONFIGURATION SETTINGS

'// - V6 (June 2011)

'// - Made by The G17 Media Team

'// - © Copyright 2009-2011, G17 Media

'// ---------------------------------------------------

[General]

ChanceCrimeIsComittedMultiplier = 350

DelayBetweenCalloutsMaxSeconds = 30

DelayBetweenCalloutsMinSeconds = 180

[OTHER]

Language = en-US

UNITNUMBER = 76

CALLOUTS = 1

HARDCORE = False

[XGWEBSERVICES]

Services|Enabled = True

Share this post


Link to post
Share on other sites

Make sure that file is in a folder called "scripts." If it isn't, reinstall the mod. Select all the check boxes EXCEPT for xlive.dll.

Do us a favor and run this, please.

If you don't have any working mods, make sure all .asi files are in your main GTA IV folder.

Edit: Also, please read this. Please ensure you are using .95 RC 1.

Edited by Iconography

Share this post


Link to post
Share on other sites

A Problem caused the Diagnostic program to stop working, But I was able to sneak a peak at it and everything had a check mark next to it except for "ASI LOADER- NOT FOUND" I suppose I should start a hunt for any out of place .asi Files?

Share this post


Link to post
Share on other sites

Install 0.95 RC 1, run the installer as an admin, and make sure you select dsound.dll. That is the asi loader. It sounds like you are missing an asi loader, causing every script mod to fail.

Make sure you have this and this as well. Oh, and run the diagnostic log as an administrator.

Edited by Iconography

Share this post


Link to post
Share on other sites

I ran the test again.

Here are the results:

BEGIN *SIGNED* LCPD First Response Issue Report

Diagnostics Tool Version: 0.4.3

Operating system: Windows7 HomePremium (6.1.1.0 Build: 7601) Service Pack:Service Pack 1

System RAM (GB): 3.75

CPU cores: 2

NET Framework 4.0 installed: True

Visual C++ 2010 Redistributable installed: True

GTA IV - Installed: True

GTA IV - Install folder: C:Program Files (x86)Rockstar GamesGrand Theft Auto IV

GTA IV - Version: 1, 0, 4, 0

GTA IV - Asi loader installed: False

GTA IV - Asi loader:

GTA IV - Asi loader valid: False

GTA IV - C++ ScriptHook installed: True

GTA IV - C++ ScriptHook valid: True

GTA IV - C++ ScriptHook version: 0, 5, 1, 0

GTA IV - ScriptHookDotNet installed: True

GTA IV - ScriptHookDotNet valid: True

End of *SIGNED* LCPD First Response Issue Report

Digital signature: kmQ30KApdp220WBNTUfKJQ==

I'm going to get the loader and make sure I have the other two files... I'll be back with you in a few!

Share this post


Link to post
Share on other sites

I'm going to get the loader and make sure I have the other two files... I'll be back with you in a few!

Patch GTA IV to 1.0.7.0 as well.

Share this post


Link to post
Share on other sites

After all of that. Updates and all. I got an aplication error when I tried starting it up again.

"Exception EFCreateError in Module DSOUND.dll at 000116C5. Cannot create file "C:Program Files (x86)Rockstar Games Grand Theft Auto IVasilog.txt". Access is denied." Then another error comes up saying "The applicatiopn was unable to start correctly (0xc0000142). Click OK to close the application."

What do I do?!?

Share this post


Link to post
Share on other sites

Run as administrator. As a general rule, it's usually a good idea to run every program (games, vent, xfire, etc.) as an administrator.

Share this post


Link to post
Share on other sites

I'm sorry for posting 3 of them, I was just trying to get the help as soon as I could... Where do I get the error log from, and I do believe I might have installed that patch... Sorry for being soo, Noobish haha

I can understand this, But posting multiple times on purpose Wont really get you help any faster, And as stated By gnat326, Since your getting a access is denied error, Run your game as administrator from the game directory.

Share this post


Link to post
Share on other sites

Thanks for the help,

I can understand this, But posting multiple times on purpose Wont really get you help any faster,

I'll keep this in mind for next time I am on here.

The game is working now, thanks to everyone for the tips and help.

Share this post


Link to post
Share on other sites

Hello, I have the same issue, but when I update and everything stated previously, my GTA:IV crashes and wont start at all. Help me please...

I have this mod working on GTA:SA, but would love it to work on my GTA:IV - I have never had any mods working on this, plus I cannot get my ASI Loader update to work either. Will this work after the update to 1.0.7.0?

Share this post


Link to post
Share on other sites

Please do not bump or hijack old threads. Create a new topic in the appropriate section.

GTA SA mods will not work on IV

Edited by Tom H

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×